summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAntonin Kral <a.kral@bobek.cz>2010-01-31 08:32:52 +0100
committerAntonin Kral <a.kral@bobek.cz>2010-01-31 08:32:52 +0100
commit4eefaf421bfeddf040d96a3dafb12e09673423d7 (patch)
treecb2e5ccc7f98158894f977ff131949da36673591 /debian
downloadmongodb-4eefaf421bfeddf040d96a3dafb12e09673423d7.tar.gz
Imported Upstream version 1.3.1
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control29
-rw-r--r--debian/copyright23
-rw-r--r--debian/dirs3
-rw-r--r--debian/files1
-rw-r--r--debian/init.d294
-rw-r--r--debian/mongo.162
-rw-r--r--debian/mongodump.136
-rw-r--r--debian/mongoexport.151
-rw-r--r--debian/mongofiles.152
-rw-r--r--debian/mongoimportjson.145
-rw-r--r--debian/mongorestore.136
-rw-r--r--debian/mongos.139
-rw-r--r--debian/postinst55
-rw-r--r--debian/postrm39
-rw-r--r--debian/preinst37
-rw-r--r--debian/prerm41
-rw-r--r--debian/rules95
-rw-r--r--debian/ubuntu/mongodb.conf13
-rw-r--r--debian/ubuntu/mongodb_settings.conf6
-rw-r--r--debian/watch10
22 files changed, 974 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..3c6963c
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+mongodb (1.3.1) unstable; urgency=low
+
+ * Initial release
+
+ -- Kristina Chodorow <kristina@10gen.com> Tue, 07 Apr 2009 10:18:58 -0400
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..6616a8b
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,29 @@
+Source: mongodb
+Section: devel
+Priority: optional
+Maintainer: Kristina Chodorow <kristina@10gen.com>
+Build-Depends: debhelper (>= 7), libboost-dev, libpcre3, libpcre3-dev, scons, xulrunner-1.9-dev | xulrunner-1.9.1-dev, libboost-thread-dev, libboost-filesystem-dev, libboost-program-options-dev, libboost-date-time-dev
+Standards-Version: 3.8.0
+Homepage: http://www.mongodb.org
+
+Package: mongodb
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, xulrunner-1.9-dev
+Description: An object/document-oriented database
+ MongoDB is a high-performance, open source, schema-free
+ document-oriented data store that's easy to deploy, manage
+ and use. It's network accessible, written in C++ and offers
+ the following features :
+ .
+ * Collection oriented storage - easy storage of object-
+ style data
+ * Full index support, including on inner objects
+ * Query profiling
+ * Replication and fail-over support
+ * Efficient storage of binary data including large
+ objects (e.g. videos)
+ * Auto-sharding for cloud-level scalability (Q209)
+ .
+ High performance, scalability, and reasonable depth of
+ functionality are the goals for the project.
+
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..478c6f9
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,23 @@
+This package was debianized by Kristina Chodorow <kristina@10gen.com> on
+Tue, 07 Apr 2009 10:18:58 -0400.
+
+It was downloaded from http://www.mongodb.org
+
+Upstream Authors:
+
+ Eliot Horowitz
+ Dwight Merriman
+ Aaron Staple
+ Michael Dirolf
+ Kristina Chodorow
+
+Copyright:
+
+ 2009 10gen
+
+License:
+
+ AGPL
+
+The Debian packaging is (C) 2009, Kristina Chodorow <kristina@10gen.com> and
+is licensed under the AGPL, see `http://www.fsf.org/licensing/licenses/agpl-3.0.html'.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..a7b6e78
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,3 @@
+usr/bin
+usr/sbin
+var/lib/mongodb
diff --git a/debian/files b/debian/files
new file mode 100644
index 0000000..2e28959
--- /dev/null
+++ b/debian/files
@@ -0,0 +1 @@
+mongodb_0.9.7_amd64.deb devel optional
diff --git a/debian/init.d b/debian/init.d
new file mode 100644
index 0000000..b4eedf0
--- /dev/null
+++ b/debian/init.d
@@ -0,0 +1,294 @@
+#!/bin/sh
+#
+# init.d script with LSB support.
+#
+# Copyright (c) 2007 Javier Fernandez-Sanguino <jfs@debian.org>
+#
+# This is free software; you may redistribute it and/or modify
+# it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2,
+# or (at your option) any later version.
+#
+# This is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License with
+# the Debian operating system, in /usr/share/common-licenses/GPL; if
+# not, write to the Free Software Foundation, Inc., 59 Temple Place,
+# Suite 330, Boston, MA 02111-1307 USA
+#
+### BEGIN INIT INFO
+# Provides: mongodb
+# Required-Start: $network $local_fs
+# Required-Stop:
+# Should-Start: $named
+# Should-Stop:
+# Default-Start: 2 3 4 5
+# Default-Stop: 0 1 6
+# Short-Description: An object/document-oriented database
+# Description: MongoDB is a high-performance, open source, schema-free
+# document-oriented data store that's easy to deploy, manage
+# and use. It's network accessible, written in C++ and offers
+# the following features:
+#
+# * Collection oriented storage - easy storage of object-
+# style data
+# * Full index support, including on inner objects
+# * Query profiling
+# * Replication and fail-over support
+# * Efficient storage of binary data including large
+# objects (e.g. videos)
+# * Auto-sharding for cloud-level scalability (Q209)
+#
+# High performance, scalability, and reasonable depth of
+# functionality are the goals for the project.
+### END INIT INFO
+
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+DAEMON=/usr/bin/mongod
+DATA=/var/lib/mongodb
+NAME=MongoDB
+DESC=database
+
+if test ! -x $DAEMON; then
+ echo "Could not find $DAEMON"
+ exit 0
+fi
+
+if test ! -x $DATA; then
+ mkdir $DATA || exit 0
+fi
+
+. /lib/lsb/init-functions
+
+LOGDIR=/var/log/mongodb
+PIDFILE=/var/run/$NAME.pid
+DIETIME=10 # Time to wait for the server to die, in seconds
+ # If this value is set too low you might not
+ # let some servers to die gracefully and
+ # 'restart' will not work
+
+LOGFILE=$LOGDIR/$NAME.log # Server logfile
+DAEMON_OPTS="--dbpath $DATA --logpath $LOGFILE run"
+
+
+# Include mongodb defaults if available
+if [ -f /etc/default/$NAME ] ; then
+ . /etc/default/$NAME
+fi
+
+DAEMONUSER=mongodb
+# Check that the user exists (if we set a user)
+# Does the user exist?
+if [ -n "$DAEMONUSER" ] ; then
+ if getent passwd | grep -q "^$DAEMONUSER:"; then
+ # Obtain the uid and gid
+ DAEMONUID=`getent passwd |grep "^$DAEMONUSER:" | awk -F : '{print $3}'`
+ DAEMONGID=`getent passwd |grep "^$DAEMONUSER:" | awk -F : '{print $4}'`
+ else
+ log_failure_msg "The user $DAEMONUSER, required to run $NAME does not exist."
+ exit 1
+ fi
+fi
+
+set -e
+
+
+running_pid() {
+# Check if a given process pid's cmdline matches a given name
+ pid=$1
+ name=$2
+ [ -z "$pid" ] && return 1
+ [ ! -d /proc/$pid ] && return 1
+ cmd=`cat /proc/$pid/cmdline | tr "\000" "\n"|head -n 1 |cut -d : -f 1`
+ # Is this the expected server
+ [ "$cmd" != "$name" ] && return 1
+ return 0
+}
+
+running() {
+# Check if the process is running looking at /proc
+# (works for all users)
+
+ # No pidfile, probably no daemon present
+ [ ! -f "$PIDFILE" ] && return 1
+ pid=`cat $PIDFILE`
+ running_pid $pid $DAEMON || return 1
+ return 0
+}
+
+start_server() {
+# Start the process using the wrapper
+ if [ -z "$DAEMONUSER" ] ; then
+ start-stop-daemon --background --start --quiet --pidfile $PIDFILE \
+ --make-pidfile --exec $DAEMON -- $DAEMON_OPTS
+ errcode=$?
+ else
+# if we are using a daemonuser then change the user id
+ start-stop-daemon --background --start --quiet --pidfile $PIDFILE \
+ --make-pidfile --chuid $DAEMONUSER \
+ --exec $DAEMON -- $DAEMON_OPTS
+ errcode=$?
+ fi
+ return $errcode
+}
+
+stop_server() {
+# Stop the process using the wrapper
+ if [ -z "$DAEMONUSER" ] ; then
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE
+ rm $PIDFILE
+ errcode=$?
+ else
+# if we are using a daemonuser then look for process that match
+ start-stop-daemon --stop --quiet --pidfile $PIDFILE \
+ --user $DAEMONUSER \
+ --exec $DAEMON
+ errcode=$?
+ fi
+
+ return $errcode
+}
+
+reload_server() {
+ [ ! -f "$PIDFILE" ] && return 1
+ pid=pidofproc $PIDFILE # This is the daemon's pid
+ # Send a SIGHUP
+ kill -USR1 $pid
+ return $?
+}
+
+force_stop() {
+# Force the process to die killing it manually
+ [ ! -e "$PIDFILE" ] && return
+ if running ; then
+ kill -15 $pid
+ # Is it really dead?
+ sleep "$DIETIME"s
+ if running ; then
+ kill -9 $pid
+ sleep "$DIETIME"s
+ if running ; then
+ echo "Cannot kill $NAME (pid=$pid)!"
+ exit 1
+ fi
+ fi
+ fi
+ rm -f $PIDFILE
+}
+
+
+case "$1" in
+ start)
+ log_daemon_msg "Starting $DESC $NAME"
+ # Check if it's running first
+ if running ; then
+ log_progress_msg "apparently already running"
+ log_end_msg 0
+ exit 0
+ fi
+ if start_server ; then
+ # NOTE: Some servers might die some time after they start,
+ # this code will detect this issue if STARTTIME is set
+ # to a reasonable value
+ [ -n "$STARTTIME" ] && sleep $STARTTIME # Wait some time
+ if running ; then
+ # It's ok, the server started and is running
+ log_end_msg 0
+ else
+ # It is not running after we did start
+ log_end_msg 1
+ fi
+ else
+ # Either we could not start it
+ log_end_msg 1
+ fi
+ ;;
+ stop)
+ log_daemon_msg "Stopping $DESC" "$NAME"
+ if running ; then
+ # Only stop the server if we see it running
+ errcode=0
+ stop_server || errcode=$?
+ log_end_msg $errcode
+ else
+ # If it's not running don't do anything
+ log_progress_msg "apparently not running"
+ log_end_msg 0
+ exit 0
+ fi
+ ;;
+ force-stop)
+ # First try to stop gracefully the program
+ $0 stop
+ if running; then
+ # If it's still running try to kill it more forcefully
+ log_daemon_msg "Stopping (force) $DESC" "$NAME"
+ errcode=0
+ force_stop || errcode=$?
+ log_end_msg $errcode
+ fi
+ ;;
+ restart|force-reload)
+ log_daemon_msg "Restarting $DESC" "$NAME"
+ errcode=0
+ stop_server || errcode=$?
+ # Wait some sensible amount, some server need this
+ [ -n "$DIETIME" ] && sleep $DIETIME
+ start_server || errcode=$?
+ [ -n "$STARTTIME" ] && sleep $STARTTIME
+ running || errcode=$?
+ log_end_msg $errcode
+ ;;
+ status)
+
+ log_daemon_msg "Checking status of $DESC" "$NAME"
+ if running ; then
+ log_progress_msg "running"
+ log_end_msg 0
+ else
+ log_progress_msg "apparently not running"
+ log_end_msg 1
+ exit 1
+ fi
+ ;;
+ # Use this if the daemon cannot reload
+ reload)
+ log_warning_msg "Reloading $NAME daemon: not implemented, as the daemon"
+ log_warning_msg "cannot re-read the config file (use restart)."
+ ;;
+ # And this if it cann
+ #reload)
+ #
+ # If the daemon can reload its config files on the fly
+ # for example by sending it SIGHUP, do it here.
+ #
+ # If the daemon responds to changes in its config file
+ # directly anyway, make this a do-nothing entry.
+ #
+ # log_daemon_msg "Reloading $DESC configuration files" "$NAME"
+ # if running ; then
+ # reload_server
+ # if ! running ; then
+ # Process died after we tried to reload
+ # log_progress_msg "died on reload"
+ # log_end_msg 1
+ # exit 1
+ # fi
+ # else
+ # log_progress_msg "server is not running"
+ # log_end_msg 1
+ # exit 1
+ # fi
+ #;;
+
+ *)
+ N=/etc/init.d/$NAME
+ echo "Usage: $N {start|stop|force-stop|restart|force-reload|status}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/debian/mongo.1 b/debian/mongo.1
new file mode 100644
index 0000000..2eeb674
--- /dev/null
+++ b/debian/mongo.1
@@ -0,0 +1,62 @@
+.\" Documentation for the MongoDB shell
+.TH MONGO "1" "June 2009" "10gen" "Mongo Database"
+.SH "NAME"
+mongo \- the Mongo command\-line tool
+.SH "SYNOPSIS"
+\fBmongo [\fIOPTIONS\fR] [\fIDB_ADDRESS\fR] [\fIFILE+\fR]\fR
+.SH "DESCRIPTION"
+.PP
+\fBmongo\fR
+is a JavaScript shell (with GNU
+readline
+capabilities). It supports interactive and non\-interactive use. When used interactively, JavaScript can be used to query the database or perform any other function normally available with SpiderMonkey. Database output is displayed in JSON format.
+.PP
+If JavaScript files are specified on the command line, the shell will run non\-interactively, running each one in sequence and then exiting.
+.SH "EXAMPLES"
+.TP
+.B mongo
+start the shell, connecting to the server at localhost:27017 and using the test database
+.TP
+.B mongod foo
+start the shell using the foo database at localhost:27017
+.TP
+.B mongod 192.169.0.5/foo
+start the shell using the foo database at 192.169.0.5:27017
+.TP
+.B mongod 192.169.0.5:9999/foo
+start the shell using the foo database at 192.169.0.5:9999
+.TP
+.B mongod script1.js script2.js script3.js
+run three scripts and exit
+.SH "OPTIONS"
+.TP
+.B \-\-shell
+run the shell after executing files
+.TP
+.B \-\-help
+show usage information
+.TP
+.B \-\-host HOST
+server to connect to (default HOST=localhost)
+.TP
+.B \-\-port PORT
+port to connect to (default PORT=27017)
+.TP
+.B \-\-nodb
+do not connect to mongod
+.TP
+.B \-\-eval SCRIPT
+evaluate JavaScript
+.TP
+.B \-u USERNAME
+specify user to log in as
+.TP
+.B \-pPASSWORD
+specify password of user (notice there is no space)
+.SH "COPYRIGHT"
+.PP
+Copyright 2007\-2009 10gen
+.SH "SEE ALSO"
+For more information, please refer to the MongoDB wiki, available at http://www.mongodb.org.
+.SH "AUTHOR"
+Kristina Chodorow
diff --git a/debian/mongodump.1 b/debian/mongodump.1
new file mode 100644
index 0000000..5cb33ce
--- /dev/null
+++ b/debian/mongodump.1
@@ -0,0 +1,36 @@
+.\" Documentation for the MongoDB dump tool
+.TH MONGODUMP "1" "June 2009" "10gen" "Mongo Database"
+.SH "NAME"
+mongodump \- the Mongo dump tool
+.SH "SYNOPSIS"
+\fBmongodump [\fIOPTIONS\fR]\fR
+.SH "DESCRIPTION"
+.PP
+\fBmongodump\fR
+is a tool to output a binary representation of a database. It is mostly used for doing hot backups of a database.
+.SH "OPTIONS"
+.TP
+.B \-\-help
+show usage information
+.TP
+.B \-h, \-\-host HOST
+server to connect to (default HOST=localhost)
+.TP
+.B \-d, \-\-db DATABASE
+database to use
+.TP
+.B \-c, \-\-c COLLECTION
+collection to use
+.TP
+.B \-o, \-\-out FILE
+output file, if not specified, stdout is used
+.TP
+.B \-\-dbpath PATH
+directly access mongod data files in this path, instead of connecting to a mongod instance
+.SH "COPYRIGHT"
+.PP
+Copyright 2007\-2009 10gen
+.SH "SEE ALSO"
+For more information, please refer to the MongoDB wiki, available at http://www.mongodb.org.
+.SH "AUTHOR"
+Kristina Chodorow
diff --git a/debian/mongoexport.1 b/debian/mongoexport.1
new file mode 100644
index 0000000..1996b36
--- /dev/null
+++ b/debian/mongoexport.1
@@ -0,0 +1,51 @@
+.\" Documentation for the MongoDB shell
+.TH MONGOEXPORT "1" "June 2009" "10gen" "Mongo Database"
+.SH "NAME"
+mongoexport \- the Mongo export tool
+.SH "SYNOPSIS"
+\fBmongoexport [\fIOPTIONS\fR]\fR
+.SH "DESCRIPTION"
+.PP
+\fBmongoexport\fR
+is a tool to export a MongoDB collection to either JSON or CSV. The query can be filtered or a list of fields to output can be given.
+.PP
+If the output is CSV, the fields must be specified in order.
+.SH "EXAMPLES"
+.TP
+.B mongoexport -d test -c test1 --csv -f "name,num"
+export documents from test.test1 in CSV format
+.SH "OPTIONS"
+.TP
+.B \-\-help
+show usage information
+.TP
+.B \-h, \-\-host HOST
+server to connect to (default HOST=localhost)
+.TP
+.B \-d, \-\-db DATABASE
+database to use
+.TP
+.B \-c, \-\-c COLLECTION
+collection to use
+.TP
+.B \-q, \-\-query QUERY
+query filter
+.TP
+.B \-f, \-\-fields FIELDS
+comma\-separated list of field names
+.TP
+.B \-\-csv
+export to CSV instead of JSON
+.TP
+.B \-o, \-\-out FILE
+output file, if not specified, stdout is used
+.TP
+.B \-\-dbpath PATH
+directly access mongod data files in this path, instead of connecting to a mongod instance
+.SH "COPYRIGHT"
+.PP
+Copyright 2007\-2009 10gen
+.SH "SEE ALSO"
+For more information, please refer to the MongoDB wiki, available at http://www.mongodb.org.
+.SH "AUTHOR"
+Kristina Chodorow
diff --git a/debian/mongofiles.1 b/debian/mongofiles.1
new file mode 100644
index 0000000..4d7c0c5
--- /dev/null
+++ b/debian/mongofiles.1
@@ -0,0 +1,52 @@
+.\" Documentation for the MongoDB dump tool
+.TH MONGOFILES "1" "June 2009" "10gen" "Mongo Database"
+.SH "NAME"
+mongofiles \- a simple GridFS interface
+.SH "SYNOPSIS"
+\fBmongofiles [\fIOPTIONS\fR]\fR
+.SH "DESCRIPTION"
+.PP
+\fBmongofiles\fR
+is used to list, get, and insert files in the database.
+.SH "EXAMPLES"
+.TP
+.B mongofiles list
+lists files in test.fs.files
+.TP
+.B mongofiles put README.txt
+inserts the file README.txt into the collection test.fs.files
+.TP
+.B mongofiles get photo.jpg
+retrieves photo.jpg from test.fs.files and saves it locally
+.SH "OPTIONS"
+.TP
+.B \-\-help
+show usage information
+.TP
+.B \-h, \-\-host HOST
+mongo host to which to connect
+.TP
+.B \-d, \-\-db DB
+database to use (default DB=test)
+.TP
+.B \-c, \-\-collection COLLECTION (default COLLECTION=fs.files)
+collection to use
+.TP
+.B \-\-command [list\||\|search\||\|put\||\|get]
+execute a command
+.TP
+.B \-\-file FILE
+filename for get or put
+.TP
+.B list
+list all files. takes an optional filename. the file has to start with the filename
+.TP
+.B search
+search all files for something that contains the string
+.SH "COPYRIGHT"
+.PP
+Copyright 2007\-2009 10gen
+.SH "SEE ALSO"
+For more information, please refer to the MongoDB wiki, available at http://www.mongodb.org.
+.SH "AUTHOR"
+Kristina Chodorow
diff --git a/debian/mongoimportjson.1 b/debian/mongoimportjson.1
new file mode 100644
index 0000000..5f3f450
--- /dev/null
+++ b/debian/mongoimportjson.1
@@ -0,0 +1,45 @@
+.\" Documentation for the MongoDB shell
+.TH MONGOIMPORTJSON "1" "June 2009" "10gen" "Mongo Database"
+.SH "NAME"
+mongoimportjson \- the Mongo import tool
+.SH "SYNOPSIS"
+\fBmongoimportjson [\fIOPTIONS\fR]\fR
+.SH "DESCRIPTION"
+.PP
+\fBmongoimportjson\fR
+is a tool to import JSON documents into MongoDB. This utility takes a single file that contains one JSON string per line and inserts it. A databaase and collection must be specified.
+.SH "OPTIONS"
+.TP
+.B \-\-help
+show usage information
+.TP
+.B \-h, \-\-host HOST
+server to connect to (default HOST=localhost)
+.TP
+.B \-d, \-\-db DATABASE
+database to use
+.TP
+.B \-c, \-\-c COLLECTION
+collection to use
+.TP
+.B \-\-file FILE
+file from which to import
+.TP
+.B \-\-dbpath PATH
+directly access mongod data files in this path, instead of connecting to a mongod instance
+.TP
+.B \-\-idbefore
+create id index before importing
+.TP
+.B \-\-id
+create id index after importing (recommended)
+.TP
+.B \-\-drop
+drop collection before importing
+.SH "COPYRIGHT"
+.PP
+Copyright 2007\-2009 10gen
+.SH "SEE ALSO"
+For more information, please refer to the MongoDB wiki, available at http://www.mongodb.org.
+.SH "AUTHOR"
+Kristina Chodorow
diff --git a/debian/mongorestore.1 b/debian/mongorestore.1
new file mode 100644
index 0000000..5f207b0
--- /dev/null
+++ b/debian/mongorestore.1
@@ -0,0 +1,36 @@
+.\" Documentation for the MongoDB dump tool
+.TH MONGORESTORE "1" "June 2009" "10gen" "Mongo Database"
+.SH "NAME"
+mongorestore \- the Mongo restoration tool
+.SH "SYNOPSIS"
+\fBmongorestore [\fIOPTIONS\fR]\fR
+.SH "DESCRIPTION"
+.PP
+\fBmongorestore\fR
+is a tool to use the output from mongodump to restore a database.
+.SH "OPTIONS"
+.TP
+.B \-\-help
+show usage information
+.TP
+.B \-h, \-\-host HOST
+server to connect to (default HOST=localhost)
+.TP
+.B \-d, \-\-db DATABASE
+database to use
+.TP
+.B \-c, \-\-c COLLECTION
+collection to use
+.TP
+.B \-\-dir PATH
+directory from which to restore
+.TP
+.B \-\-dbpath PATH
+directly access mongod data files in this path, instead of connecting to a mongod instance
+.SH "COPYRIGHT"
+.PP
+Copyright 2007\-2009 10gen
+.SH "SEE ALSO"
+For more information, please refer to the MongoDB wiki, available at http://www.mongodb.org.
+.SH "AUTHOR"
+Kristina Chodorow
diff --git a/debian/mongos.1 b/debian/mongos.1
new file mode 100644
index 0000000..74d01c6
--- /dev/null
+++ b/debian/mongos.1
@@ -0,0 +1,39 @@
+.\" Documentation for the MongoDB dump tool
+.TH MONGOS "1" "June 2009" "10gen" "Mongo Database"
+.SH "NAME"
+mongos \- the Mongo sharding server
+.SH "SYNOPSIS"
+\fBmongos [\fIOPTIONS\fR]\fR
+.SH "DESCRIPTION"
+.PP
+\fBmongos\fR
+is used to setup, configure, and get information about sharded databases.
+.SH "EXAMPLES"
+.PP
+.B ./mongod --port 9999 --dbpath /data/db/a # first server
+.PP
+.B ./mongod --port 9998 --dbpath /data/db/b # second server
+.PP
+.B ./mongos --configdb localhost:9999 # mongos
+.PP
+starts three servers to set up sharding
+.SH "OPTIONS"
+.TP
+.B \-\-help
+show usage information
+.TP
+.B \-\-port N
+port on which to listen
+.TP
+.B \-\-configdb DATABASE+
+one or more databases to use as the configuration databases
+.TP
+.B \-v+
+verbosity
+.SH "COPYRIGHT"
+.PP
+Copyright 2007\-2009 10gen
+.SH "SEE ALSO"
+For more information, please refer to the MongoDB wiki, available at http://www.mongodb.org.
+.SH "AUTHOR"
+Kristina Chodorow
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..3745b99
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,55 @@
+#!/bin/sh
+# postinst script for mongodb
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ configure)
+ # create a mongodb group and user
+ if ! grep -q mongodb /etc/passwd; then
+ adduser --system mongodb
+ addgroup --system mongodb
+ adduser mongodb mongodb
+ fi
+
+ # create db
+ mkdir -p /var/lib/mongodb
+ chown mongodb:mongodb /var/lib/mongodb
+
+ # create logdir
+ mkdir -p /var/log/mongodb
+ chown mongodb:mongodb /var/log/mongodb
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/postrm b/debian/postrm
new file mode 100644
index 0000000..4bbb708
--- /dev/null
+++ b/debian/postrm
@@ -0,0 +1,39 @@
+#!/bin/sh
+# postrm script for mongodb
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postrm> `remove'
+# * <postrm> `purge'
+# * <old-postrm> `upgrade' <new-version>
+# * <new-postrm> `failed-upgrade' <old-version>
+# * <new-postrm> `abort-install'
+# * <new-postrm> `abort-install' <old-version>
+# * <new-postrm> `abort-upgrade' <old-version>
+# * <disappearer's-postrm> `disappear' <overwriter>
+# <overwriter-version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ purge|remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
+ ;;
+
+ *)
+ echo "postrm called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/preinst b/debian/preinst
new file mode 100644
index 0000000..c2d5362
--- /dev/null
+++ b/debian/preinst
@@ -0,0 +1,37 @@
+#!/bin/sh
+# preinst script for mongodb
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <new-preinst> `install'
+# * <new-preinst> `install' <old-version>
+# * <new-preinst> `upgrade' <old-version>
+# * <old-preinst> `abort-upgrade' <new-version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ install|upgrade)
+ ;;
+
+ abort-upgrade)
+ ;;
+
+ *)
+ echo "preinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/prerm b/debian/prerm
new file mode 100644
index 0000000..9507ade
--- /dev/null
+++ b/debian/prerm
@@ -0,0 +1,41 @@
+#!/bin/sh
+# prerm script for mongodb
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <prerm> `remove'
+# * <old-prerm> `upgrade' <new-version>
+# * <new-prerm> `failed-upgrade' <old-version>
+# * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
+# * <deconfigured's-prerm> `deconfigure' `in-favour'
+# <package-being-installed> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+echo "arg: $1"
+
+case "$1" in
+ remove|upgrade|deconfigure)
+ ;;
+
+ failed-upgrade)
+ ;;
+
+ *)
+ echo "prerm called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/rules b/debian/rules
new file mode 100644
index 0000000..c258723
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,95 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ scons
+ #docbook-to-man debian/mongodb.sgml > mongodb.1
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ scons -c
+ rm -f config.log
+ rm -f mongo
+ rm -f mongod
+ rm -f mongoimportjson
+ rm -f mongoexport
+ rm -f mongorestore
+ rm -f mongodump
+ rm -f mongofiles
+ rm -f .sconsign.dblite
+ rm -f libmongoclient.a
+ rm -rf client/*.o
+ rm -rf tools/*.o
+ rm -rf shell/*.o
+ rm -rf .sconf_temp
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ scons --prefix=$(CURDIR)/debian/mongodb/usr install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+ dh_installinit
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/debian/ubuntu/mongodb.conf b/debian/ubuntu/mongodb.conf
new file mode 100644
index 0000000..90a5e44
--- /dev/null
+++ b/debian/ubuntu/mongodb.conf
@@ -0,0 +1,13 @@
+# Ubuntu upstart file at /etc/init/mongodb.conf
+# Presumes installation of mongodb is in /usr/local/mongodb/
+
+pre-start script
+ mkdir -p /var/lib/mongodb/
+ mkdir -p /var/log/mongodb/
+end script
+
+start on runlevel [345]
+
+exec /usr/local/mongodb/bin/mongod --config /usr/local/mongodb/mongodb_settings.conf
+
+respawn \ No newline at end of file
diff --git a/debian/ubuntu/mongodb_settings.conf b/debian/ubuntu/mongodb_settings.conf
new file mode 100644
index 0000000..dbb83cb
--- /dev/null
+++ b/debian/ubuntu/mongodb_settings.conf
@@ -0,0 +1,6 @@
+# This is an example config file for MongoDB to be located at /usr/local/mongodb/mongodb_settings.conf
+# and used by /etc/init/mongodb.conf
+
+logappend = true
+logpath = /var/log/mongodb/mongod.log
+dbpath = /var/lib/mongodb/ \ No newline at end of file
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..08ce42b
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,10 @@
+# Example watch control file for uscan
+# Rename this file to "watch" and then you can run the "uscan" command
+# to check for upstream updates and more.
+# See uscan(1) for format
+
+# Compulsory line, this is a version 3 file
+version=3
+
+# examine a Webserver directory
+http://downloads.mongodb.org/linux/mongodb-linux-(.*)\.tar\.gz