summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules130
1 files changed, 10 insertions, 120 deletions
diff --git a/debian/rules b/debian/rules
index 61118b1..974a844 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,129 +1,19 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+include /usr/share/cdbs/1/rules/utils.mk
+include /usr/share/cdbs/1/class/scons.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
-# debug and nostrip is effectively equivalent for current version of scons
-# build system in current mongodb revision
-DEB_SCONS_FLAGS :=
+DEB_DH_INSTALLINIT_ARGS = --name=mongodb
+
+DEB_SCONS_OPTIONS :=
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- DEB_SCONS_FLAGS := --d=DEBUGBUILD
+ DEB_SCONS_OPTIONS := --d=DEBUGBUILD
endif
ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- DEB_SCONS_FLAGS := --d=DEBUGBUILD
+ DEB_SCONS_OPTIONS := --d=DEBUGBUILD
endif
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- # Add here commands to configure the package.
-
- touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp
- dh_testdir
-
- # Add here commands to compile the package.
- scons $(DEB_SCONS_FLAGS)
- #docbook-to-man debian/mongodb.sgml > mongodb.1
-
- #run regression tests
- scons --smokedbprefix=$(CURDIR)/debian/tmp-test smoke
- rm -rf $(CURDIR)/debian/tmp-test
-
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- rm -rf $(CURDIR)/debian/tmp
- # FIXME: scons freaks out at the presence of target files
- # under debian/tmp.
- scons -c
- rm -f config.log
- rm -f mongo
- rm -f mongod
- rm -f mongoimportjson
- rm -f mongoexport
- rm -f mongorestore
- rm -f mongodump
- rm -f mongofiles
- rm -f .sconsign.dblite
- rm -f libmongoclient.a
- rm -rf client/*.o
- rm -rf tools/*.o
- rm -rf shell/*.o
- rm -rf .sconf_temp
- rm -f buildscripts/*.pyc
- rm -f *.pyc
- rm -f buildinfo.cpp
- rm -rf debian/tmp-test
- rm -f debian/mongodb.upstart
- dh_clean debian/files
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
-
- scons --prefix=$(CURDIR)/debian/tmp/usr --full install
-
- mkdir -p $(CURDIR)/debian/tmp/usr/share/lintian/overrides/
- install -m 644 $(CURDIR)/debian/mongodb-server.lintian \
- $(CURDIR)/debian/tmp/usr/share/lintian/overrides/mongodb-server
- install -m 644 $(CURDIR)/debian/mongodb-clients.lintian \
- $(CURDIR)/debian/tmp/usr/share/lintian/overrides/mongodb-clients
-
- mkdir -p $(CURDIR)/debian/tmp/etc
- install -m 644 $(CURDIR)/debian/mongodb.conf \
- $(CURDIR)/debian/tmp/etc/mongodb.conf
-
- mkdir -p $(CURDIR)/debian/tmp/usr/share/man/man1
- install -m 644 $(CURDIR)/debian/*.1 \
- $(CURDIR)/debian/tmp/usr/share/man/man1
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
- dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
- dh_installinit -pmongodb-server --name=mongodb
-# dh_installinfo
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+DEB_SCONS_INSTALL_OPTIONS += --prefix=$(CURDIR)/debian/tmp/usr --full
+DEB_SCONS_CHECK_TARGET = --smokedbprefix=$(CURDIR)/debian/tmp-test smoke
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure