summaryrefslogtreecommitdiff
path: root/debian/patches/versioned_symbols.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/versioned_symbols.patch')
-rw-r--r--debian/patches/versioned_symbols.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/patches/versioned_symbols.patch b/debian/patches/versioned_symbols.patch
new file mode 100644
index 0000000..720f3d7
--- /dev/null
+++ b/debian/patches/versioned_symbols.patch
@@ -0,0 +1,25 @@
+Author: Nicholas Bamber <nicholas@periapt.co.uk>
+Bug: http://bugs.mysql.com/bug.php?id=64386
+Debian-Bug: http://bugs.debian.org/660686
+Subject: versioned symbols got dropped from the build
+Last-Update: 2012-06-01
+--- a/libmysql/CMakeLists.txt
++++ b/libmysql/CMakeLists.txt
+@@ -136,6 +136,8 @@
+
+ )
+
++CONFIGURE_FILE(libmysql.ver.in ${CMAKE_BINARY_DIR}/libmysql/libmysql.ver)
++
+ SET(CLIENT_SOURCES
+ get_password.c
+ libmysql.c
+@@ -209,7 +211,7 @@
+ SET(libmysql_link_flags)
+ ENDIF()
+ SET_TARGET_PROPERTIES(libmysql PROPERTIES LINK_FLAGS
+- "${libmysql_link_flags} ${LINK_FLAG_NO_UNDEFINED}")
++ "${libmysql_link_flags} ${LINK_FLAG_NO_UNDEFINED} -Wl,--version-script=libmysql.ver")
+ ENDIF()
+ # clean direct output needs to be set several targets have the same name
+ #(mysqlclient in this case)