summaryrefslogtreecommitdiff
path: root/debian/patches/libedit.patch
diff options
context:
space:
mode:
authorpetere <petere@0070b5ef-2f16-0410-befa-9a02bd1d6ddb>2008-06-15 16:32:21 +0000
committerpetere <petere@0070b5ef-2f16-0410-befa-9a02bd1d6ddb>2008-06-15 16:32:21 +0000
commitaa773a8fbf37ac3a6a67a870c9a69ac941325bfe (patch)
treecf1cf914f266ac3a32333e31f07e06d199548fa7 /debian/patches/libedit.patch
parentbf86f547eb9ee3658e9dec3e0d64aaaadf6244ca (diff)
downloadntp-aa773a8fbf37ac3a6a67a870c9a69ac941325bfe.tar.gz
* Use libedit instead of libreadline, added libedit.patch (closes: #448408)
* While updating autotools.patch, added description how it is generated (closes: #446756) git-svn-id: svn://svn.debian.org/pkg-ntp/ntp/trunk@221 0070b5ef-2f16-0410-befa-9a02bd1d6ddb
Diffstat (limited to 'debian/patches/libedit.patch')
-rw-r--r--debian/patches/libedit.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/debian/patches/libedit.patch b/debian/patches/libedit.patch
new file mode 100644
index 0000000..544ce52
--- /dev/null
+++ b/debian/patches/libedit.patch
@@ -0,0 +1,41 @@
+fixes to be able to use libedit instead of readline; see also bug #448408
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -334,8 +334,8 @@ AC_CHECK_LIB(md5, MD5Init, ,
+ AC_CHECK_LIB(md, MD5Init))
+ AC_CHECK_FUNCS(MD5Init)
+ dnl HMS: What a hack...
+-AC_CHECK_HEADERS(readline/history.h readline/readline.h)
+-case "$ac_cv_header_readline_history_h$ac_cv_header_readline_readline_h" in
++AC_CHECK_HEADERS(editline/history.h editline/readline.h)
++case "$ac_cv_header_editline_history_h$ac_cv_header_editline_readline_h" in
+ *no*) ;;
+ *) save_LIBS=$LIBS
+ LIBS=
+--- a/ntpdc/ntpdc.c
++++ b/ntpdc/ntpdc.c
+@@ -27,8 +27,8 @@
+ #endif /* SYS_WINNT */
+
+ #if defined(HAVE_LIBREADLINE) || defined (HAVE_LIBEDIT)
+-# include <readline/readline.h>
+-# include <readline/history.h>
++# include <editline/readline.h>
++# include <editline/history.h>
+ #endif /* HAVE_LIBREADLINE || HAVE_LIBEDIT */
+
+ #ifdef SYS_VXWORKS
+--- a/ntpq/ntpq.c
++++ b/ntpq/ntpq.c
+@@ -31,8 +31,8 @@
+ #endif /* SYS_WINNT */
+
+ #if defined(HAVE_LIBREADLINE) || defined(HAVE_LIBEDIT)
+-# include <readline/readline.h>
+-# include <readline/history.h>
++# include <editline/readline.h>
++# include <editline/history.h>
+ #endif /* HAVE_LIBREADLINE || HAVE_LIBEDIT */
+
+ #ifdef SYS_VXWORKS