summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorpetere <petere@0070b5ef-2f16-0410-befa-9a02bd1d6ddb>2011-11-26 23:21:33 +0000
committerpetere <petere@0070b5ef-2f16-0410-befa-9a02bd1d6ddb>2011-11-26 23:21:33 +0000
commitf5c471df7ec583c21d430b5c2e56563be408d0ef (patch)
treeed6678da2d3d85b48d5abb86e117e330df2120fb /debian/rules
parent5de86d3b475e218dc1ca5ea4691f5cc48a5651f7 (diff)
downloadntp-f5c471df7ec583c21d430b5c2e56563be408d0ef.tar.gz
Get build flags from dpkg-buildflags, and fix the resulting
-Wformat-security errors using patch from Colin Watson (closes: #627403) git-svn-id: svn://svn.debian.org/pkg-ntp/ntp/trunk@337 0070b5ef-2f16-0410-befa-9a02bd1d6ddb
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 4 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index d9a8e77..a851a95 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,12 +8,9 @@ export AUTOHEADER = : autoheader
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-CFLAGS = -g -fno-strict-aliasing
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-CFLAGS += -O0
-else
-CFLAGS += -O2
-endif
+CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS) -D_GNU_SOURCE
+CFLAGS = $(shell dpkg-buildflags --get CFLAGS) -fno-strict-aliasing
+LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
config.status:
dh_testdir
@@ -22,7 +19,7 @@ ifeq (hurd, $(DEB_HOST_ARCH_OS))
exit 1
endif
cp /usr/share/misc/config.guess /usr/share/misc/config.sub .
- ./configure CFLAGS='$(CFLAGS)' CPPFLAGS='-D_GNU_SOURCE' \
+ ./configure CFLAGS='$(CFLAGS)' CPPFLAGS='$(CPPFLAGS)' LDFLAGS='$(LDFLAGS)' \
ac_cv_var_tick=no ac_cv_var_tickadj=no \
--prefix=/usr \
--enable-all-clocks --enable-parse-clocks --enable-SHM \