summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorpetere <petere@0070b5ef-2f16-0410-befa-9a02bd1d6ddb>2006-07-15 16:35:08 +0000
committerpetere <petere@0070b5ef-2f16-0410-befa-9a02bd1d6ddb>2006-07-15 16:35:08 +0000
commit29e1ae7bc393988bbffab5ca857851ec0e7c5df0 (patch)
tree787661a0abf5b55ff13881ee78637cd546031175 /debian
parent4ea9a40378203ef474c73509966d2088ddc83d1e (diff)
downloadntp-29e1ae7bc393988bbffab5ca857851ec0e7c5df0.tar.gz
* Support DEB_BUILD_OPTIONS=noopt
* Compile with -fno-strict-aliasing (closes: #316304) git-svn-id: svn://svn.debian.org/pkg-ntp/ntp/trunk@49 0070b5ef-2f16-0410-befa-9a02bd1d6ddb
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules10
2 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 09b4641..2abd277 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,8 @@ ntp (1:4.2.2+dfsg-1) unstable; urgency=low
(closes: #308840)
* Cron jobs parse /etc/ntp.conf to fetch current values of logfile and
statsdir (closes: #177341, #318824)
+ * Support DEB_BUILD_OPTIONS=noopt
+ * Compile with -fno-strict-aliasing (closes: #316304)
[ Kurt Roeckx ]
* Make ntp and ntpdate depend on netbase because they
diff --git a/debian/rules b/debian/rules
index c137da0..4ffd9b4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,10 +8,18 @@ export AUTOCONF = : autoconf
export AUTOMAKE = : automake
export AUTOHEADER = : autoheader
+CFLAGS = -g -fno-strict-aliasing
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+CFLAGS += -O0
+else
+CFLAGS += -O2
+endif
+
config: patch config.status
config.status: $(QUILT_STAMPFN)
dh_testdir
- ./configure --prefix=/usr \
+ ./configure CFLAGS='$(CFLAGS)' \
+ --prefix=/usr \
--enable-all-clocks --enable-parse-clocks --enable-SHM \
--disable-debugging --sysconfdir=/var/lib/ntp \
--disable-errorcache --with-sntp=no \