summaryrefslogtreecommitdiff
path: root/src/procmemstat/GNUmakefile.install
diff options
context:
space:
mode:
Diffstat (limited to 'src/procmemstat/GNUmakefile.install')
-rw-r--r--src/procmemstat/GNUmakefile.install39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/procmemstat/GNUmakefile.install b/src/procmemstat/GNUmakefile.install
new file mode 100644
index 0000000..9b2a459
--- /dev/null
+++ b/src/procmemstat/GNUmakefile.install
@@ -0,0 +1,39 @@
+#
+# Copyright (c) 2000,2004 Silicon Graphics, Inc. All Rights Reserved.
+#
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; either version 2 of the License, or (at your
+# option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+#
+
+CFILES = procmemstat.c
+CFLAGS = -I/usr/include/pcp -DPCP_DEBUG=1
+TARGETS = procmemstat
+LDOPTS =
+LDLIBS = -lpcp
+
+default: $(TARGETS)
+
+install:
+
+clobber:
+ rm -f $(TARGETS) *.o core a.out pmnsmap.h mylog.* pmnsmap.i
+
+procmemstat: procmemstat.c pmnsmap.h
+ rm -f $@
+ $(CC) $(CFLAGS) procmemstat.c -o $@ $(LDOPTS) $(LDLIBS)
+
+pmnsmap.h: pmnsmap.spec
+ <CPP> <pmnsmap.spec \
+ | sed -e '/^#/d' -e '/^$$/d' >pmnsmap.i
+ pmgenmap pmnsmap.i >pmnsmap.h