summaryrefslogtreecommitdiff
path: root/debian/patches/debian/fakeroot.diff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2019-11-26 14:11:14 +0300
committerIgor Pashev <pashev.igor@gmail.com>2019-11-26 14:11:14 +0300
commitcf9383412494964d6188fcf08a362c0c0f313afc (patch)
treebd9e6a5b3a63cbb155b81112c855c19cb5f2b314 /debian/patches/debian/fakeroot.diff
downloadperl-cf9383412494964d6188fcf08a362c0c0f313afc.tar.gz
Import perl (5.30.0-9)debian/5.30.0-9debian
Diffstat (limited to 'debian/patches/debian/fakeroot.diff')
-rw-r--r--debian/patches/debian/fakeroot.diff39
1 files changed, 39 insertions, 0 deletions
diff --git a/debian/patches/debian/fakeroot.diff b/debian/patches/debian/fakeroot.diff
new file mode 100644
index 0000000..01cfd11
--- /dev/null
+++ b/debian/patches/debian/fakeroot.diff
@@ -0,0 +1,39 @@
+From: Brendan O'Dea <bod@debian.org>
+Date: Fri, 18 Mar 2005 22:22:25 +1100
+Subject: Postpone LD_LIBRARY_PATH evaluation to the binary targets.
+
+Modify the setting of LD_LIBRARY_PATH to append pre-existing values at the
+time the rule is evaluated rather than when the Makefile is created.
+
+This is required when building packages with dpkg-buildpackage and fakeroot,
+since fakeroot (which now sets LD_LIBRARY_PATH) is not used for the "build"
+rule where the Makefile is created, but is for the clean/binary* targets.
+---
+ Makefile.SH | 7 ++-----
+ 1 file changed, 2 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.SH b/Makefile.SH
+index 5777970..f8adb85 100755
+--- a/Makefile.SH
++++ b/Makefile.SH
+@@ -48,10 +48,7 @@ case "$useshrplib" in
+ true)
+ # Prefix all runs of 'miniperl' and 'perl' with
+ # $ldlibpth so that ./perl finds *this* shared libperl.
+- case "$LD_LIBRARY_PATH" in
+- '') ldlibpth="LD_LIBRARY_PATH=` quote "$pwd" `" ;;
+- *) ldlibpth="LD_LIBRARY_PATH=` quote "$pwd" `:` quote "$LD_LIBRARY_PATH" `" ;;
+- esac
++ ldlibpth="LD_LIBRARY_PATH=` quote "$pwd" `"'$${LD_LIBRARY_PATH:+:}$$LD_LIBRARY_PATH'
+
+ pldlflags="$cccdlflags"
+ static_ldflags=''
+@@ -130,7 +127,7 @@ true)
+ ;;
+ esac
+ case "$ldlibpthname" in
+- '') ;;
++ ''|LD_LIBRARY_PATH) ;;
+ *)
+ case "$osname" in
+ os2)