summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorStefan Fritsch <sf@sfritsch.de>2011-12-27 19:42:28 +0100
committerStefan Fritsch <sf@sfritsch.de>2011-12-27 19:42:28 +0100
commit02a0e3b89d2ea1b984365e692c910668d75c6dcd (patch)
treeb9ba1c635c12bace3b2afbe7f548a0aab67102f5 /configure.in
parent0268977037115539ad65a26e858aa0df8d18cd13 (diff)
downloadapache2-02a0e3b89d2ea1b984365e692c910668d75c6dcd.tar.gz
Upstream tarball 2.2.11upstream/2.2.11
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 434a43ec..0ccf8591 100644
--- a/configure.in
+++ b/configure.in
@@ -18,6 +18,15 @@ sinclude(build/find_apr.m4)
sinclude(build/find_apu.m4)
sinclude(acinclude.m4)
+dnl Later versions of autoconf (>= 2.62) by default cause the produced
+dnl configure script to emit at least warnings when it comes across unknown
+dnl command line options. These versions also have the macro
+dnl AC_DISABLE_OPTION_CHECKING defined which turns this off by default.
+dnl We want to have this turned off here since our configure calls can
+dnl contain options for APR / APR-UTIL configure that are unknown to us.
+dnl So avoid confusing the user by turning this off. See also PR 45221.
+ifdef([AC_DISABLE_OPTION_CHECKING], [AC_DISABLE_OPTION_CHECKING])
+
dnl XXX we can't just use AC_PREFIX_DEFAULT because that isn't subbed in
dnl by configure until it is too late. Is that how it should be or not?
dnl Something seems broken here.
@@ -235,7 +244,7 @@ case $host in
LIBTOOL="$my_libtool \$(LTFLAGS)"
libtoolversion=`$my_libtool --version`
case $libtoolversion in
- *1.[[45]]*)
+ *1.[[45]]* | *[[2-9]].[[0-9]]*)
SH_LIBTOOL='$(LIBTOOL)'
SHLTCFLAGS="-prefer-pic"
LTCFLAGS="-prefer-non-pic -static"
@@ -329,10 +338,15 @@ INSTALL="\$(LIBTOOL) --mode=install \$(abs_srcdir)/build/install.sh -c"
APACHE_SUBST(MKINSTALLDIRS)
APACHE_SUBST(INSTALL)
-dnl various OS checks that apparently set required flags
+dnl Various OS checks that apparently set required flags
+ifdef([AC_USE_SYSTEM_EXTENSIONS], [
+AC_USE_SYSTEM_EXTENSIONS
+], [
AC_AIX
-AC_ISC_POSIX
AC_MINIX
+])
+
+AC_ISC_POSIX
# Ensure that satisfactory versions of apr and apr-util are
# found if external copies are configured.