summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorStefan Fritsch <sf@sfritsch.de>2012-04-15 17:36:52 +0200
committerStefan Fritsch <sf@sfritsch.de>2012-04-15 17:36:52 +0200
commit4a7e5ad42b5b84ec4f8f03d4c5452ce3fdefdeb5 (patch)
treeffdd458cd0b79d6994252f3a57f360a91ecb2490 /debian/rules
parent0b88a4a63a8381b1f8e629d70c05699b1da717c7 (diff)
downloadapache2-4a7e5ad42b5b84ec4f8f03d4c5452ce3fdefdeb5.tar.gz
Fix all config files to use tabs for indentation
Enforce this during the build to avoid regressions
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 16 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 08357a76..7736dad6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -40,6 +40,20 @@ unpatch:
rm patch.stamp ;\
fi
+prebuild-checks:
+ ERRS="" ;\
+ for a in $$(find debian/config-dir/ -type f) ; do \
+ t="$$a.$$$$" ;\
+ unexpand < "$$a" > "$$t" ;\
+ cmp -s "$$a" "$$t" || ERRS="$$ERRS $$a" ;\
+ rm "$$t" ;\
+ done ;\
+ if [ -n "$$ERRS" ] ; then \
+ echo 'ERROR: The following files contain spaces instead of tabs. Run through unexpand!' ;\
+ ls -1 $$ERRS ;\
+ false ;\
+ fi
+
clean-config-vars:
# Clean up config_vars.mk
# FIXME: Maybe someone could document here why we actually need to
@@ -68,7 +82,7 @@ generate-maintainer-scripts:
%:
dh $@ --parallel --with autotools_dev
-override_dh_auto_configure: patch generate-maintainer-scripts
+override_dh_auto_configure: patch generate-maintainer-scripts prebuild-checks
./configure --enable-layout=Debian --enable-so --with-program-name=apache2 \
--enable-suexec --with-suexec-caller=www-data \
--with-suexec-bin=/usr/lib/apache2/suexec --with-suexec-docroot=/var/www \
@@ -139,4 +153,4 @@ override_dh_auto_install:
override_dh_clean: unpatch
dh_clean
-.PHONY: patch unpatch generate-maintainer-scripts clean-config-vars prepare-scripts
+.PHONY: patch unpatch generate-maintainer-scripts clean-config-vars prepare-scripts prebuild-checks