summaryrefslogtreecommitdiff
path: root/debian/exim4-config.config
diff options
context:
space:
mode:
authorMarc Haber <zugschlus@debian.org>2007-04-21 09:46:27 +0000
committerMarc Haber <zugschlus@debian.org>2007-04-21 09:46:27 +0000
commit9bafa5e9497f9e52f0fc1932b527ecc199b1e661 (patch)
tree7c86222d4fa1b8843becdde9401b118644bdfb03 /debian/exim4-config.config
parent0426f5c9c02729929d46a0f27bb1124779fa9e3b (diff)
downloadexim4-9bafa5e9497f9e52f0fc1932b527ecc199b1e661.tar.gz
* new upstream version
* remove 37_upstream-patch-384015-add_headers * remove 80_disable_rsa_export * remove 80_upstream_408174_4-64-PH18 * EDITME patch changes to allow for 4.67 * enable dovecot authentication * Upstream patch from Magnus Holmgren included upstream. Thanks to Simon Walter. Closes: #407957 * Upstream patch PH/18 included upstream. Thanks to Marc Schiffbauer. Closes: #408174 * merge experimental changes * exim man page patch changes for 4.67 * robustness patches for * create-custom-package * exim-gencert * exim4-base.config * exim4-base.postinst * exim4-config.config * exim4-config.postinst * exim4-daemon-light.postinst * update-exim4defaults * replace backticks with $() notation * Add patch to 50_localscan_dlopen to reduce dynamic symbol table. Thanks to Magnus Holmgren. Closes: #413602 * remove woody compatibility hacks from * exim4-daemon-light.postinst * exim4-config.postinst * Fix eximnext => exinext in man page. * update-exim4.conf(8): * clarify update-exim4.conf about how ue4cc and exim configuration interface * multiple minor changes to lintian overrides * debian/control: have exim4 depend on debconf (>= 1.4.69) | cdebconf (>= 0.39) explicitly to allow usage of debconf error template type. svn path=/exim/trunk/; revision=2014
Diffstat (limited to 'debian/exim4-config.config')
-rw-r--r--debian/exim4-config.config80
1 files changed, 40 insertions, 40 deletions
diff --git a/debian/exim4-config.config b/debian/exim4-config.config
index bb04cfe..bbe61f6 100644
--- a/debian/exim4-config.config
+++ b/debian/exim4-config.config
@@ -3,7 +3,7 @@ set -e
alias stripwhitespace="sed -e 's/^[[:blank:]]*//' -e 's/[[:blank:]]*$//'"
-installeddebconfversion=`dpkg -s debconf | sed -ne '/^Version/s/^Version: //p'`
+installeddebconfversion="$(dpkg -s debconf | sed -ne '/^Version/s/^Version: //p')"
if [ "reconfigure" != "$1" ] && \
dpkg --compare-versions "${installeddebconfversion}" "le" "1.4" && \
[ "$exim4postinstisrunning" != "true" ] ; then
@@ -92,19 +92,19 @@ convert_transport_to_short ()
# store environment variables in debconf db.
storevar2db() {
- dc_eximconfig_configtype=`printf '%s\n' "${dc_eximconfig_configtype}" | stripwhitespace`
- dc_local_interfaces=`printf '%s\n' "${dc_local_interfaces}" | stripwhitespace`
- dc_other_hostnames=`printf '%s\n' "${dc_other_hostnames}" | stripwhitespace`
- dc_readhost=`printf '%s\n' "${dc_readhost}" | stripwhitespace`
- dc_relay_domains=`printf '%s\n' "${dc_relay_domains}" | stripwhitespace`
- dc_relay_nets=`printf '%s\n' "${dc_relay_nets}" | stripwhitespace`
- dc_smarthost=`printf '%s\n' "${dc_smarthost}" | stripwhitespace`
- dc_minimaldns=`printf '%s\n' "${dc_minimaldns}" | stripwhitespace`
- dc_use_split_config=`printf '%s\n' "${dc_use_split_config}" | stripwhitespace`
- dc_hide_mailname=`printf '%s\n' "${dc_hide_mailname}" | stripwhitespace`
+ dc_eximconfig_configtype="$(printf '%s\n' "${dc_eximconfig_configtype}" | stripwhitespace)"
+ dc_local_interfaces="$(printf '%s\n' "${dc_local_interfaces}" | stripwhitespace)"
+ dc_other_hostnames="$(printf '%s\n' "${dc_other_hostnames}" | stripwhitespace)"
+ dc_readhost="$(printf '%s\n' "${dc_readhost}" | stripwhitespace)"
+ dc_relay_domains="$(printf '%s\n' "${dc_relay_domains}" | stripwhitespace)"
+ dc_relay_nets="$(printf '%s\n' "${dc_relay_nets}" | stripwhitespace)"
+ dc_smarthost="$(printf '%s\n' "${dc_smarthost}" | stripwhitespace)"
+ dc_minimaldns="$(printf '%s\n' "${dc_minimaldns}" | stripwhitespace)"
+ dc_use_split_config="$(printf '%s\n' "${dc_use_split_config}" | stripwhitespace)"
+ dc_hide_mailname="$(printf '%s\n' "${dc_hide_mailname}" | stripwhitespace)"
# store externally changed values to debconf.db
db_set exim4/dc_eximconfig_configtype \
- "`convert_to_long ${dc_eximconfig_configtype}`"
+ "$(convert_to_long ${dc_eximconfig_configtype})"
db_set exim4/dc_local_interfaces "${dc_local_interfaces}"
db_set exim4/dc_other_hostnames "${dc_other_hostnames}"
db_set exim4/dc_readhost "${dc_readhost}"
@@ -119,9 +119,9 @@ storevar2db() {
# do not store "locally customized" in debconf db, otherwise simply
# removing the custom dc_localdelivery from ue4cc won't work.
if [ "x${dc_localdelivery}" != "x" ] &&
- [ "`convert_transport_to_long ${dc_localdelivery}`" != "locally customized" ] ; then
+ [ "$(convert_transport_to_long ${dc_localdelivery})" != "locally customized" ] ; then
db_set exim4/dc_localdelivery \
- "`convert_transport_to_long ${dc_localdelivery}`"
+ "$(convert_transport_to_long ${dc_localdelivery})"
fi
db_fset "exim4/dc_other_hostnames" mailname "${dc_mailname_in_oh}"
}
@@ -137,21 +137,21 @@ alias coloncolon2oe="sed -e 's/[[:blank:]]*//g' -e '/^</d' -e 's/:::::/:öö/g' -e
# try to parse exim3 configuration file - works only if it was generated
# with eximconfig.
parseexim3() {
- dc_mailname=`head -n 1 /etc/mailname | stripwhitespace` || true
+ dc_mailname="$(head -n 1 /etc/mailname | stripwhitespace)" || true
# get the .... entries from
# host_accept_relay = 127.0.0.1 : ::::1 : ......
# if they exist, ie. parse list, and remove "127.0.0.1", "::::1"
# and "localhost" from it.
#
- dc_relay_nets=`cat $1 | grep -h '^host_accept_relay[[:blank:]]*=' | sed -e 's/^host_accept_relay[[:blank:]]*=//' | coloncolon2oe | sed -e 's/ 127\.0\.0\\.1 //g' -e 's/ localhost //g' -e 's/ öö1//g' -e 's/[[:blank:]]*//g' -e 's/::/:/g' -e 's/^://' -e 's/:$//' -e 's/ö/::/g'`
+ dc_relay_nets="$(cat $1 | grep -h '^host_accept_relay[[:blank:]]*=' | sed -e 's/^host_accept_relay[[:blank:]]*=//' | coloncolon2oe | sed -e 's/ 127\.0\.0\\.1 //g' -e 's/ localhost //g' -e 's/ öö1//g' -e 's/[[:blank:]]*//g' -e 's/::/:/g' -e 's/^://' -e 's/:$//' -e 's/ö/::/g')"
# 'local_domains = $colonhostnames', including mailname and "localhost"
#
- dc_other_hostnames=`cat $1 | grep -h '^local_domains[[:blank:]]*=' | sed -e 's/^local_domains[[:blank:]]*=//' | coloncolon2oe | sed -e 's/ localhost //g' -e "s/ ${dc_mailname} //g" -e 's/[[:blank:]]*//g' -e 's/::/:/g' -e 's/^://' -e 's/:$//' -e 's/ö/::/g'`
+ dc_other_hostnames="$(cat $1 | grep -h '^local_domains[[:blank:]]*=' | sed -e 's/^local_domains[[:blank:]]*=//' | coloncolon2oe | sed -e 's/ localhost //g' -e "s/ ${dc_mailname} //g" -e 's/[[:blank:]]*//g' -e 's/::/:/g' -e 's/^://' -e 's/:$//' -e 's/ö/::/g')"
# relay_domains = some.domain
- dc_relay_domains=`cat $1 | grep -h '^relay_domains = ' | sed -e 's/^relay_domains[[:blank:]]*=[[:blank:]]*//' -e 's/[[:blank:]]*$//'`
+ dc_relay_domains="$(cat $1 | grep -h '^relay_domains = ' | sed -e 's/^relay_domains[[:blank:]]*=[[:blank:]]*//' -e 's/[[:blank:]]*$//')"
# lookuphost router exist ---> dc_eximconfig_configtype=internet
#
@@ -164,13 +164,13 @@ parseexim3() {
#
# Later we need the new_address directive to find dc_readhost.
# ' || true' is required for "set -e"
- dc_readhost=`cat $1 | grep -h -A2 '^smart:' | grep -h -A1 '^[[:blank:]]*driver = smartuser' | grep -h '^[[:blank:]]*new_address' || true`
+ dc_readhost="$(cat $1 | grep -h -A2 '^smart:' | grep -h -A1 '^[[:blank:]]*driver = smartuser' | grep -h '^[[:blank:]]*new_address' || true)"
# smarthost router exists --> dc_eximconfig_configtype is satellite or smarthost
#
# we need the route_list directive to find dc_smarthost
# ' || true' is required for "set -e"
- dc_smarthost=`cat $1 | grep -h -A3 '^smarthost:' | grep -h -A2 '[[:blank:]]*driver = domainlist' | grep -h -A1 '^[[:blank:]]*transport = remote_smtp' | grep -h '^[[:blank:]]*route_list = "' || true`
+ dc_smarthost="$(< $1 grep -A3 '^smarthost:' | grep -A2 '[[:blank:]]*driver = domainlist' | grep -A1 '^[[:blank:]]*transport = remote_smtp' | grep '^[[:blank:]]*route_list = ".*"' || true)"
if [ ! -z "${dc_readhost}" ] ; then
dc_eximconfig_configtype=satellite
@@ -203,17 +203,17 @@ parseexim3() {
;;
satellite)
# new_address = ${local_part}@$readhost
- dc_readhost=`printf '%s\n' "${dc_readhost}" | sed -e 's/^.*@//' -e 's/[[:blank:]]*$//'`
+ dc_readhost="$(printf '%s\n' "${dc_readhost}" | sed -e 's/^.*@//' -e 's/[[:blank:]]*$//')"
# route_list = "* $smtphost bydns_a"
- dc_smarthost=`printf '%s\n' "${dc_smarthost}" | \
- sed -e 's/^ *route_list = "\* //' -e 's/ bydns_a"//' -e 's/[[:blank:]]*$//'`
+ dc_smarthost="$(printf '%s\n' "${dc_smarthost}" | \
+ sed -e 's/^ *route_list = "\* //' -e 's/ bydns_a"//' -e 's/[[:blank:]]*$//')"
dc_hide_mailname='true'
dc_relay_domains=''
;;
smarthost)
# route_list = "* $smtphost bydns_a"
- dc_smarthost=`printf '%s\n' "${dc_smarthost}" | \
- sed -e 's/^ *route_list = "\* //' -e 's/ bydns_a"//' -e 's/[[:blank:]]*$//'`
+ dc_smarthost="$(printf '%s\n' "${dc_smarthost}" | \
+ sed -e 's/^ *route_list = "\* //' -e 's/ bydns_a"//' -e 's/[[:blank:]]*$//')"
dc_hide_mailname='false'
dc_relay_domains=''
;;
@@ -228,11 +228,11 @@ mailname2otherhostnames() {
# in a file to pass it to postinst..
[ -d /var/lib/exim4 ] || \
install -d -oroot -groot -m755 /var/lib/exim4
- dc_mailname=`head -n 1 /etc/mailname | stripwhitespace` || true
+ dc_mailname="$(head -n 1 /etc/mailname | stripwhitespace)" || true
if [ -z "${dc_other_hostnames}" ] ; then
dc_other_hostnames="${dc_mailname}"
else
- dc_other_hostnames=`printf '%s\n' "${dc_other_hostnames}" | stripwhitespace`:${dc_mailname}
+ dc_other_hostnames="$(printf '%s\n' "${dc_other_hostnames}" | stripwhitespace)":${dc_mailname}
fi
printf '%s\n' dc_other_hostnames="'""${dc_other_hostnames}""'" > \
/var/lib/exim4/addmailname2oh
@@ -243,9 +243,9 @@ mailname2otherhostnamesdcloop() {
# append mailname to other_hostnames, once. on fresh installations.
if [ "${dc_mailname_in_oh}" != "true" ] ;then
db_get exim4/mailname
- dc_mailname=`printf '%s\n' "$RET"| stripwhitespace`
+ dc_mailname="$(printf '%s\n' "$RET"| stripwhitespace)"
db_get "exim4/dc_other_hostnames"
- dc_other_hostnames=`printf '%s\n' "$RET"| stripwhitespace`
+ dc_other_hostnames="$(printf '%s\n' "$RET"| stripwhitespace)"
if [ -z "${dc_other_hostnames}" ] ; then
dc_other_hostnames="${dc_mailname}"
else
@@ -267,7 +267,7 @@ if command -v db_settitle > /dev/null 2>&1; then
db_settitle exim4/exim4-config-title 2>/dev/null || true
fi
db_get exim4/dc_eximconfig_configtype
-dc_eximconfig_configtype=`convert_to_short "$RET"`
+dc_eximconfig_configtype="$(convert_to_short "$RET")"
db_get exim4/use_split_config
dc_use_split_config="$RET"
# Did we append mailname to other_hostnames yet?
@@ -294,7 +294,7 @@ else
# 1. remove comment lines
# 2. remove blank lines
# 3. remove "\<optional space><newline><optional space>"
- exim3confunfolded=`tempfile -p EX3`
+ exim3confunfolded="$(tempfile -p EX3)"
perl -e \
'undef $/;
while (<>) {
@@ -316,11 +316,11 @@ fi
## config script is called two times before update-exim4.conf.conf exists.
[ "x${dc_eximconfig_configtype}" = "x" ] && \
dc_eximconfig_configtype="local" && \
- db_set exim4/dc_eximconfig_configtype "`convert_to_long ${dc_eximconfig_configtype}`"
+ db_set exim4/dc_eximconfig_configtype "$(convert_to_long ${dc_eximconfig_configtype})"
if [ -e /etc/mailname ] ; then
- dc_mailname=`head -n 1 /etc/mailname | stripwhitespace` || true
+ dc_mailname="$(head -n 1 /etc/mailname | stripwhitespace)" || true
# store values
db_set exim4/mailname "${dc_mailname}"
else
@@ -330,11 +330,11 @@ fi
#Set default mailname
if [ "x${dc_mailname}" = "x" ] ; then
- dc_mailname=`hostname --fqdn` || dc_mailname=`hostname` && \
- dc_mailname=`printf '%s\n' "${dc_mailname}" | stripwhitespace` && \
+ dc_mailname="$(hostname --fqdn)" || dc_mailname="$(hostname)" && \
+ dc_mailname="$(printf '%s\n' "${dc_mailname}" | stripwhitespace)" && \
db_set exim4/mailname "${dc_mailname}"
fi
-fqdn=`hostname --fqdn` || fqdn=''
+fqdn="$(hostname --fqdn)" || fqdn=''
db_subst exim4/dc_other_hostnames fqdn "$fqdn"
# initialize env-vars from debconf_db, if they haven't been set yet either by
@@ -374,8 +374,8 @@ fi
if [ "x${dc_localdelivery}" = "x" ] ; then
db_get exim4/dc_localdelivery
- dc_localdelivery=`convert_transport_to_short "$RET"`
-elif [ "`convert_transport_to_long ${dc_localdelivery}`" = "locally customized" ] ; then
+ dc_localdelivery="$(convert_transport_to_short "$RET")"
+elif [ "$(convert_transport_to_long ${dc_localdelivery})" = "locally customized" ] ; then
dc_localdelivery="custom"
fi
@@ -405,7 +405,7 @@ while [ "$STATE" != 0 ] && [ "$STATE" -le "$STATELIMIT" ]; do
3)
EX4QUESTION=""
db_get exim4/dc_eximconfig_configtype
- dc_eximconfig_configtype=`convert_to_short "$RET"`
+ dc_eximconfig_configtype="$(convert_to_short "$RET")"
PREVSTATE=$(($STATE - 1))
case "${dc_eximconfig_configtype}" in
none)
@@ -775,7 +775,7 @@ if [ ! -e /etc/aliases ] || \
fi
db_get exim4/dc_postmaster || true
-dc_postmaster=`printf '%s\n' "$RET" | stripwhitespace`
+dc_postmaster="$(printf '%s\n' "$RET" | stripwhitespace)"
# if [ "x${dc_eximconfig_configtype}" = "xsatellite" ] || [ "x${dc_eximconfig_configtype}" = "xlocal" ] ; then
# # reset dc_relay_domains dc_relay_nets and dc_other_hostnames