summaryrefslogtreecommitdiff
path: root/debian/patches/36_pcre.dpatch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/36_pcre.dpatch')
-rwxr-xr-xdebian/patches/36_pcre.dpatch91
1 files changed, 91 insertions, 0 deletions
diff --git a/debian/patches/36_pcre.dpatch b/debian/patches/36_pcre.dpatch
new file mode 100755
index 0000000..0480b95
--- /dev/null
+++ b/debian/patches/36_pcre.dpatch
@@ -0,0 +1,91 @@
+#! /bin/sh -e
+## 36_pcre.dpatch by Andreas Metzler
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Link exim and eximon dynamically instead of statically
+## DP: pcre.
+
+if [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch) patch -f --no-backup-if-mismatch -p1 < $0;;
+ -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1;;
+esac
+
+exit 0
+
+@DPATCH@
+diff -urNad 30.tmp/OS/Makefile-Base 30/OS/Makefile-Base
+--- 30.tmp/OS/Makefile-Base Mon Dec 30 10:28:54 2002
++++ 30/OS/Makefile-Base Mon Dec 30 10:29:28 2002
+@@ -94,7 +94,7 @@
+ # This is the real default target for all the various exim binaries and
+ # scripts, once the configuring stuff is done.
+
+-allexim: config.h buildpcre $(EXIM_MONITOR) exicyclog exinext exiwhat \
++allexim: config.h $(EXIM_MONITOR) exicyclog exinext exiwhat \
+ exigrep eximstats exiqgrep exiqsumm \
+ transport-filter.pl convert4r3 convert4r4 \
+ exim_checkaccess \
+@@ -255,7 +255,7 @@
+ store.o string.o tls.o tod.o transport.o tree.o verify.o \
+ local_scan.o $(EXIM_PERL)
+
+-exim: pcre/libpcre.a lookups/lookups.a auths/auths.a \
++exim: lookups/lookups.a auths/auths.a \
+ routers/routers.a transports/transports.a \
+ $(OBJ_EXIM) version.c
+ @echo " "
+@@ -264,7 +264,7 @@
+ $(CC) -c $(CFLAGS) $(INCLUDE) $(IPV6_INCLUDE) $(TLS_INCLUDE) version.c
+ rm -f exim
+ $(PURIFY) $(LNCC) -o exim $(LFLAGS) $(OBJ_EXIM) version.o \
+- pcre/libpcre.a \
++ -lpcre \
+ routers/routers.a transports/transports.a lookups/lookups.a \
+ auths/auths.a \
+ $(LIBRESOLV) $(LIBS) $(LIBS_EXIM) $(IPV6_LIBS) $(EXTRALIBS) \
+@@ -366,12 +366,12 @@
+
+ OBJ_MONBIN = util-spool_in.o util-store.o util-string.o tod.o tree.o $(MONBIN)
+
+-eximon.bin: $(EXIMON_EDITME) eximon $(OBJ_MONBIN) pcre/libpcre.a \
++eximon.bin: $(EXIMON_EDITME) eximon $(OBJ_MONBIN) \
+ ../exim_monitor/em_version.c
+ $(CC) -o em_version.o -c \
+ $(CFLAGS) $(XINCLUDE) -I. ../exim_monitor/em_version.c
+ $(PURIFY) $(LNCC) -o eximon.bin em_version.o $(LFLAGS) $(XLFLAGS) \
+- $(OBJ_MONBIN) -lXaw -lXmu -lXt -lXext -lX11 pcre/libpcre.a \
++ $(OBJ_MONBIN) -lXaw -lXmu -lXt -lXext -lX11 -lpcre \
+ $(LIBS) $(LIBS_EXIMON) $(EXTRALIBS) $(EXTRALIBS_EXIMON) -lc
+ @if [ x"$(STRIP_COMMAND)" != x"" ]; then \
+ echo $(STRIP_COMMAND) eximon.bin; \
+diff -urNad 30.tmp/exim_monitor/em_hdr.h 30/exim_monitor/em_hdr.h
+--- 30.tmp/exim_monitor/em_hdr.h Mon Dec 30 10:28:54 2002
++++ 30/exim_monitor/em_hdr.h Mon Dec 30 10:29:28 2002
+@@ -85,7 +85,7 @@
+
+ /* Regular expression include */
+
+-#include "pcre/pcre.h"
++#include <pcre.h>
+
+ /* Includes from the main source of Exim. We need to have MAXPACKET defined for
+ the benefit of structs.h. One of these days I should tidy up this interface so
+diff -urNad 30.tmp/src/exim.h 30/src/exim.h
+--- 30.tmp/src/exim.h Mon Dec 30 10:28:54 2002
++++ 30/src/exim.h Mon Dec 30 10:29:28 2002
+@@ -322,7 +322,7 @@
+
+ /* The header from the PCRE regex package */
+
+-#include "pcre/pcre.h"
++#include <pcre.h>
+
+ /* Exim includes are in several files */
+