summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco TĂșlio Gontijo e Silva <marcot@debian.org>2010-03-06 02:06:02 +0300
committer=?UTF-8?q?Marco=20T=C3=BAlio=20Gontijo=20e=20Silva?= <=?UTF-8?q?Marco=20T=C3=BAlio=20Gontijo=20e=20Silva?=>2010-03-06 02:06:02 +0300
commit0b5445c3845525847e9a58b25908f8ce5e9725a3 (patch)
tree25a14380e1dbe5c237f9944c8c6be3ecfe72bc4f
parent87643a29376960215e90d757ecbcfb04c04e8031 (diff)
downloadDHG_packages-0b5445c3845525847e9a58b25908f8ce5e9725a3.tar.gz
haskell-devscripts: hlibrary.mk: Create HASKELL_HIDE_PACKAGES variable, to make it possible to create packages hidden by default.
-rw-r--r--p/haskell-devscripts/debian/debian/changelog7
-rw-r--r--p/haskell-devscripts/debian/hlibrary.mk1
2 files changed, 8 insertions, 0 deletions
diff --git a/p/haskell-devscripts/debian/debian/changelog b/p/haskell-devscripts/debian/debian/changelog
index b3cd68768..b7ad6fb9d 100644
--- a/p/haskell-devscripts/debian/debian/changelog
+++ b/p/haskell-devscripts/debian/debian/changelog
@@ -1,3 +1,10 @@
+haskell-devscripts (0.7.5) UNRELEASED; urgency=low
+
+ * hlibrary.mk: Create HASKELL_HIDE_PACKAGES variable, to make it
+ possible to create packages hidden by default.
+
+ -- Marco TĂșlio Gontijo e Silva <marcot@debian.org> Fri, 05 Mar 2010 19:50:39 -0300
+
haskell-devscripts (0.7.4) unstable; urgency=low
* Prevent building of packages with ghc6 << 6.12.1-10
diff --git a/p/haskell-devscripts/debian/hlibrary.mk b/p/haskell-devscripts/debian/hlibrary.mk
index a4de337e4..fad00b76d 100644
--- a/p/haskell-devscripts/debian/hlibrary.mk
+++ b/p/haskell-devscripts/debian/hlibrary.mk
@@ -104,6 +104,7 @@ install/libghc6-$(CABAL_PACKAGE)-dev:: debian/tmp-inst-ghc6
\( ! -name "*_p.a" ! -name "*.p_hi" \) \
-exec install -Dm 644 '{}' ../$(notdir $@)/'{}' ';'
pkg_config=`$(DEB_SETUP_BIN_NAME) register --builddir=dist-ghc6 --gen-pkg-config | sed -r 's,.*: ,,'`; \
+ $(if $(HASKELL_HIDE_PACKAGES),sed -i 's/^exposed: True$$/exposed: False/' $$pkg_config;) \
install -Dm 644 $$pkg_config debian/$(notdir $@)/var/lib/ghc-$(GHC6_VERSION)/package.conf.d/$$pkg_config; \
rm -f $$pkg_config
mkdir -p debian/$(notdir $@)/$(DEB_HADDOCK_DIR)