summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2017-09-16 13:10:51 -0700
committerSean Whitton <spwhitton@spwhitton.name>2017-09-16 13:10:51 -0700
commit200730a765ad196712eb34a971ec049257a10091 (patch)
treeef17935bf581c378e2d7d0391356e69f6c9ef66f
parent7e0d12ef5c9a238f83cfe7d90c0c003703f4927e (diff)
downloadDHG_packages-200730a765ad196712eb34a971ec049257a10091.tar.gz
cryptonite: deduplicate patch
-rw-r--r--p/haskell-cryptonite/debian/changelog2
-rw-r--r--p/haskell-cryptonite/debian/patches/more-alignment.patch14
2 files changed, 3 insertions, 13 deletions
diff --git a/p/haskell-cryptonite/debian/changelog b/p/haskell-cryptonite/debian/changelog
index 5a5b928bf..2a54d3a20 100644
--- a/p/haskell-cryptonite/debian/changelog
+++ b/p/haskell-cryptonite/debian/changelog
@@ -3,7 +3,7 @@ haskell-cryptonite (0.23-1) unstable; urgency=medium
* New upstream release.
* Refresh more-alignment.patch
- -- Sean Whitton <spwhitton@spwhitton.name> Sat, 16 Sep 2017 12:48:17 -0700
+ -- Sean Whitton <spwhitton@spwhitton.name> Sat, 16 Sep 2017 13:10:45 -0700
haskell-cryptonite (0.21-3) unstable; urgency=medium
diff --git a/p/haskell-cryptonite/debian/patches/more-alignment.patch b/p/haskell-cryptonite/debian/patches/more-alignment.patch
index 01352bcac..138d864a8 100644
--- a/p/haskell-cryptonite/debian/patches/more-alignment.patch
+++ b/p/haskell-cryptonite/debian/patches/more-alignment.patch
@@ -5,7 +5,7 @@ Forwarded: https://github.com/haskell-crypto/cryptonite/pull/175
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/cbits/cryptonite_align.h
+++ b/cbits/cryptonite_align.h
-@@ -34,9 +34,34 @@
+@@ -34,9 +34,24 @@
#define need_alignment(p,n) IS_ALIGNED(p,n)
#endif
@@ -24,16 +24,6 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+ return le64_to_cpu(*((uint64_t *) p));
+}
+
-+static inline void store_be32_aligned(uint8_t *p, uint32_t val)
-+{
-+ *((uint32_t *) p) = cpu_to_be32(val);
-+}
-+
-+static inline void store_be64_aligned(uint8_t *p, uint64_t val)
-+{
-+ *((uint64_t *) p) = cpu_to_be64(val);
-+}
-+
static inline uint32_t load_le32_aligned(const uint8_t *p)
{
- return le32_to_cpu(*((uint32_t *) p));
@@ -41,7 +31,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
}
static inline void store_le32_aligned(uint8_t *dst, const uint32_t v)
-@@ -60,12 +85,83 @@ static inline void store_be64_aligned(ui
+@@ -60,12 +75,83 @@ static inline void store_be64_aligned(ui
}
#ifdef UNALIGNED_ACCESS_OK