summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2017-06-17 14:41:43 -0400
committerClint Adams <clint@debian.org>2017-06-18 11:19:03 -0400
commita3a7c652aa5dad3eaac236f72b3a4259a2eac480 (patch)
treef835dd7b8942d6c53bea3bab703b2f8e914149de
parentaebe409625ca74795b05f42b52fb17c1e14c95b7 (diff)
downloadDHG_packages-a3a7c652aa5dad3eaac236f72b3a4259a2eac480.tar.gz
GLUT: Upgrading from 2.7.0.10 to 2.7.0.12
-rw-r--r--p/haskell-glut/debian/changelog6
-rw-r--r--p/haskell-glut/debian/patches/use-extra-libraries26
2 files changed, 17 insertions, 15 deletions
diff --git a/p/haskell-glut/debian/changelog b/p/haskell-glut/debian/changelog
index 74311d305..6263ef917 100644
--- a/p/haskell-glut/debian/changelog
+++ b/p/haskell-glut/debian/changelog
@@ -1,3 +1,9 @@
+haskell-glut (2.7.0.12-1) unstable; urgency=medium
+
+ * New upstream release
+
+ -- Clint Adams <clint@debian.org> Sat, 17 Jun 2017 14:41:43 -0400
+
haskell-glut (2.7.0.10-4) unstable; urgency=medium
* Use extra-libraries: GLUT so that this properly links against libglut
diff --git a/p/haskell-glut/debian/patches/use-extra-libraries b/p/haskell-glut/debian/patches/use-extra-libraries
index 377cf70bf..330fe0293 100644
--- a/p/haskell-glut/debian/patches/use-extra-libraries
+++ b/p/haskell-glut/debian/patches/use-extra-libraries
@@ -1,8 +1,6 @@
-Index: haskell-glut/GLUT.cabal
-===================================================================
---- haskell-glut.orig/GLUT.cabal 2016-05-12 12:47:38.000000000 -0400
-+++ haskell-glut/GLUT.cabal 2017-05-06 16:55:16.164611101 -0400
-@@ -103,6 +103,7 @@
+--- a/GLUT.cabal
++++ b/GLUT.cabal
+@@ -104,6 +104,7 @@
else
cpp-options: "-DCALLCONV=ccall"
cc-options: "-DUSE_DLSYM"
@@ -10,16 +8,14 @@ Index: haskell-glut/GLUT.cabal
executable BOGLGP01-OnYourOwn1
if !flag(BuildExamples)
-Index: haskell-glut/cbits/HsGLUT.c
-===================================================================
---- haskell-glut.orig/cbits/HsGLUT.c 2016-05-12 12:47:38.000000000 -0400
-+++ haskell-glut/cbits/HsGLUT.c 2017-05-06 16:56:30.898637798 -0400
-@@ -66,7 +66,7 @@
- handle = dlopen("/System/Library/Frameworks/GLUT.framework/GLUT", RTLD_LAZY | RTLD_GLOBAL);
- }
+--- a/cbits/HsGLUT.c
++++ b/cbits/HsGLUT.c
+@@ -57,7 +57,7 @@
+ /* If the public path failed, try the system framework path. */
+ "/System/Library/Frameworks/GLUT.framework/GLUT"
#else
-- handle = dlopen("libglut.so", RTLD_LAZY | RTLD_GLOBAL);
-+ handle = dlopen(NULL, RTLD_LAZY | RTLD_GLOBAL);
+- "libglut.so", "libglut.so.3"
++ NULL
#endif
- }
+ };