summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoachim Breitner <mail@joachim-breitner.de>2010-02-20 21:54:25 +0300
committerJoachim Breitner <mail@joachim-breitner.de>2010-02-20 21:54:25 +0300
commitb1d69c6eef2434ca816e5817550fe1b4859a7097 (patch)
tree8639d28dc7348202687051ea530e2e47dd467f8a
parente0251822e2212b98f21c2e128151dee29a989f20 (diff)
downloadDHG_packages-b1d69c6eef2434ca816e5817550fe1b4859a7097.tar.gz
haskell-devscripts: Parse cabal files more liberaly in hlibrary.mk
-rw-r--r--p/haskell-devscripts/debian/debian/changelog30
-rw-r--r--p/haskell-devscripts/debian/hlibrary.mk4
2 files changed, 2 insertions, 32 deletions
diff --git a/p/haskell-devscripts/debian/debian/changelog b/p/haskell-devscripts/debian/debian/changelog
index 62c0a6e66..b3cd68768 100644
--- a/p/haskell-devscripts/debian/debian/changelog
+++ b/p/haskell-devscripts/debian/debian/changelog
@@ -1,33 +1,3 @@
-haskell-devscripts (0.7.7) unstable; urgency=low
-
- * Fix "Haskell cleanup fails if optional hlibrary.setup is missing"
- changing the way the shell conditional is done. Thanks to Jonas
- Smedegaard <dr@jones.dk>. (Closes: #576447)
-
- -- Marco Túlio Gontijo e Silva <marcot@debian.org> Sun, 04 Apr 2010 22:36:51 -0300
-
-haskell-devscripts (0.7.6) unstable; urgency=low
-
- * Remove Dh_Haskell.pm.
- * source/format: Use 3.0 (native).
- * Fix "GREP_OPTIONS breaks build" cleaning GREP_OPTIONS in hlibrary.mk
- (Closes: #573925)
- * Move DEB_BUILD_DEPENDENCIES = build-arch to hlibrary.mk, instead of
- all packages debian/rules.
- * Fix "hlibrary.mk should do cleanup" by including Setup clean in the
- clean:: target of hlibrary.mk. (Closes: #575128)
-
- -- Marco Túlio Gontijo e Silva <marcot@debian.org> Tue, 30 Mar 2010 21:06:16 -0300
-
-haskell-devscripts (0.7.5) unstable; urgency=low
-
- * hlibrary.mk: Create HASKELL_HIDE_PACKAGES variable, to make it
- possible to create packages hidden by default.
- * hlibrary.mk: Include package.conf file in md5sums, since it doesn't
- change.
-
- -- Marco Túlio Gontijo e Silva <marcot@debian.org> Tue, 09 Mar 2010 21:37:30 -0300
-
haskell-devscripts (0.7.4) unstable; urgency=low
* Prevent building of packages with ghc6 << 6.12.1-10
diff --git a/p/haskell-devscripts/debian/hlibrary.mk b/p/haskell-devscripts/debian/hlibrary.mk
index da233501c..dda339a21 100644
--- a/p/haskell-devscripts/debian/hlibrary.mk
+++ b/p/haskell-devscripts/debian/hlibrary.mk
@@ -21,9 +21,9 @@ export GREP_OPTIONS :=
DEB_CABAL_PACKAGE ?= $(shell cat *.cabal |\
perl -ne \
- 'if (/^name\s*:\s*(.*)$$/i) {$$_ = $$1; tr/A-Z/a-z/; print; exit 0;}')
+ 'if (/^name\s*:\s*(.*?)\s*$$/i) {$$_ = $$1; tr/A-Z/a-z/; print; exit 0;}')
CABAL_PACKAGE=$(DEB_CABAL_PACKAGE)
-CABAL_VERSION=$(shell cat *.cabal | egrep -i '^\s*version:' | head -n1 | sed -r 's,^\s*version:\s*,,i')
+CABAL_VERSION=$(shell cat *.cabal | egrep -i '^\s*version:' | head -n1 | sed -r 's,^\s*version:\s*,,i'| sed -r 's,\s*$$,,i')
ENABLE_PROFILING = $(shell egrep -qe '^Package: libghc6-.*-prof$$' debian/control && echo --enable-library-profiling; exit 0)