summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2016-10-17 18:30:27 -0400
committerClint Adams <clint@debian.org>2016-10-17 18:30:27 -0400
commitd53d4612af71bd05fa0bfe368e74721932a05cfc (patch)
tree47c027d9595c04b617f128cfff64601e67de1162
parenteaee49f573039725d43bb24800ebc8a1558c6fc3 (diff)
downloadDHG_packages-d53d4612af71bd05fa0bfe368e74721932a05cfc.tar.gz
http-api-data: build with ghc 8 in experimental
-rw-r--r--p/haskell-http-api-data/debian/changelog7
-rw-r--r--p/haskell-http-api-data/debian/control67
-rwxr-xr-xp/haskell-http-api-data/debian/rules5
3 files changed, 49 insertions, 30 deletions
diff --git a/p/haskell-http-api-data/debian/changelog b/p/haskell-http-api-data/debian/changelog
index 837304da5..2f63a583b 100644
--- a/p/haskell-http-api-data/debian/changelog
+++ b/p/haskell-http-api-data/debian/changelog
@@ -1,3 +1,10 @@
+haskell-http-api-data (0.2.4-3) experimental; urgency=medium
+
+ * Temporarily build-depend on ghc 8.
+ * Re-enable testsuite on armel.
+
+ -- Clint Adams <clint@debian.org> Mon, 17 Oct 2016 18:29:43 -0400
+
haskell-http-api-data (0.2.4-2) unstable; urgency=medium
* Disable testsuite on armel, where ghci is broken.
diff --git a/p/haskell-http-api-data/debian/control b/p/haskell-http-api-data/debian/control
index 9f8011837..e26612ea9 100644
--- a/p/haskell-http-api-data/debian/control
+++ b/p/haskell-http-api-data/debian/control
@@ -1,26 +1,29 @@
Source: haskell-http-api-data
Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
-Uploaders: Clint Adams <clint@debian.org>
+Uploaders:
+ Clint Adams <clint@debian.org>,
Priority: extra
Section: haskell
-Build-Depends: debhelper (>= 9),
- haskell-devscripts (>= 0.9),
+Build-Depends:
cdbs,
- ghc,
+ debhelper (>= 9),
+ ghc (>= 8),
ghc-prof,
+ haskell-devscripts (>= 0.9),
+ libghc-doctest-dev (<< 0.12),
+ libghc-doctest-dev (>= 0.11),
+ libghc-hspec-dev (>= 1.3),
+ libghc-hunit-dev,
+ libghc-quickcheck2-dev,
+ libghc-text-dev,
libghc-text-dev (>= 0.5),
libghc-text-prof,
libghc-text-show-dev (>= 2),
libghc-text-show-prof,
libghc-time-locale-compat-dev,
libghc-time-locale-compat-prof,
- libghc-hunit-dev,
- libghc-quickcheck2-dev,
- libghc-doctest-dev (>= 0.11),
- libghc-doctest-dev (<< 0.12),
- libghc-hspec-dev (>= 1.3),
- libghc-text-dev,
-Build-Depends-Indep: ghc-doc,
+Build-Depends-Indep:
+ ghc-doc,
libghc-text-doc,
libghc-text-show-doc,
libghc-time-locale-compat-doc,
@@ -35,13 +38,18 @@ X-Description: converting to/from HTTP API data
Package: libghc-http-api-data-dev
Architecture: any
-Depends: ${haskell:Depends},
+Depends:
+ ${haskell:Depends},
${misc:Depends},
${shlibs:Depends},
-Recommends: ${haskell:Recommends},
-Suggests: ${haskell:Suggests},
-Conflicts: ${haskell:Conflicts},
-Provides: ${haskell:Provides},
+Recommends:
+ ${haskell:Recommends},
+Suggests:
+ ${haskell:Suggests},
+Conflicts:
+ ${haskell:Conflicts},
+Provides:
+ ${haskell:Provides},
Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
${haskell:LongDescription}
.
@@ -49,12 +57,17 @@ Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
Package: libghc-http-api-data-prof
Architecture: any
-Depends: ${haskell:Depends},
+Depends:
+ ${haskell:Depends},
${misc:Depends},
-Recommends: ${haskell:Recommends},
-Suggests: ${haskell:Suggests},
-Conflicts: ${haskell:Conflicts},
-Provides: ${haskell:Provides},
+Recommends:
+ ${haskell:Recommends},
+Suggests:
+ ${haskell:Suggests},
+Conflicts:
+ ${haskell:Conflicts},
+Provides:
+ ${haskell:Provides},
Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
${haskell:LongDescription}
.
@@ -63,11 +76,15 @@ Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
Package: libghc-http-api-data-doc
Architecture: all
Section: doc
-Depends: ${haskell:Depends},
+Depends:
+ ${haskell:Depends},
${misc:Depends},
-Recommends: ${haskell:Recommends},
-Suggests: ${haskell:Suggests},
-Conflicts: ${haskell:Conflicts},
+Recommends:
+ ${haskell:Recommends},
+Suggests:
+ ${haskell:Suggests},
+Conflicts:
+ ${haskell:Conflicts},
Description: ${haskell:ShortDescription}${haskell:ShortBlurb}
${haskell:LongDescription}
.
diff --git a/p/haskell-http-api-data/debian/rules b/p/haskell-http-api-data/debian/rules
index 82fbf1b26..a3600f64c 100755
--- a/p/haskell-http-api-data/debian/rules
+++ b/p/haskell-http-api-data/debian/rules
@@ -3,12 +3,7 @@
DEB_CABAL_PACKAGE = http-api-data
DEB_DEFAULT_COMPILER = ghc
-# ghci is broken on armel (#839840)
-ifeq (,$(filter $(DEB_BUILD_ARCH),armel))
DEB_ENABLE_TESTS = yes
-else
-DEB_ENABLE_TESTS = no
-endif
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/hlibrary.mk