summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2016-10-09 13:14:41 -0400
committerClint Adams <clint@debian.org>2016-10-13 14:33:53 -0400
commite36810ed4b795acb3f0d2f198e01232f87702222 (patch)
tree8befe3ae36d105bc1b8d0e39414dcc58ceb62ac3
parent2a20636d1b5edd9baac94ac65d72da2bf0fc0807 (diff)
downloadDHG_packages-e36810ed4b795acb3f0d2f198e01232f87702222.tar.gz
attoparsec: patch out fail, build with ghc 8 in experimental
-rw-r--r--p/haskell-attoparsec/debian/changelog6
-rw-r--r--p/haskell-attoparsec/debian/control8
-rw-r--r--p/haskell-attoparsec/debian/patches/no-fail32
-rw-r--r--p/haskell-attoparsec/debian/patches/series1
4 files changed, 41 insertions, 6 deletions
diff --git a/p/haskell-attoparsec/debian/changelog b/p/haskell-attoparsec/debian/changelog
index c92862e66..eda85f7b3 100644
--- a/p/haskell-attoparsec/debian/changelog
+++ b/p/haskell-attoparsec/debian/changelog
@@ -1,3 +1,9 @@
+haskell-attoparsec (0.13.1.0-2) experimental; urgency=medium
+
+ * Patch out use of empty 'fail' library.
+
+ -- Clint Adams <clint@debian.org> Sun, 09 Oct 2016 13:13:21 -0400
+
haskell-attoparsec (0.13.1.0-1) unstable; urgency=medium
* New upstream release
diff --git a/p/haskell-attoparsec/debian/control b/p/haskell-attoparsec/debian/control
index 3606c5931..c3208c9bd 100644
--- a/p/haskell-attoparsec/debian/control
+++ b/p/haskell-attoparsec/debian/control
@@ -6,11 +6,8 @@ Section: haskell
Build-Depends: debhelper (>= 9),
haskell-devscripts (>= 0.10),
cdbs,
- ghc,
+ ghc (>= 8),
ghc-prof,
- libghc-fail-dev (>= 4.9),
- libghc-fail-dev (<< 4.10),
- libghc-fail-prof,
libghc-scientific-dev (>= 0.3.1),
libghc-scientific-dev (<< 0.4),
libghc-scientific-prof,
@@ -27,13 +24,12 @@ Build-Depends: debhelper (>= 9),
libghc-text-dev,
libghc-vector-dev,
Build-Depends-Indep: ghc-doc,
- libghc-fail-doc,
libghc-scientific-doc,
libghc-semigroups-doc,
libghc-text-doc,
Standards-Version: 3.9.8
Homepage: https://github.com/bos/attoparsec
-Vcs-Browser: https://anonscm.debian.org/cgit/pkg-haskell/DHG_packages.git/
+Vcs-Browser: https://anonscm.debian.org/cgit/pkg-haskell/DHG_packages.git/tree/p/haskell-attoparsec
Vcs-Git: https://anonscm.debian.org/git/pkg-haskell/DHG_packages.git
Package: libghc-attoparsec-dev
diff --git a/p/haskell-attoparsec/debian/patches/no-fail b/p/haskell-attoparsec/debian/patches/no-fail
new file mode 100644
index 000000000..dc6e9bd4d
--- /dev/null
+++ b/p/haskell-attoparsec/debian/patches/no-fail
@@ -0,0 +1,32 @@
+--- a/attoparsec.cabal
++++ b/attoparsec.cabal
+@@ -52,8 +52,7 @@ library
+
+ if !impl(ghc >= 8.0)
+ -- Data.Semigroup && Control.Monad.Fail are available in base-4.9+
+- build-depends: fail == 4.9.*,
+- semigroups >=0.16.1 && <0.19
++ build-depends: semigroups >=0.16.1 && <0.19
+
+ exposed-modules: Data.Attoparsec
+ Data.Attoparsec.ByteString
+@@ -120,8 +119,7 @@ test-suite tests
+
+ if !impl(ghc >= 8.0)
+ -- Data.Semigroup && Control.Monad.Fail are available in base-4.9+
+- build-depends: fail == 4.9.*,
+- semigroups >=0.16.1 && <0.19
++ build-depends: semigroups >=0.16.1 && <0.19
+
+ benchmark benchmarks
+ type: exitcode-stdio-1.0
+@@ -166,8 +164,7 @@ benchmark benchmarks
+
+ if !impl(ghc >= 8.0)
+ -- Data.Semigroup && Control.Monad.Fail are available in base-4.9+
+- build-depends: fail == 4.9.*,
+- semigroups >=0.16.1 && <0.19
++ build-depends: semigroups >=0.16.1 && <0.19
+
+ source-repository head
+ type: git
diff --git a/p/haskell-attoparsec/debian/patches/series b/p/haskell-attoparsec/debian/patches/series
index 4ac7ef72c..b3653e66b 100644
--- a/p/haskell-attoparsec/debian/patches/series
+++ b/p/haskell-attoparsec/debian/patches/series
@@ -1 +1,2 @@
no-threaded-testsuite
+no-fail