summaryrefslogtreecommitdiff
path: root/README.md
diff options
context:
space:
mode:
authorJoachim Breitner <mail@joachim-breitner.de>2017-05-06 17:24:07 -0400
committerJoachim Breitner <mail@joachim-breitner.de>2017-05-06 17:24:07 -0400
commitb5ef99c4c203b2f7f1a968f384f80d9d15f01c99 (patch)
tree556a0e46d2991173003f7bc47200a02189fccef5 /README.md
parentcfb93a6d362be9922bf1263b3745e9cccddd43ae (diff)
downloadDHG_packages-b5ef99c4c203b2f7f1a968f384f80d9d15f01c99.tar.gz
Line-wrap README
Diffstat (limited to 'README.md')
-rw-r--r--README.md20
1 files changed, 14 insertions, 6 deletions
diff --git a/README.md b/README.md
index d35f2dafa..7b65d8c91 100644
--- a/README.md
+++ b/README.md
@@ -16,6 +16,7 @@ repository.
Also, our work is maintaining the debian/ directory, so we decided to track
only that, and _not_ upstream sources. Therefore, the directory structure for a
Haskell package foo is as follows:
+
/p/ -- root of all packaging
/p/haskell-foo/ -- package name (Debian source package name)
/p/haskell-foo/debian/ -- packaging directory
@@ -41,12 +42,14 @@ Packages are in one of three states:
* `UNRELEASED` in `debian/changelog`:
- Changes (compared to the version in the archive) present, package not ready for upload.
+ Changes (compared to the version in the archive) present, package not ready
+ for upload.
* `unstable` in `debian/changelog`, no corresponding git tag:
- Changes (compared to the version in the archive) present, package ready for upload.
+ Changes (compared to the version in the archive) present, package ready for
+ upload.
* `unstable` in `debian/changelog`, corresponding tag present
@@ -65,7 +68,12 @@ In the full debian version, `:` and `~` are replaced by `_`.
Debian Haskell Tools
--------------------
-We provide tools for a number of repeated tasks, such as tagging, upgrading, knowing what to build and what to upgrade, etc. They are provided in the `pkg-haskell-tools` package, available in sid, or at ssh://git.debian.org/git/pkg-haskell/pkg-haskell-tools.git (git://anonscm.debian.org/pkg-haskell/pkg-haskell-tools.git for non-Debian-developers).
+We provide tools for a number of repeated tasks, such as tagging, upgrading,
+knowing what to build and what to upgrade, etc. They are provided in the
+`pkg-haskell-tools` package, available in sid, or at
+ssh://git.debian.org/git/pkg-haskell/pkg-haskell-tools.git
+(git://anonscm.debian.org/pkg-haskell/pkg-haskell-tools.git for
+non-Debian-developers).
All tools are under the `dht` prefix, and it has a manpage (man dht) or at
<file:///usr/share/doc/pkg-haskell-tools/dht.html>.
@@ -77,9 +85,9 @@ Useful general tools
* `origtargz`:
In order to download and extract upstream sources in one go, simply run
- `origtargz` inside the `haskell-foo/` directory. You can also run this command
- after you increased the version number in `debian/changelog`, and it will
- clean out `haskell-foo` before.
+ `origtargz` inside the `haskell-foo/` directory. You can also run this
+ command after you increased the version number in `debian/changelog`, and it
+ will clean out `haskell-foo` before.
* `git clean -d -x -n`: