summaryrefslogtreecommitdiff
path: root/p/c2hs
diff options
context:
space:
mode:
authorerikd <erikd@mega-nerd.com>2009-07-20 09:42:20 +0400
committererikd <erikd@mega-nerd.com>2009-07-20 09:42:20 +0400
commit3107793b9b493eb8a2f76e9d0788cd3c657d116c (patch)
tree6227d239aa81f4834fe97f953973c1f5ed7e0ea8 /p/c2hs
parent9e8d0c5e2f7b8572e7b04b52881fb602432b4a10 (diff)
downloadDHG_packages-3107793b9b493eb8a2f76e9d0788cd3c657d116c.tar.gz
c2hs: Switch to haskell-devscripts based build. UNRELEASED.
Diffstat (limited to 'p/c2hs')
-rw-r--r--p/c2hs/debian/c2hs.install4
-rw-r--r--p/c2hs/debian/changelog13
-rw-r--r--p/c2hs/debian/control12
-rwxr-xr-xp/c2hs/debian/rules129
-rw-r--r--p/c2hs/debian/watch4
5 files changed, 28 insertions, 134 deletions
diff --git a/p/c2hs/debian/c2hs.install b/p/c2hs/debian/c2hs.install
index cb2818045..666a18ec7 100644
--- a/p/c2hs/debian/c2hs.install
+++ b/p/c2hs/debian/c2hs.install
@@ -1,2 +1,2 @@
-debian/tmp/usr/bin/*
-debian/tmp/usr/share/*
+dist-ghc6/build/c2hs/c2hs usr/bin
+C2HS.hs usr/share/c2hs
diff --git a/p/c2hs/debian/changelog b/p/c2hs/debian/changelog
index b70e1609c..5c87a4c69 100644
--- a/p/c2hs/debian/changelog
+++ b/p/c2hs/debian/changelog
@@ -1,3 +1,16 @@
+c2hs (0.15.1-5) UNRELEASED; urgency=low
+
+ * debian/control:
+ - Maintainer is now Debian Haskell Group with two uploaders.
+ - Make Vcs-* fields point to darcs.
+ - Homepage now points to Hackage.
+ - Standards version 3.8.2.
+ * debian/watch: Point to Hackage.
+ * debian/rules: Switch to haskell-devscripts for build.
+ * debian/c2hs.install: Changes required due to change in build.
+
+ -- Erik de Castro Lopo <erikd@mega-nerd.com> Sun, 19 Jul 2009 16:57:09 +1000
+
c2hs (0.15.1-4) unstable; urgency=low
* debian/control:
diff --git a/p/c2hs/debian/control b/p/c2hs/debian/control
index e7afd4677..3e18e5c07 100644
--- a/p/c2hs/debian/control
+++ b/p/c2hs/debian/control
@@ -1,15 +1,15 @@
Source: c2hs
Section: devel
Priority: optional
-Maintainer: Arjan Oosting <arjan@debian.org>
-Build-Depends: alex, debhelper (>= 5.0.0), dpatch,
+Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
+Uploaders: Arjan Oosting <arjan@debian.org>, Erik de Castro Lopo <erikd@mega-nerd.com>
+Build-Depends: alex, debhelper (>= 5.0.0), dpatch, cdbs,
dpkg-dev (>= 1.13.19), ghc6 (>= 6.8.2), happy
Build-Depends-Indep: docbook-xsl, xsltproc
Build-Conflicts: libghc6-wash-dev
-Standards-Version: 3.7.3
-Vcs-Svn: svn://svn.debian.org/svn/pkg-haskell/packages/c2hs/trunk
-Vcs-Browser: http://svn.debian.org/wsvn/pkg-haskell/packages/c2hs/trunk
-Homepage: http://www.cse.unsw.edu.au/~chak/haskell/c2hs/
+Standards-Version: 3.8.2
+Vcs-Darcs: http://darcs.debian.org/darcs/pkg-haskell/c2hs
+Homepage: http://hackage.haskell.org/package/c2hs
Package: c2hs
Architecture: any
diff --git a/p/c2hs/debian/rules b/p/c2hs/debian/rules
index bec60d0a7..e5446465d 100755
--- a/p/c2hs/debian/rules
+++ b/p/c2hs/debian/rules
@@ -1,128 +1,11 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-#
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-#
-# Modified to make a template file for a multi-binary package with separated
-# build-arch and build-indep targets by Bill Allombert 2001
-# include dpatch
-include /usr/share/dpatch/dpatch.make
+# Use dpatch for patches.
+include /usr/share/cdbs/1/rules/dpatch.mk
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# Standard way of building Haskell libraries .
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/hlibrary.mk
-# This has to be exported to make some magic below work.
-export DH_OPTIONS
+build/$(CABAL_PACKAGE) :: build-ghc6-stamp
-# These are used for cross-compiling and for saving the configure
-# script
-# from having to guess our platform (since we know it already)
-DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
-export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
-export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
-
-# Autoconf 2.52 and higher goes into crosscompiling mode when --host
-# is specified, so only pass --host when it is necessary.
-#ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
-# CONFIGURE_FLAGS := --build=$(DEB_HOST_GNU_TYPE)
-#else
-# CONFIGURE_FLAGS := --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
-#endif
-
-# ghc -split-objs only works on i386 and amd64
-ifneq (,$(findstring $(DEB_HOST_ARCH),"i386 amd64"))
-CONFIGURE_FLAGS += --enable-split-objs
-endif
-
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-configure: configure-stamp
-configure-stamp: patch-stamp
- dh_testdir
- ghc6 -package Cabal Setup.hs -o setup
- ./setup configure --prefix=/usr --with-compiler=/usr/bin/ghc6 $(CONFIGURE_FLAGS)
- touch configure-stamp
-
-build: build-arch
-build-arch: build-arch-stamp
-build-arch-stamp: configure-stamp
- ./setup build
- touch build-arch-stamp
-
-build-indep: build-indep-stamp
-build-indep-stamp: configure-stamp
- cp doc/users_guide/fptools.css doc/
- make -C doc
- touch build-indep-stamp
-
-clean: clean-patched unpatch
-clean-patched:
- dh_testdir
- dh_testroot
- rm -f build-arch-stamp build-indep-stamp configure-stamp
- if [ -e setup ] && [ -e .setup-config ] ; then ./setup clean ; fi
- rm -rf dist
- # remove Cabal setup files
- rm -f setup Setup.hi Setup.o
- rm -f doc/fptools.css doc/users_guide/*.html
- dh_clean
-
-install: install-arch install-indep
-install-arch: build-arch-stamp
- dh_testdir
- dh_testroot
- dh_clean -k -s
- dh_installdirs -s
- ./setup copy --copy-prefix="$(CURDIR)/debian/tmp/usr"
- rm -f $(CURDIR)/debian/tmp/usr/share/doc/c2hs-0.15.1/COPYING
- rmdir $(CURDIR)/debian/tmp/usr/share/doc/c2hs-0.15.1/
- dh_install -s
-
-install-indep: build-indep-stamp
- dh_testdir
- dh_testroot
- dh_clean -k -i
- dh_installdirs -i
-
-# Must not depend on anything. This is to be called by
-# binary-arch/binary-indep
-# in another 'make' thread.
-binary-common:
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-arch binary-indep
-# Build architecture dependant packages using the common target.
-binary-arch: install-arch
- $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
-
-# Build architecture independant packages using the common target.
-binary-indep: install-indep
- $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
-
-.PHONY: configure build build-arch build-indep clean clean-patched install install-arch install-indep binary-arch binary-indep binary
diff --git a/p/c2hs/debian/watch b/p/c2hs/debian/watch
index 19967b861..6b9a50d8f 100644
--- a/p/c2hs/debian/watch
+++ b/p/c2hs/debian/watch
@@ -1,4 +1,2 @@
-# format version number, currently 3; this line is compulsory!
version=3
-
-http://www.cse.unsw.edu.au/~chak/haskell/c2hs/c2hs-([.0-9]*)\.tar\.gz
+http://hackage.haskell.org/packages/archive/c2hs/([\d\.]+)/c2hs-([\d\.]+)\.tar\.gz