summaryrefslogtreecommitdiff
path: root/p/frown/debian
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2011-12-07 22:27:01 +0400
committerHelmut Grohne <helmut@subdivi.de>2011-12-07 22:27:01 +0400
commit1a4503af7c8fd4ab4eb68a8da4d820ae14805f3b (patch)
tree16c55ae4df9487f63c1f37504bd1ee3aa7dd0304 /p/frown/debian
parentdc0181f37a963c48273fddc953452da74c8b27ce (diff)
downloadDHG_packages-1a4503af7c8fd4ab4eb68a8da4d820ae14805f3b.tar.gz
frown: fix logic error in debian/patches/07_no-n-plus-k-pattern
Diffstat (limited to 'p/frown/debian')
-rw-r--r--p/frown/debian/changelog8
-rw-r--r--p/frown/debian/patches/07_no-n-plus-k-pattern2
2 files changed, 9 insertions, 1 deletions
diff --git a/p/frown/debian/changelog b/p/frown/debian/changelog
index c79ff7c42..7814980a5 100644
--- a/p/frown/debian/changelog
+++ b/p/frown/debian/changelog
@@ -1,3 +1,11 @@
+frown (0.6.1-11.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Fix "OOM on compiling any remotely valid grammer" fix logic error in
+ debian/patches/07_no-n-plus-k-pattern (Closes: #650808)
+
+ -- Helmut Grohne <helmut@subdivi.de> Wed, 07 Dec 2011 17:35:30 +0100
+
frown (0.6.1-11) unstable; urgency=low
[ Marco Silva ]
diff --git a/p/frown/debian/patches/07_no-n-plus-k-pattern b/p/frown/debian/patches/07_no-n-plus-k-pattern
index a6afc1f80..6c4b0517f 100644
--- a/p/frown/debian/patches/07_no-n-plus-k-pattern
+++ b/p/frown/debian/patches/07_no-n-plus-k-pattern
@@ -9,7 +9,7 @@ Index: frown-0.6.1/SearchTree.lhs
-> build (n + 1) x = (Node l a v r, z)
-> where m = n `div` 2
+> build n x = (Node l a v r, z)
-+> where m = n-1 `div` 2
++> where m = (n-1) `div` 2
> (l, (a, v) : y) = build m x
-> (r, z) = build (n - m) y
+> (r, z) = build (n - 1 - m) y