summaryrefslogtreecommitdiff
path: root/p/frown/debian
diff options
context:
space:
mode:
authorIlias Tsitsimpis <i.tsitsimpis@gmail.com>2016-05-22 14:40:22 +0300
committerIlias Tsitsimpis <i.tsitsimpis@gmail.com>2016-05-23 14:14:20 +0300
commitbe7dc911dffa9f344e171fa8a33486f29f4b3d46 (patch)
tree9cee43125b64075855298a92c33dc9fd1d3ba3d2 /p/frown/debian
parentfd8ba9128b44a105780870cc5251c5d8529eeeb9 (diff)
downloadDHG_packages-be7dc911dffa9f344e171fa8a33486f29f4b3d46.tar.gz
frown: Add patch 'fix-pdf-generation'
Due to an error in the way Makefile produces the doc files, the Manual.pdf file was not generated correctly. This has been fixed by patching the Makefile.
Diffstat (limited to 'p/frown/debian')
-rw-r--r--p/frown/debian/changelog4
-rw-r--r--p/frown/debian/patches/fix-pdf-generation30
-rw-r--r--p/frown/debian/patches/series1
3 files changed, 35 insertions, 0 deletions
diff --git a/p/frown/debian/changelog b/p/frown/debian/changelog
index e0e41fd3c..2d6da1073 100644
--- a/p/frown/debian/changelog
+++ b/p/frown/debian/changelog
@@ -12,6 +12,10 @@ frown (0.6.2.3-2) UNRELEASED; urgency=medium
* Disable dbgsym generation.
GHC cannot produce debugging symbols, so the dbgsym package ends
up being empty.
+ * Add patch 'fix-pdf-generation'.
+ Due to an error in the way Makefile produces the doc files, the
+ Manual.pdf file was not generated correctly. This has been fixed
+ by patching the Makefile.
-- Ilias Tsitsimpis <i.tsitsimpis@gmail.com> Wed, 18 May 2016 16:36:18 +0300
diff --git a/p/frown/debian/patches/fix-pdf-generation b/p/frown/debian/patches/fix-pdf-generation
new file mode 100644
index 000000000..b2d5f9e9a
--- /dev/null
+++ b/p/frown/debian/patches/fix-pdf-generation
@@ -0,0 +1,30 @@
+Description: Do not override the Manual.dvi file
+ When generating the html pages, the Manual.dvi file gets overwritten
+ meaning that the next time make will be run, the Manual.pdf file will
+ be generated again. In addition, since this dvi file has now been
+ produced using different flags for the lhs2Tex program, the result
+ is different from the expected one. Fix that by making the html
+ target depend on the Manual.dvi one and not rebuilting that file.
+Author: Ilias Tsitsimpis <i.tsitsimpis@gmail.com>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: b/Manual/Makefile
+===================================================================
+--- a/Manual/Makefile
++++ b/Manual/Makefile
+@@ -102,14 +102,7 @@ gv : $(file).ps
+ acro : $(file).pdf
+ /opt/Acrobat7/acroread $(file).pdf &
+
+-html: $(file).lhs $(file).fmt $(sessions)
+- lhs2TeX --math $(file).lhs > $(file).tex
+- latex $(file)
+- bibtex $(file)
+- latex $(file)
+- latex $(file)
+- latex $(file)
+-# the above commands are only used to produce a `.bbl' file
++html: $(file).lhs $(file).fmt $(file).dvi $(sessions)
+ lhs2TeX --tt -lhtml=True $(file).lhs > $(file).tex
+ hevea -fix $(file).tex
+ hevea -fix $(file).tex
diff --git a/p/frown/debian/patches/series b/p/frown/debian/patches/series
index ecbeae779..65d10454d 100644
--- a/p/frown/debian/patches/series
+++ b/p/frown/debian/patches/series
@@ -1 +1,2 @@
05_only-build-pdf
+fix-pdf-generation