summaryrefslogtreecommitdiff
path: root/p/ftphs
diff options
context:
space:
mode:
authorJohn Goerzen <jgoerzen@complete.org>2010-02-19 18:58:45 +0300
committerJohn Goerzen <jgoerzen@complete.org>2010-02-19 18:58:45 +0300
commit322398b0865fa1d13417d9fd924064a6c317e462 (patch)
tree91efc0c7c457cbe13e22937fbbe91aba135a3ba7 /p/ftphs
parent019d89a82a6fc68a38008a9248de9602c1102434 (diff)
downloadDHG_packages-322398b0865fa1d13417d9fd924064a6c317e462.tar.gz
ftphs: Updating with standard Haskell build stuff
Diffstat (limited to 'p/ftphs')
-rw-r--r--p/ftphs/debian/compat2
-rw-r--r--p/ftphs/debian/gbp.conf2
-rwxr-xr-xp/ftphs/debian/rules149
3 files changed, 6 insertions, 147 deletions
diff --git a/p/ftphs/debian/compat b/p/ftphs/debian/compat
index b8626c4cf..7ed6ff82d 100644
--- a/p/ftphs/debian/compat
+++ b/p/ftphs/debian/compat
@@ -1 +1 @@
-4
+5
diff --git a/p/ftphs/debian/gbp.conf b/p/ftphs/debian/gbp.conf
new file mode 100644
index 000000000..cec628c74
--- /dev/null
+++ b/p/ftphs/debian/gbp.conf
@@ -0,0 +1,2 @@
+[DEFAULT]
+pristine-tar = True
diff --git a/p/ftphs/debian/rules b/p/ftphs/debian/rules
index 5a0107306..bc087e2c1 100755
--- a/p/ftphs/debian/rules
+++ b/p/ftphs/debian/rules
@@ -1,149 +1,6 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# Standard way of building Haskell libraries .
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/hlibrary.mk
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-# shared library versions, option 1
-version=2.0.5
-major=2
-# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
-#version=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
-#major=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- # Add here commands to configure the package.
-
- touch configure-stamp
-
-
-build: build-stamp
-build-stamp: configure-stamp
- dh_testdir
-
- #make test-ghc6
- # Add here commands to compile the package.
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- -./setup clean
- -make clean
- -rm -rf setup Setup.hi Setup.ho Setup.o .*config* dist html
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs -a
-
- # Add here commands to install the package into debian/tmp
- dh_haskell -a
- dh_haskell_depends -a
- make test-ghc
-
-builddocs: builddocs-stamp
-builddocs-stamp:
- dh_testdir
-
- #make test-hugs
-
-installdocs: builddocs
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs -i
-
- dh_haskell -i
- #make test-hugs
-
-# Build architecture-independent files here.
-binary-indep: builddocs installdocs
- dh_testdir
- dh_testroot
- dh_installchangelogs -i
- dh_installdocs -i
- dh_installexamples -i
-# dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman -i
- dh_link -i
- dh_strip -i
- dh_compress -i
- dh_fixperms -i
-# dh_perl
-# dh_python
-# dh_makeshlibs
- dh_installdeb -i
- dh_shlibdeps -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs -a
- dh_installdocs -a
- dh_installexamples -a
-# dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman -a
- dh_link -a
- dh_strip -a
- dh_compress -a
- dh_fixperms -a
-# dh_perl
-# dh_python
-# dh_makeshlibs
- dh_installdeb -a
- dh_shlibdeps -a
- dh_gencontrol -a
- dh_md5sums -a
- dh_builddeb -a
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure