summaryrefslogtreecommitdiff
path: root/p/happy
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2015-12-22 02:33:52 +0000
committerColin Watson <cjwatson@debian.org>2015-12-22 02:33:52 +0000
commit4c4a40bea16b7d2c38874ec69d0e9e517e456893 (patch)
tree7092241f34648c6d5cd14395b48c36e662d25d27 /p/happy
parente099cdfbe4e63c739e17f44b6b3c13785e562b7f (diff)
downloadDHG_packages-4c4a40bea16b7d2c38874ec69d0e9e517e456893.tar.gz
happy: Implement a stage1 profile build for bootstrapping.
Diffstat (limited to 'p/happy')
-rw-r--r--p/happy/debian/changelog6
-rw-r--r--p/happy/debian/control5
-rwxr-xr-xp/happy/debian/rules7
3 files changed, 16 insertions, 2 deletions
diff --git a/p/happy/debian/changelog b/p/happy/debian/changelog
index 154a905a9..d85fc40e5 100644
--- a/p/happy/debian/changelog
+++ b/p/happy/debian/changelog
@@ -1,3 +1,9 @@
+happy (1.19.5-5) UNRELEASED; urgency=medium
+
+ * Implement a stage1 profile build for bootstrapping.
+
+ -- Colin Watson <cjwatson@debian.org> Tue, 22 Dec 2015 01:54:14 +0000
+
happy (1.19.5-4) unstable; urgency=medium
* Switch Vcs-Git/Vcs-Browser headers to new location.
diff --git a/p/happy/debian/control b/p/happy/debian/control
index 1646f71d2..a6f376efa 100644
--- a/p/happy/debian/control
+++ b/p/happy/debian/control
@@ -6,7 +6,8 @@ Uploaders: Iain Lane <laney@ubuntu.com>
Standards-Version: 3.9.6
Build-Depends: cdbs (>= 0.4.59),
haskell-devscripts (>= 0.10),
- debhelper (>= 9),
+ debhelper (>= 9.20141010),
+ dpkg-dev (>= 1.17.14),
autoconf,
docbook-utils,
ghc (>= 7.10),
@@ -14,7 +15,7 @@ Build-Depends: cdbs (>= 0.4.59),
docbook-xml,
xsltproc,
libghc-mtl-dev,
- happy
+ happy <!stage1>
Homepage: http://www.haskell.org/happy
Vcs-Git: git://git.debian.org/git/pkg-haskell/DHG_packages.git
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-haskell/DHG_packages.git/
diff --git a/p/happy/debian/rules b/p/happy/debian/rules
index 9aee53eba..3af4434be 100755
--- a/p/happy/debian/rules
+++ b/p/happy/debian/rules
@@ -13,6 +13,13 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/hlibrary.mk
include /usr/share/cdbs/1/rules/utils.mk
+ifneq (,$(filter stage1,$(DEB_BUILD_PROFILES)))
+DEB_SETUP_GHC_CONFIGURE_ARGS += --with-happy=/bin/true
+
+cleanbuilddir/happy::
+ cp -a dist/build/happy/happy-tmp/*.hs src/
+endif
+
clean::
[ ! -f doc/config.mk ] || $(MAKE) -C doc clean