summaryrefslogtreecommitdiff
path: root/p/haskell-aeson
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2016-01-10 22:56:01 -0500
committerClint Adams <clint@debian.org>2016-01-10 22:57:36 -0500
commit11bbcb8209fd2c5d27b13a742cca04be0f76f94e (patch)
tree4c6094b5a501f303c324f027d334a93716feb2c0 /p/haskell-aeson
parentce79192a9f961a169892300cdf274e7e105133a6 (diff)
downloadDHG_packages-11bbcb8209fd2c5d27b13a742cca04be0f76f94e.tar.gz
aeson: Upgrading from 0.8.0.2 to 0.10.0.0
Diffstat (limited to 'p/haskell-aeson')
-rw-r--r--p/haskell-aeson/debian/changelog6
-rw-r--r--p/haskell-aeson/debian/control4
-rw-r--r--p/haskell-aeson/debian/patches/th-option.diff18
-rw-r--r--p/haskell-aeson/debian/patches/threaded-option.diff16
4 files changed, 23 insertions, 21 deletions
diff --git a/p/haskell-aeson/debian/changelog b/p/haskell-aeson/debian/changelog
index d37532254..fd339a27d 100644
--- a/p/haskell-aeson/debian/changelog
+++ b/p/haskell-aeson/debian/changelog
@@ -1,3 +1,9 @@
+haskell-aeson (0.10.0.0-1) unstable; urgency=medium
+
+ * New upstream release
+
+ -- Clint Adams <clint@debian.org> Sun, 10 Jan 2016 22:56:01 -0500
+
haskell-aeson (0.8.0.2-5) unstable; urgency=medium
* Switch Vcs-Git/Vcs-Browser headers to new location.
diff --git a/p/haskell-aeson/debian/control b/p/haskell-aeson/debian/control
index c7910e3bf..236feb13c 100644
--- a/p/haskell-aeson/debian/control
+++ b/p/haskell-aeson/debian/control
@@ -8,7 +8,7 @@ Build-Depends: debhelper (>= 9),
cdbs,
ghc,
ghc-prof,
- libghc-attoparsec-dev (>= 0.11.3.4),
+ libghc-attoparsec-dev (>= 0.13.0.1),
libghc-attoparsec-prof,
libghc-dlist-dev (>= 0.2),
libghc-dlist-prof,
@@ -23,7 +23,7 @@ Build-Depends: debhelper (>= 9),
libghc-syb-prof,
libghc-text-dev (>= 1.1.1.0),
libghc-text-prof,
- libghc-unordered-containers-dev (>= 0.2.3.0),
+ libghc-unordered-containers-dev (>= 0.2.5.0),
libghc-unordered-containers-prof,
libghc-vector-dev (>= 0.7.1),
libghc-vector-prof,
diff --git a/p/haskell-aeson/debian/patches/th-option.diff b/p/haskell-aeson/debian/patches/th-option.diff
index 1c97af592..9901cc6a8 100644
--- a/p/haskell-aeson/debian/patches/th-option.diff
+++ b/p/haskell-aeson/debian/patches/th-option.diff
@@ -1,11 +1,9 @@
-Index: aeson-0.8.0.2/aeson.cabal
-===================================================================
---- aeson-0.8.0.2.orig/aeson.cabal 2014-12-23 13:51:42.483548266 +0100
-+++ aeson-0.8.0.2/aeson.cabal 2014-12-23 13:51:42.483548266 +0100
-@@ -80,6 +80,10 @@
+--- a/aeson.cabal
++++ b/aeson.cabal
+@@ -62,6 +62,10 @@
If true then depend on time < 1.5 together with old-locale.
default: False
-
+
+flag th
+ description: build TH bits
+ default: True
@@ -13,13 +11,13 @@ Index: aeson-0.8.0.2/aeson.cabal
library
exposed-modules:
Data.Aeson
-@@ -87,7 +91,8 @@
- Data.Aeson.Generic
+@@ -70,7 +74,8 @@
+ Data.Aeson.Internal.Time
Data.Aeson.Parser
Data.Aeson.Types
- Data.Aeson.TH
+ if flag(th)
+ exposed-modules: Data.Aeson.TH
-
+
other-modules:
- Data.Aeson.Encode.ByteString
+ Data.Aeson.Encode.Builder
diff --git a/p/haskell-aeson/debian/patches/threaded-option.diff b/p/haskell-aeson/debian/patches/threaded-option.diff
index 84011527a..f1f1ef23b 100644
--- a/p/haskell-aeson/debian/patches/threaded-option.diff
+++ b/p/haskell-aeson/debian/patches/threaded-option.diff
@@ -1,11 +1,9 @@
-Index: aeson-0.8.0.2/aeson.cabal
-===================================================================
---- aeson-0.8.0.2.orig/aeson.cabal 2014-12-23 13:51:58.479832676 +0100
-+++ aeson-0.8.0.2/aeson.cabal 2014-12-23 13:52:36.524513794 +0100
-@@ -84,6 +84,10 @@
+--- a/aeson.cabal
++++ b/aeson.cabal
+@@ -66,6 +66,10 @@
description: build TH bits
default: True
-
+
+flag threaded
+ description: build threaded
+ default: True
@@ -13,10 +11,10 @@ Index: aeson-0.8.0.2/aeson.cabal
library
exposed-modules:
Data.Aeson
-@@ -132,6 +136,10 @@
+@@ -117,6 +121,10 @@
+
ghc-options: -O2 -Wall
- cpp-options: -DGENERICS
-
+
+ if flag(threaded)
+ ghc-options: -threaded
+