summaryrefslogtreecommitdiff
path: root/p/haskell-aeson
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-05-31 17:48:31 +0900
committerSean Whitton <spwhitton@spwhitton.name>2016-05-31 17:48:31 +0900
commitf064f067d948b9f34cf3fdc99f8bfa6ee2dc6a11 (patch)
treec20ddb9a899f75aba36d4edebbaf77874d11937f /p/haskell-aeson
parentd251f448c7ba1c1573648a0d287f3b9a883435e4 (diff)
downloadDHG_packages-f064f067d948b9f34cf3fdc99f8bfa6ee2dc6a11.tar.gz
refresh haskell-aeson patches
Diffstat (limited to 'p/haskell-aeson')
-rw-r--r--p/haskell-aeson/debian/changelog9
-rw-r--r--p/haskell-aeson/debian/patches/5cd5d79e8a0db136ba5f679fbcfb60c7cd17649f.patch68
-rw-r--r--p/haskell-aeson/debian/patches/a35b5570d6d729a38d68e309c3bd92f3138e3833.patch28
-rw-r--r--p/haskell-aeson/debian/patches/missing-test-modules105
-rw-r--r--p/haskell-aeson/debian/patches/series3
-rw-r--r--p/haskell-aeson/debian/patches/th-option.diff8
-rw-r--r--p/haskell-aeson/debian/patches/threaded-option.diff12
7 files changed, 18 insertions, 215 deletions
diff --git a/p/haskell-aeson/debian/changelog b/p/haskell-aeson/debian/changelog
index 29be1b448..cd92fa038 100644
--- a/p/haskell-aeson/debian/changelog
+++ b/p/haskell-aeson/debian/changelog
@@ -8,7 +8,14 @@ haskell-aeson (0.11.2.0-1) unstable; urgency=medium
[ Joachim Breitner ]
* New upstream release
- -- Joachim Breitner <nomeata@debian.org> Sat, 28 May 2016 13:35:43 +0200
+ [ Sean Whitton ]
+ * Refresh patches.
+ * Delete obsolete patches (applied upstream):
+ - missing-test-modules
+ - 5cd5d79e8a0db136ba5f679fbcfb60c7cd17649f.patch
+ - a35b5570d6d729a38d68e309c3bd92f3138e3833.patch
+
+ -- Sean Whitton <spwhitton@spwhitton.name> Tue, 31 May 2016 17:48:20 +0900
haskell-aeson (0.10.0.0-3) unstable; urgency=medium
diff --git a/p/haskell-aeson/debian/patches/5cd5d79e8a0db136ba5f679fbcfb60c7cd17649f.patch b/p/haskell-aeson/debian/patches/5cd5d79e8a0db136ba5f679fbcfb60c7cd17649f.patch
deleted file mode 100644
index 89874f27d..000000000
--- a/p/haskell-aeson/debian/patches/5cd5d79e8a0db136ba5f679fbcfb60c7cd17649f.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 5cd5d79e8a0db136ba5f679fbcfb60c7cd17649f Mon Sep 17 00:00:00 2001
-From: Bryan O'Sullivan <bos@serpentine.com>
-Date: Fri, 22 Jan 2016 10:14:42 -0800
-Subject: [PATCH] No bitwise comparison on ToJSON/ToEncoding results (gh-340)
-
----
- tests/DataFamilies/Properties.hs | 6 +++---
- tests/Properties.hs | 17 ++++++-----------
- 2 files changed, 9 insertions(+), 14 deletions(-)
-
-Index: haskell-aeson/tests/DataFamilies/Properties.hs
-===================================================================
---- haskell-aeson.orig/tests/DataFamilies/Properties.hs 2016-01-22 22:08:26.189073858 +0100
-+++ haskell-aeson/tests/DataFamilies/Properties.hs 2016-01-22 22:08:26.185073775 +0100
-@@ -61,11 +61,11 @@
- , testProperty "ApproxDefault" $
- thApproxToJSONDefault `sameAs` thApproxToEncodingDefault
- , testProperty "SomeType2ElemArray" $
-- thSomeTypeToJSON2ElemArray `sameAsV` thSomeTypeToEncoding2ElemArray
-+ thSomeTypeToJSON2ElemArray `sameAs` thSomeTypeToEncoding2ElemArray
- , testProperty "SomeTypeTaggedObject" $
-- thSomeTypeToJSONTaggedObject `sameAsV` thSomeTypeToEncodingTaggedObject
-+ thSomeTypeToJSONTaggedObject `sameAs` thSomeTypeToEncodingTaggedObject
- , testProperty "SomeTypeObjectWithSingleField" $
-- thSomeTypeToJSONObjectWithSingleField `sameAsV`
-+ thSomeTypeToJSONObjectWithSingleField `sameAs`
- thSomeTypeToEncodingObjectWithSingleField
- ]
- ]
-Index: haskell-aeson/tests/Properties.hs
-===================================================================
---- haskell-aeson.orig/tests/Properties.hs 2016-01-22 22:08:26.189073858 +0100
-+++ haskell-aeson/tests/Properties.hs 2016-01-22 22:08:26.185073775 +0100
-@@ -63,16 +63,11 @@
- result :: Result ()
- result = parse parser ()
-
---- | Perform a bit-for-bit comparison of two encoding methods.
-+-- | Perform a structural comparison of the results of two encoding
-+-- methods. Compares decoded values to account for HashMap-driven
-+-- variation in JSON object key ordering.
- sameAs :: (a -> Value) -> (a -> Encoding) -> a -> Property
- sameAs toVal toEnc v =
-- toLazyByteString (encodeToBuilder (toVal v)) ===
-- toLazyByteString (fromEncoding (toEnc v))
--
---- | Behaves like 'sameAs', but compares decoded values to account for
---- HashMap-driven variation in JSON object key ordering.
--sameAsV :: (a -> Value) -> (a -> Encoding) -> a -> Property
--sameAsV toVal toEnc v =
- eitherDecode (toLazyByteString (fromEncoding (toEnc v))) === Right (toVal v)
-
- type P6 = Product6 Int Bool String (Approx Double) (Int, Approx Double) ()
-@@ -191,11 +186,11 @@
- , testProperty "ApproxDefault" $
- thApproxToJSONDefault `sameAs` thApproxToEncodingDefault
- , testProperty "SomeType2ElemArray" $
-- thSomeTypeToJSON2ElemArray `sameAsV` thSomeTypeToEncoding2ElemArray
-+ thSomeTypeToJSON2ElemArray `sameAs` thSomeTypeToEncoding2ElemArray
- , testProperty "SomeTypeTaggedObject" $
-- thSomeTypeToJSONTaggedObject `sameAsV` thSomeTypeToEncodingTaggedObject
-+ thSomeTypeToJSONTaggedObject `sameAs` thSomeTypeToEncodingTaggedObject
- , testProperty "SomeTypeObjectWithSingleField" $
-- thSomeTypeToJSONObjectWithSingleField `sameAsV`
-+ thSomeTypeToJSONObjectWithSingleField `sameAs`
- thSomeTypeToEncodingObjectWithSingleField
- ]
- ]
diff --git a/p/haskell-aeson/debian/patches/a35b5570d6d729a38d68e309c3bd92f3138e3833.patch b/p/haskell-aeson/debian/patches/a35b5570d6d729a38d68e309c3bd92f3138e3833.patch
deleted file mode 100644
index 3ab6b94e5..000000000
--- a/p/haskell-aeson/debian/patches/a35b5570d6d729a38d68e309c3bd92f3138e3833.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From a35b5570d6d729a38d68e309c3bd92f3138e3833 Mon Sep 17 00:00:00 2001
-From: Bryan O'Sullivan <bos@serpentine.com>
-Date: Thu, 21 Jan 2016 22:24:48 -0800
-Subject: [PATCH] Fix goodProducer on 32-bit systems
-
----
- tests/UnitTests.hs | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-Index: haskell-aeson/tests/UnitTests.hs
-===================================================================
---- haskell-aeson.orig/tests/UnitTests.hs 2016-01-22 22:07:57.924492201 +0100
-+++ haskell-aeson/tests/UnitTests.hs 2016-01-22 22:07:57.920492118 +0100
-@@ -77,9 +77,12 @@
- '{' (L.head (encode wibble))
- where
- wibble = Wibble {
-- wibbleString = replicate 4030 'a'
-- , wibbleInt = undefined
-+ wibbleString = replicate k 'a'
-+ , wibbleInt = 1
- }
-+ k | arch32bit = 4047
-+ | otherwise = 4030
-+ arch32bit = (maxBound :: Int) == 2147483647
-
- -- Test decoding various UTC time formats
- --
diff --git a/p/haskell-aeson/debian/patches/missing-test-modules b/p/haskell-aeson/debian/patches/missing-test-modules
deleted file mode 100644
index 1e617c553..000000000
--- a/p/haskell-aeson/debian/patches/missing-test-modules
+++ /dev/null
@@ -1,105 +0,0 @@
---- /dev/null
-+++ b/tests/DataFamilies/Instances.hs
-@@ -0,0 +1,27 @@
-+{-# LANGUAGE FlexibleInstances, TemplateHaskell, TypeFamilies #-}
-+{-# OPTIONS_GHC -fno-warn-orphans #-}
-+
-+module DataFamilies.Instances where
-+
-+import Control.Applicative
-+import Data.Aeson.TH
-+import DataFamilies.Types
-+import Test.QuickCheck (Arbitrary(..), elements, oneof)
-+import Prelude
-+
-+instance (Arbitrary a) => Arbitrary (Approx a) where
-+ arbitrary = Approx <$> arbitrary
-+
-+instance Arbitrary (Nullary Int) where
-+ arbitrary = elements [C1, C2, C3]
-+
-+instance Arbitrary a => Arbitrary (SomeType c () a) where
-+ arbitrary = oneof [ pure Nullary
-+ , Unary <$> arbitrary
-+ , Product <$> arbitrary <*> arbitrary <*> arbitrary
-+ , Record <$> arbitrary <*> arbitrary <*> arbitrary
-+ ]
-+
-+deriveJSON defaultOptions 'C1
-+deriveJSON defaultOptions 'Nullary
-+deriveJSON defaultOptions 'Approx
---- /dev/null
-+++ b/tests/DataFamilies/Properties.hs
-@@ -0,0 +1,72 @@
-+module DataFamilies.Properties (tests) where
-+
-+import DataFamilies.Encoders
-+import DataFamilies.Instances ()
-+
-+import Properties hiding (tests)
-+
-+import Test.Framework (Test, testGroup)
-+import Test.Framework.Providers.QuickCheck2 (testProperty)
-+
-+--------------------------------------------------------------------------------
-+
-+tests :: Test
-+tests = testGroup "data families" [
-+ testGroup "template-haskell" [
-+ testGroup "toJSON" [
-+ testGroup "Nullary" [
-+ testProperty "string" (isString . thNullaryToJSONString)
-+ , testProperty "2ElemArray" (is2ElemArray . thNullaryToJSON2ElemArray)
-+ , testProperty "TaggedObject" (isTaggedObjectValue . thNullaryToJSONTaggedObject)
-+ , testProperty "ObjectWithSingleField" (isObjectWithSingleField . thNullaryToJSONObjectWithSingleField)
-+
-+ , testGroup "roundTrip" [
-+ testProperty "string" (toParseJSON thNullaryParseJSONString thNullaryToJSONString)
-+ , testProperty "2ElemArray" (toParseJSON thNullaryParseJSON2ElemArray thNullaryToJSON2ElemArray)
-+ , testProperty "TaggedObject" (toParseJSON thNullaryParseJSONTaggedObject thNullaryToJSONTaggedObject)
-+ , testProperty "ObjectWithSingleField" (toParseJSON thNullaryParseJSONObjectWithSingleField thNullaryToJSONObjectWithSingleField)
-+ ]
-+ ]
-+ , testGroup "SomeType" [
-+ testProperty "2ElemArray" (is2ElemArray . thSomeTypeToJSON2ElemArray)
-+ , testProperty "TaggedObject" (isTaggedObject . thSomeTypeToJSONTaggedObject)
-+ , testProperty "ObjectWithSingleField" (isObjectWithSingleField . thSomeTypeToJSONObjectWithSingleField)
-+ , testGroup "roundTrip" [
-+ testProperty "2ElemArray" (toParseJSON thSomeTypeParseJSON2ElemArray thSomeTypeToJSON2ElemArray)
-+ , testProperty "TaggedObject" (toParseJSON thSomeTypeParseJSONTaggedObject thSomeTypeToJSONTaggedObject)
-+ , testProperty "ObjectWithSingleField" (toParseJSON thSomeTypeParseJSONObjectWithSingleField thSomeTypeToJSONObjectWithSingleField)
-+ ]
-+ , testGroup "Approx" [
-+ testProperty "string" (isString . thApproxToJSONUnwrap)
-+ , testProperty "ObjectWithSingleField" (isObjectWithSingleField . thApproxToJSONDefault)
-+ , testGroup "roundTrip" [
-+ testProperty "string" (toParseJSON thApproxParseJSONUnwrap thApproxToJSONUnwrap)
-+ , testProperty "ObjectWithSingleField" (toParseJSON thApproxParseJSONDefault thApproxToJSONDefault)
-+ ]
-+ ]
-+ ]
-+ ]
-+ , testGroup "toEncoding" [
-+ testProperty "NullaryString" $
-+ thNullaryToJSONString `sameAs` thNullaryToEncodingString
-+ , testProperty "Nullary2ElemArray" $
-+ thNullaryToJSON2ElemArray `sameAs` thNullaryToEncoding2ElemArray
-+ , testProperty "NullaryTaggedObject" $
-+ thNullaryToJSONTaggedObject `sameAs` thNullaryToEncodingTaggedObject
-+ , testProperty "NullaryObjectWithSingleField" $
-+ thNullaryToJSONObjectWithSingleField `sameAs`
-+ thNullaryToEncodingObjectWithSingleField
-+ , testProperty "ApproxUnwrap" $
-+ thApproxToJSONUnwrap `sameAs` thApproxToEncodingUnwrap
-+ , testProperty "ApproxDefault" $
-+ thApproxToJSONDefault `sameAs` thApproxToEncodingDefault
-+ , testProperty "SomeType2ElemArray" $
-+ thSomeTypeToJSON2ElemArray `sameAsV` thSomeTypeToEncoding2ElemArray
-+ , testProperty "SomeTypeTaggedObject" $
-+ thSomeTypeToJSONTaggedObject `sameAsV` thSomeTypeToEncodingTaggedObject
-+ , testProperty "SomeTypeObjectWithSingleField" $
-+ thSomeTypeToJSONObjectWithSingleField `sameAsV`
-+ thSomeTypeToEncodingObjectWithSingleField
-+ ]
-+ ]
-+ ]
diff --git a/p/haskell-aeson/debian/patches/series b/p/haskell-aeson/debian/patches/series
index 16730ef5c..79ecbcd96 100644
--- a/p/haskell-aeson/debian/patches/series
+++ b/p/haskell-aeson/debian/patches/series
@@ -1,5 +1,2 @@
th-option.diff
threaded-option.diff
-missing-test-modules
-5cd5d79e8a0db136ba5f679fbcfb60c7cd17649f.patch
-a35b5570d6d729a38d68e309c3bd92f3138e3833.patch
diff --git a/p/haskell-aeson/debian/patches/th-option.diff b/p/haskell-aeson/debian/patches/th-option.diff
index 9901cc6a8..4dd650b99 100644
--- a/p/haskell-aeson/debian/patches/th-option.diff
+++ b/p/haskell-aeson/debian/patches/th-option.diff
@@ -1,6 +1,6 @@
--- a/aeson.cabal
+++ b/aeson.cabal
-@@ -62,6 +62,10 @@
+@@ -64,6 +64,10 @@ flag old-locale
If true then depend on time < 1.5 together with old-locale.
default: False
@@ -9,9 +9,9 @@
+ default: True
+
library
- exposed-modules:
- Data.Aeson
-@@ -70,7 +74,8 @@
+ default-language: Haskell2010
+
+@@ -74,7 +78,8 @@ library
Data.Aeson.Internal.Time
Data.Aeson.Parser
Data.Aeson.Types
diff --git a/p/haskell-aeson/debian/patches/threaded-option.diff b/p/haskell-aeson/debian/patches/threaded-option.diff
index f1f1ef23b..ed5191716 100644
--- a/p/haskell-aeson/debian/patches/threaded-option.diff
+++ b/p/haskell-aeson/debian/patches/threaded-option.diff
@@ -1,6 +1,6 @@
--- a/aeson.cabal
+++ b/aeson.cabal
-@@ -66,6 +66,10 @@
+@@ -68,6 +68,10 @@ flag th
description: build TH bits
default: True
@@ -9,16 +9,16 @@
+ default: True
+
library
- exposed-modules:
- Data.Aeson
-@@ -117,6 +121,10 @@
+ default-language: Haskell2010
- ghc-options: -O2 -Wall
+@@ -132,6 +136,10 @@ library
+
+ include-dirs: include
+ if flag(threaded)
+ ghc-options: -threaded
+
+
test-suite tests
+ default-language: Haskell2010
type: exitcode-stdio-1.0
- hs-source-dirs: tests