summaryrefslogtreecommitdiff
path: root/p/haskell-async
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2012-10-13 22:07:59 +0400
committerClint Adams <clint@debian.org>2012-10-13 22:07:59 +0400
commit0b56a8732b0c84ddb573c9f9c2f8b4e675633bfd (patch)
tree2b952a65acf0c566a1ecf9676bcda5d0e1f71c82 /p/haskell-async
parent94e43b23604556787913258417d8d71908f5482b (diff)
downloadDHG_packages-0b56a8732b0c84ddb573c9f9c2f8b4e675633bfd.tar.gz
haskell-async: Initial Check-In
Diffstat (limited to 'p/haskell-async')
-rw-r--r--p/haskell-async/debian/changelog5
-rw-r--r--p/haskell-async/debian/compat1
-rw-r--r--p/haskell-async/debian/control72
-rw-r--r--p/haskell-async/debian/copyright30
-rwxr-xr-xp/haskell-async/debian/rules6
-rw-r--r--p/haskell-async/debian/source/format1
-rw-r--r--p/haskell-async/debian/watch5
7 files changed, 120 insertions, 0 deletions
diff --git a/p/haskell-async/debian/changelog b/p/haskell-async/debian/changelog
new file mode 100644
index 000000000..133bad743
--- /dev/null
+++ b/p/haskell-async/debian/changelog
@@ -0,0 +1,5 @@
+haskell-async (2.0.1.3-1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Clint Adams <clint@debian.org> Sat, 13 Oct 2012 13:58:58 -0400
diff --git a/p/haskell-async/debian/compat b/p/haskell-async/debian/compat
new file mode 100644
index 000000000..c7930257d
--- /dev/null
+++ b/p/haskell-async/debian/compat
@@ -0,0 +1 @@
+7 \ No newline at end of file
diff --git a/p/haskell-async/debian/control b/p/haskell-async/debian/control
new file mode 100644
index 000000000..505fe5a84
--- /dev/null
+++ b/p/haskell-async/debian/control
@@ -0,0 +1,72 @@
+Source: haskell-async
+Priority: extra
+Section: haskell
+Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
+Uploaders: Clint Adams <clint@debian.org>
+Build-Depends: debhelper (>= 7.0)
+ , haskell-devscripts (>= 0.8)
+ , cdbs
+ , ghc
+ , ghc-prof
+ , libghc-stm-dev (>> 2.2)
+ , libghc-stm-dev (<< 2.5)
+ , libghc-stm-prof
+ , libghc-test-framework-dev
+ , libghc-test-framework-hunit-dev
+ , libghc-hunit-dev
+Build-Depends-Indep: ghc-doc
+ , libghc-stm-doc
+Standards-Version: 3.9.4
+Homepage: https://github.com/simonmar/async
+
+Package: libghc-async-dev
+Architecture: any
+Depends: ${shlibs:Depends}
+ , ${haskell:Depends}
+ , ${misc:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Provides: ${haskell:Provides}
+Description: run IO operations asynchronously and wait for their results
+ This package provides a higher-level interface over
+ threads, in which an (Async a) is a concurrent
+ thread that will eventually deliver a value of
+ type a. The package provides ways to create
+ Async computations, wait for their results, and
+ cancel them.
+ .
+ This package contains the normal library files.
+
+Package: libghc-async-prof
+Architecture: any
+Depends: ${haskell:Depends}
+ , ${misc:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Provides: ${haskell:Provides}
+Description: run IO operations asynchronously and wait for their results; profiling libs
+ This package provides a higher-level interface over
+ threads, in which an (Async a) is a concurrent
+ thread that will eventually deliver a value of
+ type a. The package provides ways to create
+ Async computations, wait for their results, and
+ cancel them.
+ .
+ This package contains the libraries compiled with profiling enabled.
+
+Package: libghc-async-doc
+Architecture: all
+Section: doc
+Depends: ${haskell:Depends}
+ , ${misc:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Description: run IO operations asynchronously and wait for their results; documentation
+ This package provides a higher-level interface over
+ threads, in which an (Async a) is a concurrent
+ thread that will eventually deliver a value of
+ type a. The package provides ways to create
+ Async computations, wait for their results, and
+ cancel them.
+ .
+ This package contains the documentation files.
diff --git a/p/haskell-async/debian/copyright b/p/haskell-async/debian/copyright
new file mode 100644
index 000000000..0acbb121f
--- /dev/null
+++ b/p/haskell-async/debian/copyright
@@ -0,0 +1,30 @@
+Copyright (c) 2012, Simon Marlow
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials provided
+ with the distribution.
+
+ * Neither the name of Simon Marlow nor the names of other
+ contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/p/haskell-async/debian/rules b/p/haskell-async/debian/rules
new file mode 100755
index 000000000..01f1aaf04
--- /dev/null
+++ b/p/haskell-async/debian/rules
@@ -0,0 +1,6 @@
+#!/usr/bin/make -f
+
+DEB_ENABLE_TESTS = yes
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/hlibrary.mk
diff --git a/p/haskell-async/debian/source/format b/p/haskell-async/debian/source/format
new file mode 100644
index 000000000..46ebe0266
--- /dev/null
+++ b/p/haskell-async/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt) \ No newline at end of file
diff --git a/p/haskell-async/debian/watch b/p/haskell-async/debian/watch
new file mode 100644
index 000000000..271cd22bc
--- /dev/null
+++ b/p/haskell-async/debian/watch
@@ -0,0 +1,5 @@
+version=3
+opts="downloadurlmangle=s|archive/([\w\d_-]+)/([\d\.]+)/|archive/$1/$2/$1-$2.tar.gz|,\
+filenamemangle=s|(.*)/$|async-$1.tar.gz|" \
+ http://hackage.haskell.org/packages/archive/async \
+ ([\d\.]*\d)/