summaryrefslogtreecommitdiff
path: root/p/haskell-configfile
diff options
context:
space:
mode:
authorErik de Castro Lopo <erikd@mega-nerd.com>2009-11-27 12:28:58 +0300
committerErik de Castro Lopo <erikd@mega-nerd.com>2009-11-27 12:28:58 +0300
commit2e15e2cd163c365c589509335d17c420551fef84 (patch)
tree1c0b82bef2a515f7b00557f5d5b7f3f81e689e33 /p/haskell-configfile
parent98c2a20fc17a638eea2f707019f496ce8e9eb3e1 (diff)
downloadDHG_packages-2e15e2cd163c365c589509335d17c420551fef84.tar.gz
haskell-configfile: Updated to compile with latest haske-devscrips (0.6.18).
Use CDBS based hlibrary.mk instead of dh_haskell. Update control/compat. Add build-dep on hscolour. Make lintian happy.
Diffstat (limited to 'p/haskell-configfile')
-rw-r--r--p/haskell-configfile/debian/changelog16
-rw-r--r--p/haskell-configfile/debian/compat2
-rw-r--r--p/haskell-configfile/debian/control23
-rwxr-xr-xp/haskell-configfile/debian/rules148
4 files changed, 37 insertions, 152 deletions
diff --git a/p/haskell-configfile/debian/changelog b/p/haskell-configfile/debian/changelog
index d7d0e707c..103c8ec0d 100644
--- a/p/haskell-configfile/debian/changelog
+++ b/p/haskell-configfile/debian/changelog
@@ -1,3 +1,19 @@
+haskell-configfile (1.0.5-2+nmu1) UNRELEASED; urgency=low
+
+ * NMU upload ok-ed by regular maintainer.
+ * debian/rules
+ - Convert to hlibrary.mk (dh_haskell was removed to haskell-devscripts).
+ * debian/control
+ - Depend on haskell-devscripts >= 0.6.18.
+ - Move Build-Depends-Indeps to Build-Depends.
+ - Add hscolour to build deps.
+ - Standards-Version 3.8.3
+ - Section haskell.
+ * debian/compat
+ - Version 5
+
+ -- Erik de Castro Lopo <erikd@mega-nerd.com> Mon, 23 Nov 2009 19:21:49 +1100
+
haskell-configfile (1.0.5-2) unstable; urgency=low
* Switch to Haskell team maintenance.
diff --git a/p/haskell-configfile/debian/compat b/p/haskell-configfile/debian/compat
index b8626c4cf..7ed6ff82d 100644
--- a/p/haskell-configfile/debian/compat
+++ b/p/haskell-configfile/debian/compat
@@ -1 +1 @@
-4
+5
diff --git a/p/haskell-configfile/debian/control b/p/haskell-configfile/debian/control
index 914a964b5..a9ca218f0 100644
--- a/p/haskell-configfile/debian/control
+++ b/p/haskell-configfile/debian/control
@@ -2,18 +2,28 @@ Source: haskell-configfile
Priority: optional
Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
Uploaders: John Goerzen <jgoerzen@complete.org>
-Build-Depends: debhelper (>= 4.0.0), ghc6 (>= 6.10), haskell-devscripts (>= 0.6.15), cpphs, libghc6-missingh-dev (>= 1.0.3.2), libghc6-mtl-dev, libghc6-hunit-dev, libghc6-testpack-dev
-Build-Depends-Indep: debhelper (>= 4.0.0), haddock, haskell-devscripts (>= 0.6.15), ghc6 (>= 6.8.2dfsg1), cpphs
-Standards-Version: 3.6.2
-Section: devel
+Build-Depends: debhelper (>= 5.0.0),
+ cdbs,
+ haddock,
+ hscolour,
+ ghc6 (>= 6.10),
+ haskell-devscripts (>= 0.6.18),
+ cpphs,
+ libghc6-missingh-dev (>= 1.0.3.2),
+ libghc6-regex-compat-dev,
+ libghc6-mtl-dev,
+ libghc6-hunit-dev,
+ libghc6-testpack-dev
+Standards-Version: 3.8.3
+Section: haskell
Homepage: http://software.complete.org/configfile
Vcs-Git: git://git.debian.org/git/pkg-haskell/haskell-configfile.git
Vcs-Browser: http://git.debian.org/?p=pkg-haskell/haskell-configfile.git;a=summary
Package: libghc6-configfile-dev
-Section: devel
+Section: haskell
Architecture: any
-Depends: ${haskell:Depends}, libghc6-missingh-dev (>= 1.0.3), libghc6-mtl-dev
+Depends: ${misc:Depends}, ${haskell:Depends}
Suggests: configfile-doc
Description: Parser and writer for handling sectioned config files in Haskell, GHC package
The ConfigFile module works with configuration files in a standard
@@ -30,6 +40,7 @@ Description: Parser and writer for handling sectioned config files in Haskell, G
Package: configfile-doc
Section: doc
Architecture: all
+Depends: ${misc:Depends}, ${haskell:Depends}
Description: Parser and writer for handling sectioned config files in Haskell, Documentation
The ConfigFile module works with configuration files in a standard
format that is easy for the user to edit, easy for the programmer
diff --git a/p/haskell-configfile/debian/rules b/p/haskell-configfile/debian/rules
index ca31d1f88..bc087e2c1 100755
--- a/p/haskell-configfile/debian/rules
+++ b/p/haskell-configfile/debian/rules
@@ -1,148 +1,6 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+# Standard way of building Haskell libraries .
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/hlibrary.mk
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- INSTALL_PROGRAM += -s
-endif
-
-# shared library versions, option 1
-version=2.0.5
-major=2
-# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
-#version=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
-#major=`ls src/.libs/lib*.so.* | \
-# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- # Add here commands to configure the package.
-
- touch configure-stamp
-
-
-build: build-stamp
-build-stamp: configure-stamp
- dh_testdir
-
- #make test-ghc6
- # Add here commands to compile the package.
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- -./setup clean
- -make clean
- -rm -rf setup Setup.hi Setup.ho Setup.o .*config* dist html
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs -a
-
- # Add here commands to install the package into debian/tmp
- dh_haskell -a
- dh_haskell_depends -a
- make test-ghc
-
-builddocs: builddocs-stamp
-builddocs-stamp:
- dh_testdir
-
-
-installdocs: builddocs
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs -i
-
- dh_haskell -i
- #make test-hugs disabled due to hugs disable
-
-# Build architecture-independent files here.
-binary-indep: builddocs installdocs
- dh_testdir
- dh_testroot
- dh_installchangelogs -i
- dh_installdocs -i
- dh_installexamples -i
-# dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman -i
- dh_link -i
- dh_strip -i
- dh_compress -i
- dh_fixperms -i
-# dh_perl
-# dh_python
-# dh_makeshlibs
- dh_installdeb -i
- dh_shlibdeps -i
- dh_gencontrol -i
- dh_md5sums -i
- dh_builddeb -i
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs -a
- dh_installdocs -a
- dh_installexamples -a
-# dh_install
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman -a
- dh_link -a
- dh_strip -a
- dh_compress -a
- dh_fixperms -a
-# dh_perl
-# dh_python
-# dh_makeshlibs
- dh_installdeb -a
- dh_shlibdeps -a
- dh_gencontrol -a
- dh_md5sums -a
- dh_builddeb -a
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure