summaryrefslogtreecommitdiff
path: root/p/haskell-cprng-aes
diff options
context:
space:
mode:
authorclint <clint@debian.org>2011-06-11 18:13:19 +0400
committerclint <clint@debian.org>2011-06-11 18:13:19 +0400
commite17f40244d6ce60a6f6330aa4e73b484e0295dc6 (patch)
tree0b17a6422a27af877e8a13bdc1d8422d9c5df07b /p/haskell-cprng-aes
parentb20df907285c33040beed490baf7587b4024d402 (diff)
downloadDHG_packages-e17f40244d6ce60a6f6330aa4e73b484e0295dc6.tar.gz
haskell-cprng-aes: Initial Check-In
Diffstat (limited to 'p/haskell-cprng-aes')
-rw-r--r--p/haskell-cprng-aes/debian/changelog5
-rw-r--r--p/haskell-cprng-aes/debian/compat1
-rw-r--r--p/haskell-cprng-aes/debian/control110
-rw-r--r--p/haskell-cprng-aes/debian/copyright39
-rwxr-xr-xp/haskell-cprng-aes/debian/rules4
-rw-r--r--p/haskell-cprng-aes/debian/source/format1
-rw-r--r--p/haskell-cprng-aes/debian/watch5
7 files changed, 165 insertions, 0 deletions
diff --git a/p/haskell-cprng-aes/debian/changelog b/p/haskell-cprng-aes/debian/changelog
new file mode 100644
index 000000000..7ee7b435d
--- /dev/null
+++ b/p/haskell-cprng-aes/debian/changelog
@@ -0,0 +1,5 @@
+haskell-cprng-aes (0.2.1-1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Clint Adams <clint@debian.org> Thu, 09 Jun 2011 13:17:17 -0400
diff --git a/p/haskell-cprng-aes/debian/compat b/p/haskell-cprng-aes/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/p/haskell-cprng-aes/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/p/haskell-cprng-aes/debian/control b/p/haskell-cprng-aes/debian/control
new file mode 100644
index 000000000..388710ae2
--- /dev/null
+++ b/p/haskell-cprng-aes/debian/control
@@ -0,0 +1,110 @@
+Source: haskell-cprng-aes
+Section: haskell
+Priority: extra
+Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
+Uploaders: Clint Adams <clint@debian.org>
+Build-Depends: debhelper (>= 7)
+ , cdbs
+ , haskell-devscripts (>= 0.8)
+ , ghc
+ , ghc-prof
+ , libghc-bytestring-dev
+ , libghc-bytestring-prof
+ , libghc-cereal-dev
+ , libghc-cereal-prof
+ , libghc-crypto-api-dev
+ , libghc-crypto-api-prof
+ , libghc-cryptocipher-dev
+ , libghc-cryptocipher-prof
+Build-Depends-Indep: ghc-doc
+ , libghc-bytestring-doc
+ , libghc-cereal-doc
+ , libghc-crypto-api-doc
+ , libghc-cryptocipher-doc
+Standards-Version: 3.9.2
+Homepage: http://hackage.haskell.org/package/cprng-aes
+Vcs-Darcs: http://darcs.debian.org/pkg-haskell/haskell-cprng-aes
+Vcs-Browser: http://darcs.debian.org/cgi-bin/darcsweb.cgi?r=pkg-haskell/haskell-cprng-aes
+
+Package: libghc-cprng-aes-dev
+Architecture: any
+Depends: ${haskell:Depends}
+ , ${shlibs:Depends}
+ , ${misc:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Provides: ${haskell:Provides}
+Description: pseudo-random number generator using AES in counter mode
+ This package provides a library for the Haskell programming language.
+ See http://www.haskell.org/ for more information on Haskell.
+ .
+ It contains a simple crypto pseudo-random-number-generator with
+ really good randomness property.
+ .
+ Using ent, a randomness property maker on one 1Mb sample:
+ Entropy = 7.999837 bits per byte. Optimum compression would reduce
+ the size of this 1048576 byte file by 0 percent. Chi square distribution
+ for 1048576 samples is 237.02 Arithmetic mean value of data bytes is
+ 127.3422 (127.5 = random) Monte Carlo value for Pi is 3.143589568
+ (error 0.06 percent).
+ .
+ Compared to urandom with the same sampling: Entropy = 7.999831 bits per
+ byte. Optimum compression would reduce the size of this 1048576 byte file
+ by 0 percent. Chi square distribution for 1048576 samples is 246.63
+ Arithmetic mean value of data bytes is 127.6347 (127.5 = random). Monte
+ Carlo value for Pi is 3.132465868 (error 0.29 percent).
+
+Package: libghc-cprng-aes-prof
+Architecture: any
+Depends: ${haskell:Depends}
+ , ${misc:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Provides: ${haskell:Provides}
+Description: pseudo-random number generator using AES in counter mode; profiling libraries
+ This package provides a library for the Haskell programming language,
+ compiled for profiling.
+ See http://www.haskell.org/ for more information on Haskell.
+ .
+ It contains a simple crypto pseudo-random-number-generator with
+ really good randomness property.
+ .
+ Using ent, a randomness property maker on one 1Mb sample:
+ Entropy = 7.999837 bits per byte. Optimum compression would reduce
+ the size of this 1048576 byte file by 0 percent. Chi square distribution
+ for 1048576 samples is 237.02 Arithmetic mean value of data bytes is
+ 127.3422 (127.5 = random) Monte Carlo value for Pi is 3.143589568
+ (error 0.06 percent).
+ .
+ Compared to urandom with the same sampling: Entropy = 7.999831 bits per
+ byte. Optimum compression would reduce the size of this 1048576 byte file
+ by 0 percent. Chi square distribution for 1048576 samples is 246.63
+ Arithmetic mean value of data bytes is 127.6347 (127.5 = random). Monte
+ Carlo value for Pi is 3.132465868 (error 0.29 percent).
+
+Package: libghc-cprng-aes-doc
+Section: doc
+Architecture: all
+Depends: ${misc:Depends}, ${haskell:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Description: pseudo-random number generator using AES in counter mode; documentation
+ This package provides the documentation for a library for the Haskell
+ programming language.
+ See http://www.haskell.org/ for more information on Haskell.
+ .
+ It contains a simple crypto pseudo-random-number-generator with
+ really good randomness property.
+ .
+ Using ent, a randomness property maker on one 1Mb sample:
+ Entropy = 7.999837 bits per byte. Optimum compression would reduce
+ the size of this 1048576 byte file by 0 percent. Chi square distribution
+ for 1048576 samples is 237.02 Arithmetic mean value of data bytes is
+ 127.3422 (127.5 = random) Monte Carlo value for Pi is 3.143589568
+ (error 0.06 percent).
+ .
+ Compared to urandom with the same sampling: Entropy = 7.999831 bits per
+ byte. Optimum compression would reduce the size of this 1048576 byte file
+ by 0 percent. Chi square distribution for 1048576 samples is 246.63
+ Arithmetic mean value of data bytes is 127.6347 (127.5 = random). Monte
+ Carlo value for Pi is 3.132465868 (error 0.29 percent).
diff --git a/p/haskell-cprng-aes/debian/copyright b/p/haskell-cprng-aes/debian/copyright
new file mode 100644
index 000000000..18e7653c0
--- /dev/null
+++ b/p/haskell-cprng-aes/debian/copyright
@@ -0,0 +1,39 @@
+This package was debianized by Clint Adams <clint@debian.org> on
+Thu, 09 Jun 2011 17:17:17 -0000
+
+It was downloaded from
+http://hackage.haskell.org/package/cprng-aes
+
+Upstream Authors:
+
+ Vincent Hanquez <vincent@snarc.org>
+
+Copyright:
+
+ 2010-2011 Vincent Hanquez
+
+License:
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+3. Neither the name of the author nor the names of his contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+SUCH DAMAGE.
diff --git a/p/haskell-cprng-aes/debian/rules b/p/haskell-cprng-aes/debian/rules
new file mode 100755
index 000000000..683e77bcf
--- /dev/null
+++ b/p/haskell-cprng-aes/debian/rules
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/hlibrary.mk
diff --git a/p/haskell-cprng-aes/debian/source/format b/p/haskell-cprng-aes/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/p/haskell-cprng-aes/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/p/haskell-cprng-aes/debian/watch b/p/haskell-cprng-aes/debian/watch
new file mode 100644
index 000000000..cdedb72fe
--- /dev/null
+++ b/p/haskell-cprng-aes/debian/watch
@@ -0,0 +1,5 @@
+version=3
+opts="downloadurlmangle=s|archive/([\w\d_-]+)/([\d\.]+)/|archive/$1/$2/$1-$2.tar.gz|,\
+filenamemangle=s|(.*)/$|cprng-aes-$1.tar.gz|" \
+ http://hackage.haskell.org/packages/archive/cprng-aes \
+ ([\d\.]*\d)/