summaryrefslogtreecommitdiff
path: root/p/haskell-crypto-random-api
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2013-01-12 22:05:37 +0400
committerClint Adams <clint@debian.org>2013-01-12 22:05:37 +0400
commit4bc52be952d259a1485ac2e2b533180d07b4343a (patch)
tree852c83eabdb88208d1b0ee3eb1efd23f0a4dca11 /p/haskell-crypto-random-api
parentb0c9b6f1e4bf3aa4bea1bb126ed50dc31cbfcb50 (diff)
downloadDHG_packages-4bc52be952d259a1485ac2e2b533180d07b4343a.tar.gz
haskell-crypto-random-api: Initial Check-In
Diffstat (limited to 'p/haskell-crypto-random-api')
-rw-r--r--p/haskell-crypto-random-api/debian/changelog5
-rw-r--r--p/haskell-crypto-random-api/debian/compat1
-rw-r--r--p/haskell-crypto-random-api/debian/control91
-rw-r--r--p/haskell-crypto-random-api/debian/copyright53
-rwxr-xr-xp/haskell-crypto-random-api/debian/rules4
-rw-r--r--p/haskell-crypto-random-api/debian/source/format1
-rw-r--r--p/haskell-crypto-random-api/debian/watch5
7 files changed, 160 insertions, 0 deletions
diff --git a/p/haskell-crypto-random-api/debian/changelog b/p/haskell-crypto-random-api/debian/changelog
new file mode 100644
index 000000000..c0f8f5fbc
--- /dev/null
+++ b/p/haskell-crypto-random-api/debian/changelog
@@ -0,0 +1,5 @@
+haskell-crypto-random-api (0.2.0-1) experimental; urgency=low
+
+ * Initial release.
+
+ -- Clint Adams <clint@debian.org> Sat, 12 Jan 2013 12:56:11 -0500
diff --git a/p/haskell-crypto-random-api/debian/compat b/p/haskell-crypto-random-api/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/p/haskell-crypto-random-api/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/p/haskell-crypto-random-api/debian/control b/p/haskell-crypto-random-api/debian/control
new file mode 100644
index 000000000..90c10d684
--- /dev/null
+++ b/p/haskell-crypto-random-api/debian/control
@@ -0,0 +1,91 @@
+Source: haskell-crypto-random-api
+Section: haskell
+Priority: extra
+Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
+Uploaders: Clint Adams <clint@debian.org>
+Build-Depends: debhelper (>= 7)
+ , cdbs
+ , haskell-devscripts (>= 0.8.13)
+ , ghc
+ , ghc-prof
+ , libghc-entropy-dev
+ , libghc-entropy-prof
+Build-Depends-Indep: ghc-doc
+ , libghc-entropy-doc
+Standards-Version: 3.9.4
+Homepage: http://hackage.haskell.org/package/crypto-random-api
+Vcs-Darcs: http://darcs.debian.org/pkg-haskell/haskell-crypto-random-api
+Vcs-Browser: http://darcs.debian.org/cgi-bin/darcsweb.cgi?r=pkg-haskell/haskell-crypto-random-api
+
+Package: libghc-crypto-random-api-dev
+Architecture: any
+Depends: ${haskell:Depends}
+ , ${shlibs:Depends}
+ , ${misc:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Provides: ${haskell:Provides}
+Description: simple random generators API for cryptography related code
+ This provides a class of Cryptographic Secure Random generator.
+ .
+ The main difference with the generic Haskell RNG is that it return bytes
+ instead of an integer.
+ .
+ It is quite similar to the CryptoRandomGen class in crypto-api except
+ that error are not returned to the user. Instead the user is suppose to
+ handle reseeding by using the NeedReseed and SupplyEntropy methods. For
+ other type of errors, the user is expected to generate bytes with the
+ parameters bounds explicity defined here.
+ .
+ The CPRG need to be able to generate up to 2^20 bytes in one call.
+ .
+ This package provides a library for the Haskell programming language.
+ See http://www.haskell.org/ for more information on Haskell.
+
+Package: libghc-crypto-random-api-prof
+Architecture: any
+Depends: ${haskell:Depends}
+ , ${misc:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Provides: ${haskell:Provides}
+Description: simple random generators API for crypto-related code; profiling libraries
+ This provides a class of Cryptographic Secure Random generator.
+ .
+ The main difference with the generic Haskell RNG is that it return bytes
+ instead of an integer.
+ .
+ It is quite similar to the CryptoRandomGen class in crypto-api except
+ that error are not returned to the user. Instead the user is suppose to
+ handle reseeding by using the NeedReseed and SupplyEntropy methods. For
+ other type of errors, the user is expected to generate bytes with the
+ parameters bounds explicity defined here.
+ .
+ The CPRG need to be able to generate up to 2^20 bytes in one call.
+ .
+ This package provides a library for the Haskell programming language, compiled
+ for profiling. See http://www.haskell.org/ for more information on Haskell.
+
+Package: libghc-crypto-random-api-doc
+Section: doc
+Architecture: all
+Depends: ${misc:Depends}, ${haskell:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Description: simple random generators API for cryptography related code; documentation
+ This provides a class of Cryptographic Secure Random generator.
+ .
+ The main difference with the generic Haskell RNG is that it return bytes
+ instead of an integer.
+ .
+ It is quite similar to the CryptoRandomGen class in crypto-api except
+ that error are not returned to the user. Instead the user is suppose to
+ handle reseeding by using the NeedReseed and SupplyEntropy methods. For
+ other type of errors, the user is expected to generate bytes with the
+ parameters bounds explicity defined here.
+ .
+ The CPRG need to be able to generate up to 2^20 bytes in one call.
+ .
+ This package provides the documentation for a library for the Haskell
+ programming language.
+ See http://www.haskell.org/ for more information on Haskell.
diff --git a/p/haskell-crypto-random-api/debian/copyright b/p/haskell-crypto-random-api/debian/copyright
new file mode 100644
index 000000000..e2b2db4e5
--- /dev/null
+++ b/p/haskell-crypto-random-api/debian/copyright
@@ -0,0 +1,53 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: crypto-random-api
+Upstream-Contact: Vincent Hanquez <vincent@snarc.org>
+Source: http://hackage.haskell.org/package/crypto-random-api
+
+Files: *
+Copyright: 2010-2012 Vincent Hanquez
+License: BSD-3-clause
+
+Files: debian/*
+Copyright: 2013 Clint Adams
+License: ISC
+
+License: BSD-3-clause
+ .
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ 3. Neither the name of the author nor the names of his contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+ .
+ THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE
+ FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ SUCH DAMAGE.
+
+License: ISC
+ Permission to use, copy, modify, and/or distribute this software for
+ any purpose with or without fee is hereby granted, provided that the
+ above copyright notice and this permission notice appear in all
+ copies.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL
+ WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED
+ WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE
+ AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
+ DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
+ PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+ TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+ PERFORMANCE OF THIS SOFTWARE.
diff --git a/p/haskell-crypto-random-api/debian/rules b/p/haskell-crypto-random-api/debian/rules
new file mode 100755
index 000000000..683e77bcf
--- /dev/null
+++ b/p/haskell-crypto-random-api/debian/rules
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/hlibrary.mk
diff --git a/p/haskell-crypto-random-api/debian/source/format b/p/haskell-crypto-random-api/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/p/haskell-crypto-random-api/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/p/haskell-crypto-random-api/debian/watch b/p/haskell-crypto-random-api/debian/watch
new file mode 100644
index 000000000..54c346da2
--- /dev/null
+++ b/p/haskell-crypto-random-api/debian/watch
@@ -0,0 +1,5 @@
+version=3
+opts="downloadurlmangle=s|archive/([\w\d_-]+)/([\d\.]+)/|archive/$1/$2/$1-$2.tar.gz|,\
+filenamemangle=s|(.*)/$|crypto-random-api-$1.tar.gz|" \
+ http://hackage.haskell.org/packages/archive/crypto-random-api \
+ ([\d\.]*\d)/