summaryrefslogtreecommitdiff
path: root/p/haskell-crypto/debian
diff options
context:
space:
mode:
authorJoachim Breitner <mail@joachim-breitner.de>2012-10-20 01:35:21 +0400
committerJoachim Breitner <mail@joachim-breitner.de>2012-10-20 01:35:21 +0400
commit2bec54ababf8f22c18d7c4ec7d08a22fa75e2a43 (patch)
tree562f97fe5ada1f25a569b2e5c2ddaef25dc04d05 /p/haskell-crypto/debian
parent6cbe868cdcfb44df431aff804d490b74e1f96ccf (diff)
downloadDHG_packages-2bec54ababf8f22c18d7c4ec7d08a22fa75e2a43.tar.gz
haskell-crypto: Patch still needed
Diffstat (limited to 'p/haskell-crypto/debian')
-rw-r--r--p/haskell-crypto/debian/changelog1
-rw-r--r--p/haskell-crypto/debian/patches/class-constraints.diff31
-rw-r--r--p/haskell-crypto/debian/patches/series1
3 files changed, 32 insertions, 1 deletions
diff --git a/p/haskell-crypto/debian/changelog b/p/haskell-crypto/debian/changelog
index 09fcb1bc0..11eadf1cd 100644
--- a/p/haskell-crypto/debian/changelog
+++ b/p/haskell-crypto/debian/changelog
@@ -4,7 +4,6 @@ haskell-crypto (4.2.5-1) UNRELEASED; urgency=low
against experimental
* Bump standards version, no change
* New upstream release
- + Drop class-constraints.diff, applied upstream
-- Joachim Breitner <nomeata@debian.org> Fri, 19 Oct 2012 22:29:44 +0200
diff --git a/p/haskell-crypto/debian/patches/class-constraints.diff b/p/haskell-crypto/debian/patches/class-constraints.diff
new file mode 100644
index 000000000..68e2af6c8
--- /dev/null
+++ b/p/haskell-crypto/debian/patches/class-constraints.diff
@@ -0,0 +1,31 @@
+Description: ghc 7.4 class constraints
+ This patch has been emailed to upstream Caylee Hogg.
+Author: Clint Adams <clint@debian.org>
+
+--- a/Data/Digest/SHA2.hs
++++ b/Data/Digest/SHA2.hs
+@@ -106,7 +106,7 @@
+ data Hash384 = Hash384 !Word64 !Word64 !Word64 !Word64 !Word64 !Word64 deriving (Eq, Ord)
+ data Hash224 = Hash224 !Word32 !Word32 !Word32 !Word32 !Word32 !Word32 !Word32 deriving (Eq, Ord)
+
+-instance (Integral a) => Show (Hash8 a) where
++instance (Integral a, Show a) => Show (Hash8 a) where
+ showsPrec _ (Hash8 a b c d e f g h) =
+ (showHex a) . (' ':) .
+ (showHex b) . (' ':) .
+@@ -146,7 +146,7 @@
+ where
+ bs = bitSize (head r)
+
+-instance (Integral h, Bits h) => Hash (Hash8 h) where
++instance (Integral h, Bits h, Show h) => Hash (Hash8 h) where
+ toOctets (Hash8 x0 x1 x2 x3 x4 x5 x6 x7) = bitsToOctets =<< [x0, x1, x2, x3, x4, x5, x6, x7]
+
+ instance Hash Hash384 where
+@@ -282,4 +282,4 @@
+
+ -- Test with:
+ -- ghc -no-recomp -O --make Data/Digest/SHA2.hs -main-is Data.Digest.SHA2.moduleTest -o moduleTest && ./moduleTest && rm moduleTest
+-moduleTest = runTestTT test_sha2
+\ No newline at end of file
++moduleTest = runTestTT test_sha2
diff --git a/p/haskell-crypto/debian/patches/series b/p/haskell-crypto/debian/patches/series
index cf1e9241c..f37693112 100644
--- a/p/haskell-crypto/debian/patches/series
+++ b/p/haskell-crypto/debian/patches/series
@@ -1 +1,2 @@
+class-constraints.diff
no-quickcheck.patch