summaryrefslogtreecommitdiff
path: root/p/haskell-cryptocipher
diff options
context:
space:
mode:
authorNuutti Kotivuori <naked@iki.fi>2012-09-01 21:50:30 +0400
committerNuutti Kotivuori <naked@iki.fi>2012-09-01 21:50:30 +0400
commitcc05beeb59264e385c8ece59e0c3c39a35e48cdd (patch)
tree323eed4f8791b95ac82e16eb5ea4bb9d96dbee0c /p/haskell-cryptocipher
parent8f6054c8d7049bc5cf1d61934e2cd449308a5adc (diff)
downloadDHG_packages-cc05beeb59264e385c8ece59e0c3c39a35e48cdd.tar.gz
haskell-cryptocipher: Enable AES-NI support
Diffstat (limited to 'p/haskell-cryptocipher')
-rw-r--r--p/haskell-cryptocipher/debian/changelog7
-rwxr-xr-xp/haskell-cryptocipher/debian/rules6
2 files changed, 13 insertions, 0 deletions
diff --git a/p/haskell-cryptocipher/debian/changelog b/p/haskell-cryptocipher/debian/changelog
index e0fe382da..375f313c4 100644
--- a/p/haskell-cryptocipher/debian/changelog
+++ b/p/haskell-cryptocipher/debian/changelog
@@ -1,3 +1,10 @@
+haskell-cryptocipher (0.3.5-2) UNRELEASED; urgency=low
+
+ * Enable AES-NI support, thanks to Nuutti Kotivuori for the patch (Closes:
+ #686066)
+
+ -- Joachim Breitner <nomeata@debian.org> Sat, 01 Sep 2012 19:49:44 +0200
+
haskell-cryptocipher (0.3.5-1) unstable; urgency=low
* New upstream release, includes our patch.
diff --git a/p/haskell-cryptocipher/debian/rules b/p/haskell-cryptocipher/debian/rules
index 01f1aaf04..48edfcf85 100755
--- a/p/haskell-cryptocipher/debian/rules
+++ b/p/haskell-cryptocipher/debian/rules
@@ -1,5 +1,11 @@
#!/usr/bin/make -f
+DEB_BUILD_ARCH := $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+
+ifeq ($(DEB_BUILD_ARCH),amd64)
+ DEB_SETUP_GHC_CONFIGURE_ARGS = -faesni
+endif
+
DEB_ENABLE_TESTS = yes
include /usr/share/cdbs/1/rules/debhelper.mk