summaryrefslogtreecommitdiff
path: root/p/haskell-edison-api
diff options
context:
space:
mode:
authorMarco Silva <marcot@debian.org>2011-01-15 18:05:53 +0300
committerMarco Silva <marcot@debian.org>2011-01-15 18:05:53 +0300
commitac33867a5bb8009ee9ef86c7bee306dfc2002790 (patch)
treee1d4bb15ec25d3ec9111d370275ffa815fef4ab5 /p/haskell-edison-api
parentdb14e0dd6b75c75446e823266d4f7fb86465acdf (diff)
downloadDHG_packages-ac33867a5bb8009ee9ef86c7bee306dfc2002790.tar.gz
haskell-edison-api: Use ghc instead of ghc6
Diffstat (limited to 'p/haskell-edison-api')
-rw-r--r--p/haskell-edison-api/debian/changelog38
-rw-r--r--p/haskell-edison-api/debian/control22
2 files changed, 33 insertions, 27 deletions
diff --git a/p/haskell-edison-api/debian/changelog b/p/haskell-edison-api/debian/changelog
index 30732ac63..025131bc4 100644
--- a/p/haskell-edison-api/debian/changelog
+++ b/p/haskell-edison-api/debian/changelog
@@ -1,3 +1,9 @@
+haskell-edison-api (1.2.1-15) UNRELEASED; urgency=low
+
+ * Use ghc instead of ghc
+
+ -- Marco Silva <marcot@debian.org> Sat, 15 Jan 2011 12:40:55 -0200
+
haskell-edison-api (1.2.1-14) unstable; urgency=low
* control: Use versioned Replaces: and Conflicts:
@@ -133,20 +139,20 @@ haskell-edison (1.2.1-4) unstable; urgency=low
* debian/control:
- Update XS-Vcs-* fields as the packages has moved to the pkg-haskell
subversion archive.
- - Add libghc6-mtl-prof and libghc6-quickcheck-prof to Build-Depends as
- libghc6-mtl-dev and libghc6-quickcheck-dev have split of their
+ - Add libghc-mtl-prof and libghc-quickcheck-prof to Build-Depends as
+ libghc-mtl-dev and libghc-quickcheck-dev have split of their
profiling libraries into seperate packages.
- * debian/{ghc6.in,rules}:
+ * debian/{ghc.in,rules}:
- Add handling of noopt in DEB_BUILD_OPTIONS enviroment variable.
* debian/{mk-haskell-depends,rules}:
- Small cleanups.
* Generate links to other API documentation packages:
- debian/control:
- + Add libghc6-base-doc, libghc6-haskell98-doc, libghc6-mtl-doc and
- libghc6-quickcheck-doc to the Build-Depends-Indep so haddock can
+ + Add libghc-base-doc, libghc-haskell98-doc, libghc-mtl-doc and
+ libghc-quickcheck-doc to the Build-Depends-Indep so haddock can
link to the names in other packages.
- + Add libghc6-base-doc, libghc6-haskell98-doc, libghc6-mtl-doc and
- libghc6-quickcheck-doc to the Recommends of haskell-edison-doc.
+ + Add libghc-base-doc, libghc-haskell98-doc, libghc-mtl-doc and
+ libghc-quickcheck-doc to the Recommends of haskell-edison-doc.
- debian/patches/20_add-haddock-file.dpatch:
+ Add the appropriate --read-interface and --use-package options so
haddock will link to names in other packages.
@@ -197,11 +203,11 @@ haskell-edison (1.2.0.1-5) unstable; urgency=low
haskell-edison (1.2.0.1-4) unstable; urgency=low
* debian/control:
- - Bump Build-Depends on ghc6 as Edison needs a new Cabal version.
- - Add ghc6-prof to the Build-Depends.
- - Let libghc6-edison-api-dev and libghc6-edison-core-dev provide
- libghc6-edison-api-prof and libghc6-edison-core-prof.
- * debian/{ghc6.in,ghc-pkg6.in}:
+ - Bump Build-Depends on ghc as Edison needs a new Cabal version.
+ - Add ghc-prof to the Build-Depends.
+ - Let libghc-edison-api-dev and libghc-edison-core-dev provide
+ libghc-edison-api-prof and libghc-edison-core-prof.
+ * debian/{ghc.in,ghc-pkg6.in}:
- Exit on errors and show the commands executed.
* debian/patches/20_add-haddock-file: generate haddock interface file
when generating API documentation.
@@ -218,20 +224,20 @@ haskell-edison (1.2.0.1-4) unstable; urgency=low
haskell-edison (1.2.0.1-3) unstable; urgency=low
- * Stop using update-haskell-control and $ghc6_* variables, as it is not
+ * Stop using update-haskell-control and $ghc_* variables, as it is not
necessary and not using it simplifies the work for porters and for me.
* debian/copyright:
- include email from upstream with more information about the exact
licensing.
* debian/control.in:
- - add libghc6-mtl-dev and libghc6-quickcheck-dev to Build-Depends.
+ - add libghc-mtl-dev and libghc-quickcheck-dev to Build-Depends.
- replace ${ghc:Depends} with ${haskell:Depends}
- update maintainer email address.
* debian/rules:
- copy the actual package.conf file in which all installed packages
are registered.
- - remove debian/ghc6 and debian/ghc-pkg6 on clean.
- - replace debian/mk-ghc6-vars script with debian/mk-haskell-depends
+ - remove debian/ghc and debian/ghc-pkg6 on clean.
+ - replace debian/mk-ghc-vars script with debian/mk-haskell-depends
script which determines all dependencies by using the installed
package description file used by ghc-pkg.
diff --git a/p/haskell-edison-api/debian/control b/p/haskell-edison-api/debian/control
index 572a830a1..ae5274fd8 100644
--- a/p/haskell-edison-api/debian/control
+++ b/p/haskell-edison-api/debian/control
@@ -7,21 +7,21 @@ Build-Depends: cdbs
, debhelper (>= 7)
, haskell-devscripts (>= 0.7)
, cpphs
- , ghc6
- , ghc6-prof
- , ghc6-doc
- , libghc6-mtl-dev
- , libghc6-mtl-prof
- , libghc6-mtl-doc
+ , ghc
+ , ghc-prof
+ , ghc-doc
+ , libghc-mtl-dev
+ , libghc-mtl-prof
+ , libghc-mtl-doc
Standards-Version: 3.8.4
Homepage: http://www.cs.princeton.edu/~rdockins/edison/home/
Vcs-Darcs: http://darcs.debian.org/pkg-haskell/haskell-edison-api
Vcs-Browser: http://darcs.debian.org/cgi-bin/darcsweb.cgi?r=pkg-haskell/haskell-edison-api
-Package: libghc6-edison-api-dev
+Package: libghc-edison-api-dev
Architecture: any
Depends: ${haskell:Depends}, ${shlibs:Depends}, ${misc:Depends}
-Recommends: libghc6-edison-core-dev, ${haskell:Recommends}
+Recommends: libghc-edison-core-dev, ${haskell:Recommends}
Suggests: ${haskell:Suggests}
Provides: ${haskell:Provides}
Description: Haskell library of efficent, purely-functional data structures
@@ -38,10 +38,10 @@ Description: Haskell library of efficent, purely-functional data structures
.
This package contains the set of type classes.
-Package: libghc6-edison-api-prof
+Package: libghc-edison-api-prof
Architecture: any
Depends: ${haskell:Depends}, ${shlibs:Depends}, ${misc:Depends}
-Recommends: libghc6-edison-core-prof, ${haskell:Recommends}
+Recommends: libghc-edison-core-prof, ${haskell:Recommends}
Suggests: ${haskell:Suggests}
Provides: ${haskell:Provides}
Description: Haskell library of data structures; profiling libraries
@@ -58,7 +58,7 @@ Description: Haskell library of data structures; profiling libraries
.
This package contains the set of type classes.
-Package: libghc6-edison-api-doc
+Package: libghc-edison-api-doc
Replaces: haskell-edison-doc, haskell-edison-api-doc (<< 1.2.1-13)
Conflicts: haskell-edison-doc, haskell-edison-api-doc (<< 1.2.1-13)
Provides: haskell-edison-api-doc