summaryrefslogtreecommitdiff
path: root/p/haskell-enclosed-exceptions
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-06-05 05:19:01 +0400
committerColin Watson <cjwatson@debian.org>2014-06-05 05:19:01 +0400
commit2bcc6a71038a116a1d495586a824b2003f43ffbe (patch)
tree48e48cb4a3e4732309b58753a135b502bb272915 /p/haskell-enclosed-exceptions
parent653962379b6cc4070cc2bc12811e55458f359f68 (diff)
downloadDHG_packages-2bcc6a71038a116a1d495586a824b2003f43ffbe.tar.gz
haskell-enclosed-exceptions: Guard annotations to fix build without GHCi.
Diffstat (limited to 'p/haskell-enclosed-exceptions')
-rw-r--r--p/haskell-enclosed-exceptions/debian/changelog6
-rw-r--r--p/haskell-enclosed-exceptions/debian/patches/guard-annotations.patch26
-rw-r--r--p/haskell-enclosed-exceptions/debian/patches/series1
3 files changed, 33 insertions, 0 deletions
diff --git a/p/haskell-enclosed-exceptions/debian/changelog b/p/haskell-enclosed-exceptions/debian/changelog
index 63180d42d..945b8e5dc 100644
--- a/p/haskell-enclosed-exceptions/debian/changelog
+++ b/p/haskell-enclosed-exceptions/debian/changelog
@@ -1,3 +1,9 @@
+haskell-enclosed-exceptions (1.0.0.1-2) UNRELEASED; urgency=medium
+
+ * Guard annotations to fix build without GHCi.
+
+ -- Colin Watson <cjwatson@debian.org> Thu, 05 Jun 2014 02:12:14 +0100
+
haskell-enclosed-exceptions (1.0.0.1-1) unstable; urgency=medium
* Initial release.
diff --git a/p/haskell-enclosed-exceptions/debian/patches/guard-annotations.patch b/p/haskell-enclosed-exceptions/debian/patches/guard-annotations.patch
new file mode 100644
index 000000000..e5e53d9fe
--- /dev/null
+++ b/p/haskell-enclosed-exceptions/debian/patches/guard-annotations.patch
@@ -0,0 +1,26 @@
+Description: Guard annotations to fix build without GHCi
+ This can be dropped once https://ghc.haskell.org/trac/ghc/ticket/4268 is
+ available in Debian's GHC, so does not need to be forwarded upstream.
+Author: Colin Watson <cjwatson@debian.org>
+Forwarded: not-needed
+Last-Update: 2014-06-05
+
+Index: b/test/main.hs
+===================================================================
+--- a/test/main.hs
++++ b/test/main.hs
+@@ -1,3 +1,4 @@
++{-# LANGUAGE CPP #-}
+ {-# LANGUAGE NoMonomorphismRestriction #-}
+ {-# LANGUAGE DeriveDataTypeable #-}
+ {-# LANGUAGE PatternGuards #-}
+@@ -11,7 +12,9 @@
+ import Control.Concurrent (throwTo, threadDelay, forkIO)
+ import Control.Exception.Enclosed
+
++#ifdef HLINT
+ {-# ANN main ("HLint: ignore Redundant do"::String) #-}
++#endif
+ main :: IO ()
+ main = hspec $ do
+ describe "any exceptions" $ do
diff --git a/p/haskell-enclosed-exceptions/debian/patches/series b/p/haskell-enclosed-exceptions/debian/patches/series
new file mode 100644
index 000000000..9dc9acec5
--- /dev/null
+++ b/p/haskell-enclosed-exceptions/debian/patches/series
@@ -0,0 +1 @@
+guard-annotations.patch