summaryrefslogtreecommitdiff
path: root/p/haskell-hledger-lib
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2013-12-28 22:50:48 +0400
committerClint Adams <clint@debian.org>2013-12-28 22:50:48 +0400
commit7177052e7e3bfc324328551ff617d77ad2c6838b (patch)
treef1cc77a591c2076be40b2b6899f3e802f65b7484 /p/haskell-hledger-lib
parentd11cc1da78a5f3faf87c4a5156966dee4b8ffea5 (diff)
downloadDHG_packages-7177052e7e3bfc324328551ff617d77ad2c6838b.tar.gz
haskell-hledger-lib: New upstream version 0.22.
Diffstat (limited to 'p/haskell-hledger-lib')
-rw-r--r--p/haskell-hledger-lib/debian/changelog8
-rw-r--r--p/haskell-hledger-lib/debian/control13
-rw-r--r--p/haskell-hledger-lib/debian/patches/regex-tdfa54
-rw-r--r--p/haskell-hledger-lib/debian/patches/series1
4 files changed, 69 insertions, 7 deletions
diff --git a/p/haskell-hledger-lib/debian/changelog b/p/haskell-hledger-lib/debian/changelog
index 45298fdca..c07c615ed 100644
--- a/p/haskell-hledger-lib/debian/changelog
+++ b/p/haskell-hledger-lib/debian/changelog
@@ -1,8 +1,12 @@
-haskell-hledger-lib (0.21.3-2) UNRELEASED; urgency=low
+haskell-hledger-lib (0.22-1) unstable; urgency=medium
+ [ Joachim Breitner ]
* Adjust watch file to new hackage layout
- -- Joachim Breitner <nomeata@debian.org> Sat, 05 Oct 2013 18:20:35 +0200
+ [ Clint Adams ]
+ * New upstream version.
+
+ -- Clint Adams <clint@debian.org> Sat, 28 Dec 2013 13:40:01 -0500
haskell-hledger-lib (0.21.3-1) unstable; urgency=low
diff --git a/p/haskell-hledger-lib/debian/control b/p/haskell-hledger-lib/debian/control
index 813ac41f9..b43aa688a 100644
--- a/p/haskell-hledger-lib/debian/control
+++ b/p/haskell-hledger-lib/debian/control
@@ -13,6 +13,9 @@ Build-Depends: debhelper (>= 9)
, libghc-cmdargs-prof
, libghc-csv-dev
, libghc-csv-prof
+ , libghc-data-pprint-dev (>= 0.2.3)
+ , libghc-data-pprint-dev (<< 0.3)
+ , libghc-data-pprint-prof
, libghc-hunit-dev
, libghc-hunit-prof
, libghc-mtl-dev
@@ -21,9 +24,8 @@ Build-Depends: debhelper (>= 9)
, libghc-parsec3-prof
, libghc-pretty-show-dev
, libghc-pretty-show-prof
- , libghc-regex-compat-dev (>> 0.95)
- , libghc-regex-compat-dev (<< 0.96)
- , libghc-regex-compat-prof
+ , libghc-regex-tdfa-dev
+ , libghc-regex-tdfa-prof
, libghc-regexpr-dev (>> 0.5.1)
, libghc-regexpr-prof
, libghc-safe-dev (>> 0.2)
@@ -40,17 +42,18 @@ Build-Depends: debhelper (>= 9)
Build-Depends-Indep: ghc-doc
, libghc-cmdargs-doc
, libghc-csv-doc
+ , libghc-data-pprint-doc
, libghc-hunit-doc
, libghc-mtl-doc
, libghc-parsec3-doc
, libghc-pretty-show-doc
- , libghc-regex-compat-doc
+ , libghc-regex-tdfa-doc
, libghc-regexpr-doc
, libghc-safe-doc
, libghc-transformers-doc
, libghc-split-doc
, libghc-utf8-string-doc
-Standards-Version: 3.9.4
+Standards-Version: 3.9.5
Homepage: http://hackage.haskell.org/package/hledger-lib
Vcs-Darcs: http://darcs.debian.org/pkg-haskell/haskell-hledger-lib
Vcs-Browser: http://darcs.debian.org/cgi-bin/darcsweb.cgi?r=pkg-haskell/haskell-hledger-lib
diff --git a/p/haskell-hledger-lib/debian/patches/regex-tdfa b/p/haskell-hledger-lib/debian/patches/regex-tdfa
new file mode 100644
index 000000000..bda2fa8e9
--- /dev/null
+++ b/p/haskell-hledger-lib/debian/patches/regex-tdfa
@@ -0,0 +1,54 @@
+From 7f2ffe2e45e689a6f028f9dc23bee5dafa24f867 Mon Sep 17 00:00:00 2001
+From: Clint Adams <clint@debian.org>
+Date: Sat, 28 Dec 2013 13:31:58 -0500
+Subject: [PATCH] Use regex-tdfa instead of regex-compat-tdfa
+
+---
+ hledger-lib/Hledger/Utils.hs | 6 +++---
+ hledger-lib/hledger-lib.cabal | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+--- a/Hledger/Utils.hs
++++ b/Hledger/Utils.hs
+@@ -51,7 +51,7 @@
+ import Test.HUnit
+ import Text.ParserCombinators.Parsec
+ import Text.Printf
+-import Text.Regex
++import Text.Regex.TDFA
+ import Text.RegexPR
+ import Text.Show.Pretty
+ -- import qualified Data.Map as Map
+@@ -246,10 +246,10 @@
+
+ -- regex-compat (regex-posix) functions that perform better than regexpr.
+ regexMatchesRegexCompat :: String -> String -> Bool
+-regexMatchesRegexCompat r = isJust . matchRegex (mkRegex r)
++regexMatchesRegexCompat = flip (=~)
+
+ regexMatchesCIRegexCompat :: String -> String -> Bool
+-regexMatchesCIRegexCompat r = isJust . matchRegex (mkRegexWithOpts r True False)
++regexMatchesCIRegexCompat r = match (makeRegexOpts defaultCompOpt { multiline = True, caseSensitive = False, newSyntax = True } defaultExecOpt r)
+
+ -- lists
+
+--- a/hledger-lib.cabal
++++ b/hledger-lib.cabal
+@@ -68,7 +68,7 @@
+ ,old-time
+ ,parsec
+ ,pretty-show
+- ,regex-compat-tdfa == 0.95.*
++ ,regex-tdfa
+ ,regexpr >= 0.5.1
+ ,safe >= 0.2
+ ,split >= 0.1 && < 0.3
+@@ -100,7 +100,7 @@
+ , old-time
+ , parsec
+ , pretty-show
+- , regex-compat-tdfa
++ , regex-tdfa
+ , regexpr
+ , safe
+ , split
diff --git a/p/haskell-hledger-lib/debian/patches/series b/p/haskell-hledger-lib/debian/patches/series
new file mode 100644
index 000000000..2c21b355a
--- /dev/null
+++ b/p/haskell-hledger-lib/debian/patches/series
@@ -0,0 +1 @@
+regex-tdfa