summaryrefslogtreecommitdiff
path: root/p/haskell-iospec
diff options
context:
space:
mode:
authorclint <clint@debian.org>2011-06-19 01:35:06 +0400
committerclint <clint@debian.org>2011-06-19 01:35:06 +0400
commit0d08666e7feb09deb259aea6fdd4e99d13961b5c (patch)
treed82187c7ac58008df13b21f24de80ea6bef03873 /p/haskell-iospec
parent0ec48ea894befc5b93bf8ed3e4b1b4b0070ddfd7 (diff)
downloadDHG_packages-0d08666e7feb09deb259aea6fdd4e99d13961b5c.tar.gz
haskell-iospec: Initial Check-In
Diffstat (limited to 'p/haskell-iospec')
-rw-r--r--p/haskell-iospec/debian/changelog5
-rw-r--r--p/haskell-iospec/debian/compat1
-rw-r--r--p/haskell-iospec/debian/control143
-rw-r--r--p/haskell-iospec/debian/copyright44
-rwxr-xr-xp/haskell-iospec/debian/rules4
-rw-r--r--p/haskell-iospec/debian/source/format1
-rw-r--r--p/haskell-iospec/debian/watch5
7 files changed, 203 insertions, 0 deletions
diff --git a/p/haskell-iospec/debian/changelog b/p/haskell-iospec/debian/changelog
new file mode 100644
index 000000000..1c938ae62
--- /dev/null
+++ b/p/haskell-iospec/debian/changelog
@@ -0,0 +1,5 @@
+haskell-iospec (0.2.2-1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Clint Adams <clint@debian.org> Fri, 17 Jun 2011 19:12:58 -0400
diff --git a/p/haskell-iospec/debian/compat b/p/haskell-iospec/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/p/haskell-iospec/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/p/haskell-iospec/debian/control b/p/haskell-iospec/debian/control
new file mode 100644
index 000000000..3d6d90a01
--- /dev/null
+++ b/p/haskell-iospec/debian/control
@@ -0,0 +1,143 @@
+Source: haskell-iospec
+Section: haskell
+Priority: extra
+Maintainer: Debian Haskell Group <pkg-haskell-maintainers@lists.alioth.debian.org>
+Uploaders: Clint Adams <clint@debian.org>
+Build-Depends: debhelper (>= 7)
+ , cdbs
+ , haskell-devscripts (>= 0.8)
+ , ghc
+ , ghc-prof
+ , libghc-mtl-dev
+ , libghc-mtl-prof
+ , libghc-quickcheck2-dev
+ , libghc-quickcheck2-prof
+ , libghc-stream-dev
+ , libghc-stream-prof
+Build-Depends-Indep: ghc-doc
+ , libghc-mtl-doc
+ , libghc-quickcheck2-doc
+ , libghc-stream-doc
+Standards-Version: 3.9.2
+Homepage: http://hackage.haskell.org/package/iospec
+Vcs-Darcs: http://darcs.debian.org/pkg-haskell/haskell-iospec
+Vcs-Browser: http://darcs.debian.org/cgi-bin/darcsweb.cgi?r=pkg-haskell/haskell-iospec
+
+Package: libghc-iospec-dev
+Architecture: any
+Depends: ${haskell:Depends}
+ , ${shlibs:Depends}
+ , ${misc:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Provides: ${haskell:Provides}
+Description: Pure specification of the IO monad
+ This package provides a library for the Haskell programming language.
+ See http://www.haskell.org/ for more information on Haskell.
+ .
+ It consists of several modules, that give a pure specification
+ of functions in the IO monad:
+ .
+ Test.IOSpec.Fork: a pure specification of forkIO.
+ .
+ Test.IOSpec.IORef: a pure specification of most functions that create and
+ manipulate on IORefs.
+ .
+ Test.IOSpec.MVar: a pure specification of most functions that create and
+ manipulate and MVars.
+ .
+ Test.IOSpec.STM: a pure specification of atomically and the STM monad.
+ .
+ Test.IOSpec.Teletype: a pure specification of getChar, putChar, and
+ several related Prelude functions.
+ .
+ Besides these modules containing the specifications, there are a few other
+ important modules:
+ .
+ Test.IOSpec.Types: defines the IOSpec type and several amenities.
+ .
+ Test.IOSpec.VirtualMachine: defines a virtual machine on which to execute
+ pure specifications.
+ .
+ Test.IOSpec.Surrogate: a drop-in replacement for the other modules. Import
+ this and recompile your code once you've finished testing and debugging.
+ .
+ There are several well-documented examples included with the source
+ distribution.
+
+Package: libghc-iospec-prof
+Architecture: any
+Depends: ${haskell:Depends}
+ , ${misc:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Provides: ${haskell:Provides}
+Description: Pure specification of the IO monad; profiling libraries
+ This package provides a library for the Haskell programming language,
+ compiled for profiling.
+ See http://www.haskell.org/ for more information on Haskell.
+ .
+ Test.IOSpec.Fork: a pure specification of forkIO.
+ .
+ Test.IOSpec.IORef: a pure specification of most functions that create and
+ manipulate on IORefs.
+ .
+ Test.IOSpec.MVar: a pure specification of most functions that create and
+ manipulate and MVars.
+ .
+ Test.IOSpec.STM: a pure specification of atomically and the STM monad.
+ .
+ Test.IOSpec.Teletype: a pure specification of getChar, putChar, and
+ several related Prelude functions.
+ .
+ Besides these modules containing the specifications, there are a few other
+ important modules:
+ .
+ Test.IOSpec.Types: defines the IOSpec type and several amenities.
+ .
+ Test.IOSpec.VirtualMachine: defines a virtual machine on which to execute
+ pure specifications.
+ .
+ Test.IOSpec.Surrogate: a drop-in replacement for the other modules. Import
+ this and recompile your code once you've finished testing and debugging.
+ .
+ There are several well-documented examples included with the source
+ distribution.
+
+Package: libghc-iospec-doc
+Section: doc
+Architecture: all
+Depends: ${misc:Depends}, ${haskell:Depends}
+Recommends: ${haskell:Recommends}
+Suggests: ${haskell:Suggests}
+Description: Pure specification of the IO monad; documentation
+ This package provides the documentation for a library for the Haskell
+ programming language.
+ See http://www.haskell.org/ for more information on Haskell.
+ .
+ Test.IOSpec.Fork: a pure specification of forkIO.
+ .
+ Test.IOSpec.IORef: a pure specification of most functions that create and
+ manipulate on IORefs.
+ .
+ Test.IOSpec.MVar: a pure specification of most functions that create and
+ manipulate and MVars.
+ .
+ Test.IOSpec.STM: a pure specification of atomically and the STM monad.
+ .
+ Test.IOSpec.Teletype: a pure specification of getChar, putChar, and
+ several related Prelude functions.
+ .
+ Besides these modules containing the specifications, there are a few other
+ important modules:
+ .
+ Test.IOSpec.Types: defines the IOSpec type and several amenities.
+ .
+ Test.IOSpec.VirtualMachine: defines a virtual machine on which to execute
+ pure specifications.
+ .
+ Test.IOSpec.Surrogate: a drop-in replacement for the other modules. Import
+ this and recompile your code once you've finished testing and debugging.
+ .
+ There are several well-documented examples included with the source
+ distribution.
diff --git a/p/haskell-iospec/debian/copyright b/p/haskell-iospec/debian/copyright
new file mode 100644
index 000000000..fb810ddb6
--- /dev/null
+++ b/p/haskell-iospec/debian/copyright
@@ -0,0 +1,44 @@
+This package was debianized by Clint Adams <clint@debian.org> on
+Fri, 17 Jun 2011 23:12:58 -0000
+
+It was downloaded from
+http://hackage.haskell.org/package/IOSpec
+
+Upstream Authors:
+
+ Wouter Swierstra <wss@cs.nott.ac.uk>
+
+Copyright:
+
+ 2006 Wouter Swierstra
+
+License:
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+
+ * Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ * Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials
+ provided with the distribution.
+
+ * Neither the name of Wouter Swierstra nor the names of other
+ contributors may be used to endorse or promote products
+ derived from this software without specific prior written
+ permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/p/haskell-iospec/debian/rules b/p/haskell-iospec/debian/rules
new file mode 100755
index 000000000..683e77bcf
--- /dev/null
+++ b/p/haskell-iospec/debian/rules
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/hlibrary.mk
diff --git a/p/haskell-iospec/debian/source/format b/p/haskell-iospec/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/p/haskell-iospec/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/p/haskell-iospec/debian/watch b/p/haskell-iospec/debian/watch
new file mode 100644
index 000000000..01a579068
--- /dev/null
+++ b/p/haskell-iospec/debian/watch
@@ -0,0 +1,5 @@
+version=3
+opts="downloadurlmangle=s|archive/([\w\d_-]+)/([\d\.]+)/|archive/$1/$2/$1-$2.tar.gz|,\
+filenamemangle=s|(.*)/$|IOSpec-$1.tar.gz|" \
+ http://hackage.haskell.org/packages/archive/IOSpec \
+ ([\d\.]*\d)/