summaryrefslogtreecommitdiff
path: root/p/haskell-lambdabot-core
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2016-10-19 20:02:10 -0400
committerClint Adams <clint@debian.org>2016-10-19 20:41:37 -0400
commit4983c3e5312077c48495ab09c12d8cf8b0afa611 (patch)
tree554eeef2e3d0d882351f573924ff258b430b3381 /p/haskell-lambdabot-core
parent4d7c83d85ac02637862750d1081981e8762db990 (diff)
downloadDHG_packages-4983c3e5312077c48495ab09c12d8cf8b0afa611.tar.gz
lambdabot-core: Upgrading from 5.0.3 to 5.1
Diffstat (limited to 'p/haskell-lambdabot-core')
-rw-r--r--p/haskell-lambdabot-core/debian/changelog6
-rw-r--r--p/haskell-lambdabot-core/debian/control9
-rw-r--r--p/haskell-lambdabot-core/debian/patches/newer-dependent-map79
-rw-r--r--p/haskell-lambdabot-core/debian/patches/series1
4 files changed, 14 insertions, 81 deletions
diff --git a/p/haskell-lambdabot-core/debian/changelog b/p/haskell-lambdabot-core/debian/changelog
index 84d88e76c..f9911298f 100644
--- a/p/haskell-lambdabot-core/debian/changelog
+++ b/p/haskell-lambdabot-core/debian/changelog
@@ -1,3 +1,9 @@
+haskell-lambdabot-core (5.1-1) experimental; urgency=medium
+
+ * New upstream version.
+
+ -- Clint Adams <clint@debian.org> Wed, 19 Oct 2016 20:02:10 -0400
+
haskell-lambdabot-core (5.0.3-5) experimental; urgency=medium
[ Dmitry Bogatov ]
diff --git a/p/haskell-lambdabot-core/debian/control b/p/haskell-lambdabot-core/debian/control
index f5698a265..709d6a0c6 100644
--- a/p/haskell-lambdabot-core/debian/control
+++ b/p/haskell-lambdabot-core/debian/control
@@ -9,7 +9,7 @@ Build-Depends:
debhelper (>= 9),
ghc (>= 8),
ghc-prof,
- haskell-devscripts (>= 0.10),
+ haskell-devscripts (>= 0.9),
libghc-dependent-map-dev (<< 0.3),
libghc-dependent-map-dev (>= 0.2),
libghc-dependent-map-prof,
@@ -34,6 +34,9 @@ Build-Depends:
libghc-network-prof,
libghc-parsec3-dev,
libghc-parsec3-prof,
+ libghc-prim-uniq-dev (<< 0.2),
+ libghc-prim-uniq-dev (>= 0.1),
+ libghc-prim-uniq-prof,
libghc-random-dev (>= 1),
libghc-random-fu-dev (>= 0.2),
libghc-random-fu-prof,
@@ -46,6 +49,8 @@ Build-Depends:
libghc-safesemaphore-prof,
libghc-split-dev (>= 0.2),
libghc-split-prof,
+ libghc-syb-dev (>= 0.3),
+ libghc-syb-prof,
libghc-transformers-base-dev (>= 0.4),
libghc-transformers-base-prof,
libghc-utf8-string-dev (>= 0.3),
@@ -65,12 +70,14 @@ Build-Depends-Indep:
libghc-mtl-doc,
libghc-network-doc,
libghc-parsec3-doc,
+ libghc-prim-uniq-doc,
libghc-random-doc,
libghc-random-fu-doc,
libghc-random-source-doc,
libghc-regex-tdfa-doc,
libghc-safesemaphore-doc,
libghc-split-doc,
+ libghc-syb-doc,
libghc-transformers-base-doc,
libghc-utf8-string-doc,
libghc-zlib-doc,
diff --git a/p/haskell-lambdabot-core/debian/patches/newer-dependent-map b/p/haskell-lambdabot-core/debian/patches/newer-dependent-map
deleted file mode 100644
index c1766f14f..000000000
--- a/p/haskell-lambdabot-core/debian/patches/newer-dependent-map
+++ /dev/null
@@ -1,79 +0,0 @@
---- a/lambdabot-core.cabal
-+++ b/lambdabot-core.cabal
-@@ -67,12 +67,12 @@
- Lambdabot.Util.Serial
- Lambdabot.Util.Signals
-
-- build-depends: base >= 4.4 && < 5,
-+ build-depends: base >= 4.8 && < 5,
- binary >= 0.5,
- bytestring >= 0.9,
- containers >= 0.4,
-- dependent-map == 0.1.*,
-- dependent-sum == 0.2.*,
-+ dependent-map == 0.2.*,
-+ dependent-sum == 0.3.*,
- dependent-sum-template >= 0.0.0.1,
- directory >= 1.1,
- edit-distance >= 0.2,
---- a/src/Lambdabot/Monad.hs
-+++ b/src/Lambdabot/Monad.hs
-@@ -55,6 +55,7 @@
- import Control.Monad.State
- import Control.Monad.Trans.Control
- import qualified Data.Dependent.Map as D
-+import Data.Functor.Identity (Identity(..))
- import Data.IORef
- import qualified Data.Map as M
- import qualified Data.Set as S
-@@ -69,11 +70,11 @@
- data IRCRState = IRCRState
- { ircInitDoneMVar :: MVar ()
- , ircQuitMVar :: MVar ()
-- , ircConfig :: D.DMap Config
-+ , ircConfig :: D.DMap Config Identity
- }
-
- -- | Default ro state
--initRoState :: [D.DSum Config] -> IO IRCRState
-+initRoState :: [D.DSum Config Identity] -> IO IRCRState
- initRoState configuration = do
- quitMVar <- newEmptyMVar
- initDoneMVar <- newEmptyMVar
-@@ -81,7 +82,7 @@
- return IRCRState
- { ircQuitMVar = quitMVar
- , ircInitDoneMVar = initDoneMVar
-- , ircConfig = D.fromListWithKey (flip . mergeConfig) configuration
-+ , ircConfig = D.fromListWithKey (liftA2 . flip . mergeConfig) configuration
- }
-
- reportInitDone :: MonadIO m => IRCRState -> m ()
-@@ -225,7 +226,7 @@
- lift $ writeIORef ref x
-
- instance MonadConfig LB where
-- getConfig k = liftM (maybe (getConfigDefault k) id . D.lookup k) (lb (askLB ircConfig))
-+ getConfig k = liftM (maybe (getConfigDefault k) id . fmap runIdentity . D.lookup k) (lb (askLB ircConfig))
-
- instance MonadLogging LB where
- getCurrentLogger = getConfig lbRootLoggerPath
---- a/src/Lambdabot/Main.hs
-+++ b/src/Lambdabot/Main.hs
-@@ -25,6 +25,7 @@
-
- import Control.Exception.Lifted as E
- import Data.Dependent.Sum
-+import Data.Functor.Identity (Identity)
- import Data.List
- import Data.Typeable
- import Data.Version
-@@ -63,7 +64,7 @@
- -- Also, handle any fatal exceptions (such as non-recoverable signals),
- -- (i.e. print a message and exit). Non-fatal exceptions should be dealt
- -- with in the mainLoop or further down.
--lambdabotMain :: LB () -> [DSum Config] -> IO ExitCode
-+lambdabotMain :: LB () -> [DSum Config Identity] -> IO ExitCode
- lambdabotMain initialise cfg = withSocketsDo . withIrcSignalCatch $ do
- rost <- initRoState cfg
- r <- try $ evalLB (do setupLogging
diff --git a/p/haskell-lambdabot-core/debian/patches/series b/p/haskell-lambdabot-core/debian/patches/series
deleted file mode 100644
index b4c42582f..000000000
--- a/p/haskell-lambdabot-core/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-newer-dependent-map