summaryrefslogtreecommitdiff
path: root/p/haskell-lens
diff options
context:
space:
mode:
authorJoachim Breitner <mail@joachim-breitner.de>2014-08-02 13:23:14 +0400
committerJoachim Breitner <mail@joachim-breitner.de>2014-08-02 13:23:14 +0400
commit6860e2163e5a2fa7fbdbe7dbef38309f937afeb3 (patch)
treeda8a1fcded4f4f98f24bdd7914a8f8ac5cf7dacc /p/haskell-lens
parent5a5470421e9b4876974930b7e3eab06d48dbb358 (diff)
downloadDHG_packages-6860e2163e5a2fa7fbdbe7dbef38309f937afeb3.tar.gz
haskell-lens: Patch to allow building with QuickCheck-2.7
Diffstat (limited to 'p/haskell-lens')
-rw-r--r--p/haskell-lens/debian/changelog6
-rw-r--r--p/haskell-lens/debian/patches/quickcheck-2.7-compat37
-rw-r--r--p/haskell-lens/debian/patches/series1
3 files changed, 44 insertions, 0 deletions
diff --git a/p/haskell-lens/debian/changelog b/p/haskell-lens/debian/changelog
index bf1b4d8ae..ca0d208a8 100644
--- a/p/haskell-lens/debian/changelog
+++ b/p/haskell-lens/debian/changelog
@@ -1,3 +1,9 @@
+haskell-lens (4.1.2.1-2) UNRELEASED; urgency=medium
+
+ * Patch to allow building with QuickCheck-2.7
+
+ -- Joachim Breitner <nomeata@debian.org> Sat, 02 Aug 2014 11:13:59 +0200
+
haskell-lens (4.1.2.1-1) unstable; urgency=medium
* New upstream release
diff --git a/p/haskell-lens/debian/patches/quickcheck-2.7-compat b/p/haskell-lens/debian/patches/quickcheck-2.7-compat
new file mode 100644
index 000000000..a8a2e6054
--- /dev/null
+++ b/p/haskell-lens/debian/patches/quickcheck-2.7-compat
@@ -0,0 +1,37 @@
+Index: haskell-lens-4.1.2.1/lens-properties/src/Control/Lens/Properties.hs
+===================================================================
+--- haskell-lens-4.1.2.1.orig/lens-properties/src/Control/Lens/Properties.hs 2014-05-16 19:17:35.000000000 +0200
++++ haskell-lens-4.1.2.1/lens-properties/src/Control/Lens/Properties.hs 2014-08-02 11:13:41.898140422 +0200
+@@ -44,8 +44,8 @@
+ .&. do as <- arbitrary
+ bs <- arbitrary
+ t <- arbitrary
+- property $ traverse_compose l (\x -> as++[x]++bs)
+- (\x -> if t then Just x else Nothing)
++ return $ traverse_compose l (\x -> as++[x]++bs)
++ (\x -> if t then Just x else Nothing)
+
+
+ --------------------------------------------------------------------------------
+Index: haskell-lens-4.1.2.1/src/Data/Aeson/Lens.hs
+===================================================================
+--- haskell-lens-4.1.2.1.orig/src/Data/Aeson/Lens.hs 2014-08-02 11:22:48.690121006 +0200
++++ haskell-lens-4.1.2.1/src/Data/Aeson/Lens.hs 2014-08-02 11:22:59.310120629 +0200
+@@ -215,7 +215,7 @@
+ -- Just (String "xyz")
+ --
+ -- >>> "{\"a\": {}, \"b\": null}" ^? key "a" . nonNull
+--- Just (Object fromList [])
++-- Just (Object (fromList []))
+ --
+ -- >>> "{\"a\": \"xyz\", \"b\": null}" ^? key "b" . nonNull
+ -- Nothing
+@@ -235,7 +235,7 @@
+
+ -- |
+ -- >>> "{\"a\": {}, \"b\": null}" ^? key "a" . _Object
+- -- Just fromList []
++ -- Just (fromList [])
+ --
+ -- >>> "{\"a\": {}, \"b\": null}" ^? key "b" . _Object
+ -- Nothing
diff --git a/p/haskell-lens/debian/patches/series b/p/haskell-lens/debian/patches/series
index c1ba888b4..d6a23f509 100644
--- a/p/haskell-lens/debian/patches/series
+++ b/p/haskell-lens/debian/patches/series
@@ -4,3 +4,4 @@ guard-ANNotations.patch
fix-doctest-path.hs
fudge-doctest-nonascii.diff
backport-testsuite-failure-fix.patch
+quickcheck-2.7-compat