summaryrefslogtreecommitdiff
path: root/p/haskell-safe-exceptions
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2016-11-01 22:06:55 -0400
committerClint Adams <clint@debian.org>2016-11-01 22:06:55 -0400
commitb2fcbac2d138da0f165abcb1bf79be8cd88603c5 (patch)
tree9db3cbcd7df527c6781ab2f7861479453ab0d012 /p/haskell-safe-exceptions
parent4b6e693eb6602a838ccce18d4491c9f5324ad323 (diff)
downloadDHG_packages-b2fcbac2d138da0f165abcb1bf79be8cd88603c5.tar.gz
safe-exceptions: patch to build tests single-threaded on platforms without SMP support, such as arm* and s390x.
Diffstat (limited to 'p/haskell-safe-exceptions')
-rw-r--r--p/haskell-safe-exceptions/debian/changelog7
-rw-r--r--p/haskell-safe-exceptions/debian/patches/series1
-rw-r--r--p/haskell-safe-exceptions/debian/patches/smp-tests23
-rwxr-xr-xp/haskell-safe-exceptions/debian/rules4
4 files changed, 35 insertions, 0 deletions
diff --git a/p/haskell-safe-exceptions/debian/changelog b/p/haskell-safe-exceptions/debian/changelog
index 29e0daa49..34086d0d6 100644
--- a/p/haskell-safe-exceptions/debian/changelog
+++ b/p/haskell-safe-exceptions/debian/changelog
@@ -1,3 +1,10 @@
+haskell-safe-exceptions (0.1.4.0-4) unstable; urgency=medium
+
+ * Patch to build tests single-threaded on platforms without
+ SMP support, such as arm* and s390x.
+
+ -- Clint Adams <clint@debian.org> Tue, 01 Nov 2016 22:05:58 -0400
+
haskell-safe-exceptions (0.1.4.0-3) unstable; urgency=medium
* Upload to unstable as part of GHC 8 transition.
diff --git a/p/haskell-safe-exceptions/debian/patches/series b/p/haskell-safe-exceptions/debian/patches/series
new file mode 100644
index 000000000..d0948669b
--- /dev/null
+++ b/p/haskell-safe-exceptions/debian/patches/series
@@ -0,0 +1 @@
+smp-tests
diff --git a/p/haskell-safe-exceptions/debian/patches/smp-tests b/p/haskell-safe-exceptions/debian/patches/smp-tests
new file mode 100644
index 000000000..b2473827d
--- /dev/null
+++ b/p/haskell-safe-exceptions/debian/patches/smp-tests
@@ -0,0 +1,23 @@
+--- a/safe-exceptions.cabal
++++ b/safe-exceptions.cabal
+@@ -13,6 +13,10 @@
+ extra-source-files: README.md ChangeLog.md COOKBOOK.md
+ cabal-version: >=1.10
+
++flag tests-single-threaded
++ description: Build tests single-threaded
++ default: False
++
+ library
+ hs-source-dirs: src
+ exposed-modules: Control.Exception.Safe
+@@ -31,7 +35,8 @@
+ , hspec
+ , safe-exceptions
+ , void
+- ghc-options: -threaded -rtsopts -with-rtsopts=-N
++ if !flag(tests-single-threaded)
++ ghc-options: -threaded -rtsopts -with-rtsopts=-N
+ default-language: Haskell2010
+
+ source-repository head
diff --git a/p/haskell-safe-exceptions/debian/rules b/p/haskell-safe-exceptions/debian/rules
index 7f05bddbb..d30a6b839 100755
--- a/p/haskell-safe-exceptions/debian/rules
+++ b/p/haskell-safe-exceptions/debian/rules
@@ -4,5 +4,9 @@ DEB_ENABLE_TESTS = yes
DEB_CABAL_PACKAGE = safe-exceptions
DEB_DEFAULT_COMPILER = ghc
+ifeq (no,$(shell ghc --info | grep -q 'Support SMP.*NO' && echo no))
+DEB_SETUP_GHC_CONFIGURE_ARGS += -ftests-single-threaded
+endif
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/hlibrary.mk