summaryrefslogtreecommitdiff
path: root/p/haskell-src-exts/debian
diff options
context:
space:
mode:
authorJoachim Breitner <mail@joachim-breitner.de>2014-11-24 18:07:24 +0300
committerJoachim Breitner <mail@joachim-breitner.de>2014-11-24 18:07:24 +0300
commit25e7c304bacf5d6733644c14c5deefef03466b46 (patch)
treed738acc5ca92d6ca98e195d26b7c161c37c57e23 /p/haskell-src-exts/debian
parent6f44c44ce7c52408792eeae3a9100b423aa2594e (diff)
downloadDHG_packages-25e7c304bacf5d6733644c14c5deefef03466b46.tar.gz
haskell-src-exts: Pass ggc-min-expand=10 to gcc, might make this compile on mips*. Thanks to Dejan Latinovic for the patch. Closes: #770830
Diffstat (limited to 'p/haskell-src-exts/debian')
-rw-r--r--p/haskell-src-exts/debian/changelog7
-rwxr-xr-xp/haskell-src-exts/debian/rules18
2 files changed, 25 insertions, 0 deletions
diff --git a/p/haskell-src-exts/debian/changelog b/p/haskell-src-exts/debian/changelog
index 5722db546..2bcb909cd 100644
--- a/p/haskell-src-exts/debian/changelog
+++ b/p/haskell-src-exts/debian/changelog
@@ -1,3 +1,10 @@
+haskell-src-exts (1.14.0.1-2) UNRELEASED; urgency=medium
+
+ * Pass ggc-min-expand=10 to gcc, might make this compile on mips*. Thanks to
+ Dejan Latinovic for the patch. Closes: #770830
+
+ -- Joachim Breitner <nomeata@debian.org> Mon, 24 Nov 2014 16:06:36 +0100
+
haskell-src-exts (1.14.0.1-1) unstable; urgency=medium
* New upstream release
diff --git a/p/haskell-src-exts/debian/rules b/p/haskell-src-exts/debian/rules
index cd729b33a..b5c458048 100755
--- a/p/haskell-src-exts/debian/rules
+++ b/p/haskell-src-exts/debian/rules
@@ -2,7 +2,25 @@
DEB_CABAL_PACKAGE=src-exts
DEB_BUILD_DEPENDENCIES = build-arch
+
DEB_SETUP_GHC6_CONFIGURE_ARGS = --ghc-options="+RTS -V0 -RTS"
+# haskell-src-exts needs a lot of memory during compilation.
+# Unfortunately, this amount of memory is not available on all platforms,
+# and error: "virtual memory exhausted: Cannot allocate memory." could appear.
+#
+# In this case possible solution could be using ggc-min-expand.
+# This parameter specifies the minimum percentage by which the
+# garbage collector’s heap should be allowed to expand between collections.
+# Tuning this may improve compilation speed; it has no effect on code generation.
+#
+# http://hostingfu.com/article/compiling-with-gcc-on-low-memory-vps
+# -- Dejan Latinovic <Dejan.Latinovic@imgtec.com>
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+ifneq (,$(filter $(DEB_BUILD_ARCH),mips mipsel))
+ DEB_SETUP_GHC6_CONFIGURE_ARGS += "-optc--param -optcggc-min-expand=10"
+endif
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/hlibrary.mk
+