summaryrefslogtreecommitdiff
path: root/p/haskell-unlambda/debian
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2012-10-31 08:13:28 +0400
committerClint Adams <clint@debian.org>2012-10-31 08:13:28 +0400
commit64464fff697f88fb041bb4ab74fa8e678d50057b (patch)
tree8ffa67f86b257830cf7248a96993194a6e7846b6 /p/haskell-unlambda/debian
parent5df279d41df53443de80da601c3fdd7aabb7ea43 (diff)
downloadDHG_packages-64464fff697f88fb041bb4ab74fa8e678d50057b.tar.gz
haskell-unlambda: Patch to build with GHC 7.6.
Diffstat (limited to 'p/haskell-unlambda/debian')
-rw-r--r--p/haskell-unlambda/debian/changelog10
-rw-r--r--p/haskell-unlambda/debian/patches/new-exceptions.diff43
-rw-r--r--p/haskell-unlambda/debian/patches/series1
3 files changed, 51 insertions, 3 deletions
diff --git a/p/haskell-unlambda/debian/changelog b/p/haskell-unlambda/debian/changelog
index bfc4e783b..37269e3cb 100644
--- a/p/haskell-unlambda/debian/changelog
+++ b/p/haskell-unlambda/debian/changelog
@@ -1,10 +1,14 @@
-haskell-unlambda (0.1-3) UNRELEASED; urgency=low
+haskell-unlambda (0.1-3) experimental; urgency=low
- * Depend on haskell-devscripts 0.8.13 to ensure this packages is built
+ [ Joachim Breitner ]
+ * Depend on haskell-devscripts 0.8.13 to ensure this package is built
against experimental
* Bump standards version, no change
- -- Joachim Breitner <nomeata@debian.org> Sat, 13 Oct 2012 14:13:43 +0200
+ [ Clint Adams ]
+ * Patch to build with GHC 7.6.
+
+ -- Clint Adams <clint@debian.org> Wed, 31 Oct 2012 04:10:50 +0000
haskell-unlambda (0.1-2) unstable; urgency=low
diff --git a/p/haskell-unlambda/debian/patches/new-exceptions.diff b/p/haskell-unlambda/debian/patches/new-exceptions.diff
new file mode 100644
index 000000000..4d649ffaa
--- /dev/null
+++ b/p/haskell-unlambda/debian/patches/new-exceptions.diff
@@ -0,0 +1,43 @@
+Index: haskell-unlambda-0.1/Language/Unlambda.hs
+===================================================================
+--- haskell-unlambda-0.1.orig/Language/Unlambda.hs 2012-10-31 03:59:04.000000000 +0000
++++ haskell-unlambda-0.1/Language/Unlambda.hs 2012-10-31 04:05:55.828986238 +0000
+@@ -26,6 +26,8 @@
+
+ module Language.Unlambda where
+
++import Control.Exception.Base (catch, IOException)
++
+ ------------------------------------------------------------------------
+ -- Abstract syntax
+
+@@ -132,7 +134,7 @@
+ apply (Dot c) x = step >> io (putChar c) >> return x
+ apply E x = exit x
+ apply At f = do
+- dat <- io $ catch (getChar >>= return . Just) (const $ return Nothing)
++ dat <- io $ catch (getChar >>= return . Just) ((const $ return Nothing) :: IOException -> IO (Maybe Char))
+ setCurrentChar dat
+ apply f (case dat of Nothing -> V ; Just _ -> I)
+ apply (Ques c) f = do
+Index: haskell-unlambda-0.1/Main.hs
+===================================================================
+--- haskell-unlambda-0.1.orig/Main.hs 2008-06-08 22:40:02.000000000 +0000
++++ haskell-unlambda-0.1/Main.hs 2012-10-31 04:09:45.976968843 +0000
+@@ -7,6 +7,7 @@
+ import System.Posix.Resource
+ import Data.Char
+ import System.IO
++import Control.Exception.Base (catch, IOException)
+
+ import Language.Unlambda
+
+@@ -24,7 +25,7 @@
+ --
+ parse :: Handle -> IO Exp
+ parse h = do
+- c <- catch (hGetChar h) (\_ -> error "Parse error at end of file")
++ c <- catch (hGetChar h) ((\_ -> error "Parse error at end of file") :: IOException -> IO Char)
+ case toLower c of
+ d | d `elem` " \t\n" -> parse h
+ '`' -> do e1 <- parse h
diff --git a/p/haskell-unlambda/debian/patches/series b/p/haskell-unlambda/debian/patches/series
index a1fa2adbe..896857cca 100644
--- a/p/haskell-unlambda/debian/patches/series
+++ b/p/haskell-unlambda/debian/patches/series
@@ -1 +1,2 @@
unlambda_hs_charset_fix.diff
+new-exceptions.diff