summaryrefslogtreecommitdiff
path: root/p/haskell-vector/debian
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2017-07-10 07:53:27 -0400
committerClint Adams <clint@debian.org>2017-07-10 07:53:27 -0400
commit3fada2f183f9ff3468b3addb2b659ff5a37a711c (patch)
treeccc9b1c86a988a77f41bdff1f7c7010f31ff3a62 /p/haskell-vector/debian
parent20b1ef121a81c0ce82a1f36ee6ddb8d4a6a247cb (diff)
downloadDHG_packages-3fada2f183f9ff3468b3addb2b659ff5a37a711c.tar.gz
vector: patch for newer QuickCheck (drop duplicate instances). closes: #867873
Diffstat (limited to 'p/haskell-vector/debian')
-rw-r--r--p/haskell-vector/debian/changelog7
-rw-r--r--p/haskell-vector/debian/patches/newer-quickcheck15
2 files changed, 22 insertions, 0 deletions
diff --git a/p/haskell-vector/debian/changelog b/p/haskell-vector/debian/changelog
index 9e568f16b..7bb815967 100644
--- a/p/haskell-vector/debian/changelog
+++ b/p/haskell-vector/debian/changelog
@@ -1,3 +1,10 @@
+haskell-vector (0.11.0.0-8) unstable; urgency=medium
+
+ * Patch for newer QuickCheck (drop duplicate instances).
+ closes: #867873.
+
+ -- Clint Adams <clint@debian.org> Mon, 10 Jul 2017 07:51:17 -0400
+
haskell-vector (0.11.0.0-7) unstable; urgency=medium
* Upload to unstable as part of GHC 8 transition.
diff --git a/p/haskell-vector/debian/patches/newer-quickcheck b/p/haskell-vector/debian/patches/newer-quickcheck
index 3056b9f6a..583a4af4b 100644
--- a/p/haskell-vector/debian/patches/newer-quickcheck
+++ b/p/haskell-vector/debian/patches/newer-quickcheck
@@ -9,3 +9,18 @@
transformers >= 0.2.0.0
default-extensions: CPP,
+--- a/tests/Utilities.hs
++++ b/tests/Utilities.hs
+@@ -51,12 +51,6 @@
+ instance CoArbitrary a => CoArbitrary (S.Bundle v a) where
+ coarbitrary = coarbitrary . S.toList
+
+-instance Arbitrary a => Arbitrary (Identity a) where
+- arbitrary = fmap Identity arbitrary
+-
+-instance CoArbitrary a => CoArbitrary (Identity a) where
+- coarbitrary = coarbitrary . runIdentity
+-
+ instance Arbitrary a => Arbitrary (Writer a ()) where
+ arbitrary = fmap (writer . ((,) ())) arbitrary
+