summaryrefslogtreecommitdiff
path: root/p/haskell-wreq
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2016-10-29 19:40:24 -0400
committerClint Adams <clint@debian.org>2016-10-29 19:40:24 -0400
commit66a3ee04903b9c5946cebdddb430a298c9dadb62 (patch)
tree0e81d157602171499e8a24cd8326cabd5265fe87 /p/haskell-wreq
parenta54631445dd302ed0307c0e5012b6a0044443175 (diff)
downloadDHG_packages-66a3ee04903b9c5946cebdddb430a298c9dadb62.tar.gz
wreq: patch to only build with aeson-pretty >= 0.8
Diffstat (limited to 'p/haskell-wreq')
-rw-r--r--p/haskell-wreq/debian/changelog6
-rw-r--r--p/haskell-wreq/debian/patches/aeson-pretty-portability24
2 files changed, 28 insertions, 2 deletions
diff --git a/p/haskell-wreq/debian/changelog b/p/haskell-wreq/debian/changelog
index 9d80f4fcb..31f48c9c1 100644
--- a/p/haskell-wreq/debian/changelog
+++ b/p/haskell-wreq/debian/changelog
@@ -1,3 +1,9 @@
+haskell-wreq (0.4.1.0-5) unstable; urgency=medium
+
+ * Patch to only build with aeson-pretty >= 0.8.
+
+ -- Clint Adams <clint@debian.org> Sat, 29 Oct 2016 19:39:59 -0400
+
haskell-wreq (0.4.1.0-4) unstable; urgency=medium
* Patch to build with more versions of aeson-pretty.
diff --git a/p/haskell-wreq/debian/patches/aeson-pretty-portability b/p/haskell-wreq/debian/patches/aeson-pretty-portability
index 14717b36e..6cdb0a6a1 100644
--- a/p/haskell-wreq/debian/patches/aeson-pretty-portability
+++ b/p/haskell-wreq/debian/patches/aeson-pretty-portability
@@ -5,7 +5,7 @@
import Control.Monad.IO.Class (liftIO)
import Data.Aeson (Value(..), eitherDecode, object, toJSON)
-import Data.Aeson.Encode.Pretty (Config(..), encodePretty')
-+import Data.Aeson.Encode.Pretty (Config(..), defConfig, encodePretty')
++import Data.Aeson.Encode.Pretty (Config(..), Indent(Spaces), defConfig, encodePretty')
import Data.ByteString.Char8 (pack)
import Data.CaseInsensitive (original)
import Data.Maybe (catMaybes, fromMaybe)
@@ -14,7 +14,27 @@
writeJSON obj = do
modifyResponse $ setContentType "application/json"
- writeLBS . (<> "\n") . encodePretty' (Config 2 compare) . object $ obj
-+ writeLBS . (<> "\n") . encodePretty' defConfig { confIndent = 2, confCompare = compare } . object $ obj
++ writeLBS . (<> "\n") . encodePretty' defConfig { confIndent = Spaces 2, confCompare = compare } . object $ obj
respond act = do
req <- getRequest
+--- a/wreq.cabal
++++ b/wreq.cabal
+@@ -135,7 +135,7 @@
+ else
+ build-depends:
+ aeson >= 0.7,
+- aeson-pretty >= 0.7.1,
++ aeson-pretty >= 0.8.0,
+ base >= 4.5 && < 5,
+ base64-bytestring,
+ bytestring,
+@@ -178,7 +178,7 @@
+ HUnit,
+ QuickCheck >= 2.7,
+ aeson,
+- aeson-pretty >= 0.7.1,
++ aeson-pretty >= 0.8.0,
+ base >= 4.5 && < 5,
+ base64-bytestring,
+ bytestring,