summaryrefslogtreecommitdiff
path: root/p/shelltestrunner/debian/rules
diff options
context:
space:
mode:
authorIustin Pop <iustin@debian.org>2012-03-29 01:56:49 +0400
committerIustin Pop <iustin@debian.org>2012-03-29 01:56:49 +0400
commita3f0b555910c2cb33943a7665d053ae42c42b0e8 (patch)
tree5c2ed3a749bc5fff5be63dfae8e4caee015c8212 /p/shelltestrunner/debian/rules
parent3548c684ec59691afba53642d961b6bb2620eb50 (diff)
downloadDHG_packages-a3f0b555910c2cb33943a7665d053ae42c42b0e8.tar.gz
shelltestrunner: Add threaded runtime disable patch/build rule
Based on discussion on debian-haskell mailing list. Patch copied from the haskell-aeson package.
Diffstat (limited to 'p/shelltestrunner/debian/rules')
-rwxr-xr-xp/shelltestrunner/debian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/p/shelltestrunner/debian/rules b/p/shelltestrunner/debian/rules
index b6e2592ed..2ba975a24 100755
--- a/p/shelltestrunner/debian/rules
+++ b/p/shelltestrunner/debian/rules
@@ -3,6 +3,9 @@
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/hlibrary.mk
+# Disable linking with the threaded runtime if not available
+DEB_SETUP_GHC_CONFIGURE_ARGS += $(shell test -e /usr/lib/ghc-$(GHC_VERSION)/libHSrts_thr.a || echo --flags=-threaded)
+
build/$(CABAL_PACKAGE) :: build-ghc-stamp
install/$(CABAL_PACKAGE) :: build/$(CABAL_PACKAGE)