summaryrefslogtreecommitdiff
path: root/p
diff options
context:
space:
mode:
authorMarco Túlio Gontijo e Silva <marcot@holoscopio.com>2009-06-02 17:19:32 +0400
committer=?UTF-8?q?Marco=20T=C3=BAlio=20Gontijo=20e=20Silva?= <=?UTF-8?q?Marco=20T=C3=BAlio=20Gontijo=20e=20Silva?=>2009-06-02 17:19:32 +0400
commitbf03dd639c0b32be65e06f8947a67832bdd9235e (patch)
tree231c78498ef4eceb5c2e995d983e2756504e678c /p
parent6cad664649da4a3ba5f2c0a89e43f2febd549cc1 (diff)
downloadDHG_packages-bf03dd639c0b32be65e06f8947a67832bdd9235e.tar.gz
haskell-haskeline: Remove extensible-exceptions patch, since ghc6 now ships it.
Diffstat (limited to 'p')
-rw-r--r--p/haskell-haskeline/debian/control2
-rw-r--r--p/haskell-haskeline/debian/patches/00list1
-rwxr-xr-xp/haskell-haskeline/debian/patches/01_extensible-exceptions97
-rwxr-xr-xp/haskell-haskeline/debian/rules2
4 files changed, 2 insertions, 100 deletions
diff --git a/p/haskell-haskeline/debian/control b/p/haskell-haskeline/debian/control
index b90e59ef7..a785e3fa9 100644
--- a/p/haskell-haskeline/debian/control
+++ b/p/haskell-haskeline/debian/control
@@ -3,7 +3,7 @@ Section: libdevel
Priority: optional
Maintainer: Marco Túlio Gontijo e Silva <marcot@holoscopio.com>
Standards-Version: 3.8.0
-Build-Depends: debhelper (>= 5), cdbs, dpatch, haskell-devscripts (>= 0.6.15+nmu1), ghc6, ghc6-prof, libghc6-mtl-dev, libghc6-mtl-prof, libghc6-utf8-string-dev, libghc6-utf8-string-prof, libghc6-terminfo-dev, libghc6-terminfo-prof
+Build-Depends: debhelper (>= 5), cdbs, haskell-devscripts (>= 0.6.15+nmu1), ghc6, ghc6-prof, libghc6-mtl-dev, libghc6-mtl-prof, libghc6-utf8-string-dev, libghc6-utf8-string-prof, libghc6-terminfo-dev, libghc6-terminfo-prof
Build-Depends-Indep: ghc6-doc, haddock, hscolour, libghc6-mtl-doc, libghc6-utf8-string-doc, libghc6-terminfo-doc
Homepage: http://hackage.haskell.org/cgi-bin/haskeline/package/haskeline
Vcs-Darcs: http://code.haskell.org/debian/haskell-haskeline/
diff --git a/p/haskell-haskeline/debian/patches/00list b/p/haskell-haskeline/debian/patches/00list
deleted file mode 100644
index 5fe757311..000000000
--- a/p/haskell-haskeline/debian/patches/00list
+++ /dev/null
@@ -1 +0,0 @@
-01_extensible-exceptions
diff --git a/p/haskell-haskeline/debian/patches/01_extensible-exceptions b/p/haskell-haskeline/debian/patches/01_extensible-exceptions
deleted file mode 100755
index 7134255bb..000000000
--- a/p/haskell-haskeline/debian/patches/01_extensible-exceptions
+++ /dev/null
@@ -1,97 +0,0 @@
-#! /bin/sh /usr/share/dpatch/dpatch-run
-## 01_extensible-exceptions by Marco Túlio Gontijo e Silva <marcot@holoscopio.com>
-##
-## DP: Remove dependency in extensible-exceptions.
-diff -Nudar haskeline-0.6.1.3.orig/haskeline.cabal haskeline-0.6.1.3/haskeline.cabal
---- haskeline-0.6.1.3.orig/haskeline.cabal 2009-02-19 15:11:46.000000000 -0300
-+++ haskeline-0.6.1.3/haskeline.cabal 2009-03-12 10:25:36.000000000 -0300
-@@ -41,8 +41,7 @@
- Build-depends: base>=3 && <5 , containers>=0.1, directory>=1.0,
- bytestring==0.9.*
- Build-depends: filepath==1.1.*, mtl==1.1.*,
-- utf8-string==0.3.* && >=0.3.1.1,
-- extensible-exceptions==0.1.* && >=0.1.1.0
-+ utf8-string==0.3.* && >=0.3.1.1
- Extensions: ForeignFunctionInterface, RankNTypes, FlexibleInstances,
- TypeSynonymInstances
- FlexibleContexts, ExistentialQuantification
-diff -Nudar haskeline-0.6.1.3.orig/Setup.hs haskeline-0.6.1.3/Setup.hs
---- haskeline-0.6.1.3.orig/Setup.hs 2009-02-19 15:11:46.000000000 -0300
-+++ haskeline-0.6.1.3/Setup.hs 2009-03-12 10:25:22.000000000 -0300
-@@ -10,7 +10,7 @@
- import System.IO
- import System.Exit
- import System.Directory
--import Control.Exception.Extensible
-+import Control.Exception
-
- -- TODO: it's a hack that we use the autoconfUserHooks when we're not actually
- -- using autoconf...
-diff -Nudar haskeline-0.6.1.3.orig/System/Console/Haskeline/Backend/Terminfo.hs haskeline-0.6.1.3/System/Console/Haskeline/Backend/Terminfo.hs
---- haskeline-0.6.1.3.orig/System/Console/Haskeline/Backend/Terminfo.hs 2009-02-19 15:11:46.000000000 -0300
-+++ haskeline-0.6.1.3/System/Console/Haskeline/Backend/Terminfo.hs 2009-03-12 10:25:22.000000000 -0300
-@@ -8,7 +8,7 @@
- import Control.Monad
- import Data.List(intersperse)
- import System.IO
--import qualified Control.Exception.Extensible as Exception
-+import qualified Control.Exception as Exception
- import qualified Data.ByteString.Char8 as B
- import Data.Maybe (fromMaybe, catMaybes)
-
-diff -Nudar haskeline-0.6.1.3.orig/System/Console/Haskeline/Directory.hsc haskeline-0.6.1.3/System/Console/Haskeline/Directory.hsc
---- haskeline-0.6.1.3.orig/System/Console/Haskeline/Directory.hsc 2009-02-19 15:11:46.000000000 -0300
-+++ haskeline-0.6.1.3/System/Console/Haskeline/Directory.hsc 2009-03-12 10:25:22.000000000 -0300
-@@ -68,7 +68,7 @@
-
- import Data.ByteString.Char8 (pack, unpack)
- import qualified System.Directory as D
--import Control.Exception.Extensible
-+import Control.Exception
- import System.Console.Haskeline.Backend.IConv
-
- getDirectoryContents :: FilePath -> IO [FilePath]
-diff -Nudar haskeline-0.6.1.3.orig/System/Console/Haskeline/History.hs haskeline-0.6.1.3/System/Console/Haskeline/History.hs
---- haskeline-0.6.1.3.orig/System/Console/Haskeline/History.hs 2009-02-19 15:11:46.000000000 -0300
-+++ haskeline-0.6.1.3/System/Console/Haskeline/History.hs 2009-03-12 10:25:22.000000000 -0300
-@@ -27,7 +27,7 @@
-
- import qualified Data.ByteString as B
- import qualified Data.ByteString.UTF8 as UTF8
--import Control.Exception.Extensible
-+import Control.Exception
-
- import System.Directory(doesFileExist)
-
-diff -Nudar haskeline-0.6.1.3.orig/System/Console/Haskeline/MonadException.hs haskeline-0.6.1.3/System/Console/Haskeline/MonadException.hs
---- haskeline-0.6.1.3.orig/System/Console/Haskeline/MonadException.hs 2009-02-19 15:11:46.000000000 -0300
-+++ haskeline-0.6.1.3/System/Console/Haskeline/MonadException.hs 2009-03-12 10:25:22.000000000 -0300
-@@ -1,4 +1,4 @@
--{- | This module redefines some of the functions in "Control.Exception.Extensible" to
-+{- | This module redefines some of the functions in "Control.Exception" to
- work for more general monads than only 'IO'.
- -}
-
-@@ -16,8 +16,8 @@
- E.IOException())
- where
-
--import qualified Control.Exception.Extensible as E
--import Control.Exception.Extensible(Exception,SomeException)
-+import qualified Control.Exception as E
-+import Control.Exception(Exception,SomeException)
- import Prelude hiding (catch)
- import Control.Monad.Reader
- import Control.Monad.State
-diff -Nudar haskeline-0.6.1.3.orig/System/Console/Haskeline/Term.hs haskeline-0.6.1.3/System/Console/Haskeline/Term.hs
---- haskeline-0.6.1.3.orig/System/Console/Haskeline/Term.hs 2009-02-19 15:11:46.000000000 -0300
-+++ haskeline-0.6.1.3/System/Console/Haskeline/Term.hs 2009-03-12 10:25:22.000000000 -0300
-@@ -9,7 +9,7 @@
- import Control.Concurrent.Chan
- import Data.Typeable
- import Data.ByteString (ByteString)
--import Control.Exception.Extensible (fromException, AsyncException(..),bracket_)
-+import Control.Exception (fromException, AsyncException(..),bracket_)
-
- class (MonadReader Layout m, MonadException m) => Term m where
- reposition :: Layout -> LineChars -> m ()
diff --git a/p/haskell-haskeline/debian/rules b/p/haskell-haskeline/debian/rules
index caaba543f..68e0483c9 100755
--- a/p/haskell-haskeline/debian/rules
+++ b/p/haskell-haskeline/debian/rules
@@ -1,5 +1,5 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/dpatch.mk
include /usr/share/cdbs/1/class/hlibrary.mk
+