summaryrefslogtreecommitdiff
path: root/p
diff options
context:
space:
mode:
authorMarco Túlio Gontijo e Silva <marcot@holoscopio.com>2009-05-30 17:15:04 +0400
committer=?UTF-8?q?Marco=20T=C3=BAlio=20Gontijo=20e=20Silva?= <=?UTF-8?q?Marco=20T=C3=BAlio=20Gontijo=20e=20Silva?=>2009-05-30 17:15:04 +0400
commitf84c0c5c775347c0965643e3e9997cd9e60b4169 (patch)
tree3c56eaa78fbaa5e9fedab550cfa79e412a511d02 /p
parentfd5c1a65ff3c981d948958c83a2e08988ff55cf4 (diff)
downloadDHG_packages-f84c0c5c775347c0965643e3e9997cd9e60b4169.tar.gz
gtk2hs: Removes restriction of reponse values. Closes: #522481.
Diffstat (limited to 'p')
-rw-r--r--p/gtk2hs/debian/control2
-rw-r--r--p/gtk2hs/debian/patches/00list1
-rwxr-xr-xp/gtk2hs/debian/patches/01_response31
-rwxr-xr-xp/gtk2hs/debian/rules6
4 files changed, 37 insertions, 3 deletions
diff --git a/p/gtk2hs/debian/control b/p/gtk2hs/debian/control
index 8c2e7e1a7..e9aa384be 100644
--- a/p/gtk2hs/debian/control
+++ b/p/gtk2hs/debian/control
@@ -3,7 +3,7 @@ Priority: optional
Section: haskell
Maintainer: Marco Túlio Gontijo e Silva <marcot@holoscopio.com>
Uploaders: Joachim Breitner <nomeata@debian.org>
-Build-Depends: debhelper (>= 5), autoconf, automake, autotools-dev, haskell-devscripts (>= 0.6.15+nmu8), haddock (>= 2.4.1-4), ghc6 (>= 6.10.1+dfsg1-13), ghc6-doc (>= 6.10.1+dfsg1-13), libghc6-mtl-dev (>= 1.1.0.2-6), libghc6-mtl-doc (>= 1.1.0.2-6), libgconf2-dev, libgnomevfs2-dev, libgstreamer-plugins-base0.10-dev, librsvg2-dev, libglade2-dev, libgtkglext1-dev, libgtksourceview2.0-dev, dctrl-tools
+Build-Depends: debhelper (>= 5), autoconf, automake, autotools-dev, haskell-devscripts (>= 0.6.15+nmu10), haddock (>= 2.4.1-4), ghc6 (>= 6.10.1+dfsg1-13), ghc6-doc (>= 6.10.1+dfsg1-13), libghc6-mtl-dev (>= 1.1.0.2-6), libghc6-mtl-doc (>= 1.1.0.2-6), libgconf2-dev, libgnomevfs2-dev, libgstreamer-plugins-base0.10-dev, librsvg2-dev, libglade2-dev, libgtkglext1-dev, libgtksourceview2.0-dev, dctrl-tools, dpatch
Standards-Version: 3.8.1
Homepage: http://haskell.org/gtk2hs/
Vcs-Darcs: http://code.haskell.org/debian/gtk2hs/
diff --git a/p/gtk2hs/debian/patches/00list b/p/gtk2hs/debian/patches/00list
new file mode 100644
index 000000000..f775e85a2
--- /dev/null
+++ b/p/gtk2hs/debian/patches/00list
@@ -0,0 +1 @@
+01_response
diff --git a/p/gtk2hs/debian/patches/01_response b/p/gtk2hs/debian/patches/01_response
new file mode 100755
index 000000000..9f39ee72c
--- /dev/null
+++ b/p/gtk2hs/debian/patches/01_response
@@ -0,0 +1,31 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 01_response by Marco Túlio Gontijo e Silva <marcot@holoscopio.com>
+##
+## DP: This patch is already in upstream darcs. It removes the restriction
+## DP: that user defined responses should not be zero or lesser than -11.
+## DP: According to Axel Simon, "Gtk+ docs say that anything below 0 is
+## DP: reserved for Gtk+. But then, a negative number in ResponseUser is
+## DP: probably better than an pattern match error."
+## DP: http://sourceforge.net/mailarchive/message.php?msg_name=1241698296.10549.13.camel%40aconit
+## DP: Thanks to Daniel Burrows <dburrows@debian.org>. Closes: #522481.
+diff -Nudar gtk2hs-0.10.1.orig/gtk/Graphics/UI/Gtk/General/Structs.hsc gtk2hs-0.10.1/gtk/Graphics/UI/Gtk/General/Structs.hsc
+--- gtk2hs-0.10.1.orig/gtk/Graphics/UI/Gtk/General/Structs.hsc 2009-04-24 12:21:33.000000000 -0300
++++ gtk2hs-0.10.1/gtk/Graphics/UI/Gtk/General/Structs.hsc 2009-05-17 08:53:07.000000000 -0300
+@@ -548,7 +548,7 @@
+ fromResponse ResponseNo = -9
+ fromResponse ResponseApply = -10
+ fromResponse ResponseHelp = -11
+-fromResponse (ResponseUser i) | i > 0 = fromIntegral i
++fromResponse (ResponseUser i) = fromIntegral i
+
+ toResponse :: Integral a => a -> ResponseId
+ toResponse (-1) = ResponseNone
+@@ -562,7 +562,7 @@
+ toResponse (-9) = ResponseNo
+ toResponse (-10) = ResponseApply
+ toResponse (-11) = ResponseHelp
+-toResponse i | i >= 0 = ResponseUser $ fromIntegral i
++toResponse i = ResponseUser $ fromIntegral i
+
+ #if !defined(WIN32) || GTK_CHECK_VERSION(2,8,0)
+ -- | The identifer of a window of the underlying windowing system.
diff --git a/p/gtk2hs/debian/rules b/p/gtk2hs/debian/rules
index 2548b794d..87e40d3c3 100755
--- a/p/gtk2hs/debian/rules
+++ b/p/gtk2hs/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+include /usr/share/dpatch/dpatch.make
+
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
@@ -97,7 +99,7 @@ config.status: configure.ac
./configure $(configure_flags) --libdir=$(TMP_LIBDIR)
.PHONY: build
-build: build-stamp
+build: build-stamp patch
build-stamp: config.status
dh_testdir
$(MAKE) $(MAKEFLAGS)
@@ -134,7 +136,7 @@ debian/gtk2hs-doc.install: debian/gtk2hs-doc.install.in
sed -e "s#@DEB_HADDOCK_DIR@#$(DEB_HADDOCK_DIR)#g" < $^ > $@
.PHONY: clean clean-real
-clean: clean-real
+clean: clean-real unpatch
clean-real:
dh_testdir
dh_testroot