summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorNiels Thykier <nthykier@debian.org>2011-11-06 13:33:18 +0000
committerNiels Thykier <nthykier@debian.org>2011-11-06 13:33:18 +0000
commit801d01e48b31872ef0979050b30d1ebffea56c5f (patch)
tree91af497298cd24ee62a71f6d749c7781ec38e4ee /debian
parent41a230d6ad3aa51c3b13f64435da3899cd95fd74 (diff)
downloadjava-common-801d01e48b31872ef0979050b30d1ebffea56c5f.tar.gz
Made better use of the build-arch target
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
1 files changed, 5 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 58dd880..50fbd3d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -45,8 +45,9 @@ jhl_provides = $(call mk_cslist,$(provides),runtime-headless)
jdk_provides = $(call mk_cslist,$(provides),sdk)
build: build-indep build-arch
+build-arch:
+ # Do nothing :)
build-indep: build-stamp
-build-arch: build-stamp
build-stamp:
dh_testdir
@@ -62,7 +63,7 @@ clean:
dh_clean
install-indep: install-stamp
-install-stamp: build-stamp
+install-stamp: build-indep
dh_testdir
dh_testroot
dh_prep -i
@@ -73,7 +74,7 @@ install-stamp: build-stamp
touch install-stamp
-install-arch:
+install-arch: build-arch
dh_testdir
dh_testroot
dh_prep -a
@@ -139,4 +140,4 @@ binary-indep: build-indep install-indep
dh_builddeb -i
binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install configure