summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 2 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 3095fdd..38fb5a7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,12 +6,10 @@
, = ,
S = $(EMPTY) $(EMPTY)
mk_cslist = $(subst $(S),$(,)$(S),$(foreach v,$(1),$(v)-$(2)))
-vafilt = $(subst $(2)=,,$(filter $(2)=%,$(1)))
jrel = $(shell dpkg-parsechangelog | grep -E ^Version: | sed "s/Version: 0.//")
-DPKG_VARS := $(shell dpkg-architecture)
-DEB_HOST_ARCH ?= $(call vafilt,$(DPKG_VARS),DEB_HOST_ARCH)
-DEB_HOST_MULTIARCH ?= $(call vafilt,$(DPKG_VARS),DEB_HOST_MULTIARCH)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture --query DEB_HOST_ARCH)
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture --query DEB_HOST_MULTIARCH)
p_jre = gcj-jre
p_jhl = gcj-jre-headless