summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorModestas Vainius <modax@debian.org>2011-05-24 12:35:41 +0300
committerModestas Vainius <modax@debian.org>2011-05-24 12:36:07 +0300
commit7aab2c52d2894c169508f4947e9389ba0764845f (patch)
treee04b3ea16523efe72061411d304315dd4459837a /CMakeLists.txt
parent5a793f8de58e0ec3a03a6487ad74dcda890d54bb (diff)
downloadpkg-kde-tools-7aab2c52d2894c169508f4947e9389ba0764845f.tar.gz
While installing, preserve source permissions of some directory contents.
This includes files in cmake, makefiles, qt-kde-team and some other directories. This solves unexecutable scripts problem.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb0dd4c..08d471e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,14 +41,17 @@ endfunction(install_pod_manpages section)
# Install data & arch-indep library bundles
install(DIRECTORY cmake makefiles qt-kde-team
DESTINATION ${DATA_INSTALL_DIR}
+ USE_SOURCE_PERMISSIONS
COMPONENT Programs)
install(DIRECTORY vcslib/
DESTINATION ${DATA_INSTALL_DIR}/vcs
+ USE_SOURCE_PERMISSIONS
COMPONENT Programs)
install(DIRECTORY datalib/
DESTINATION ${DATALIB_INSTALL_DIR}
+ USE_SOURCE_PERMISSIONS
COMPONENT Programs)
install(DIRECTORY perllib/