summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorFathi Boudra <fabo@debian.org>2008-03-08 09:56:56 +0000
committerFathi Boudra <fabo@debian.org>2008-03-08 09:56:56 +0000
commit4d2b228aa581c45dbd4d70568a45166c24544267 (patch)
treee782591ce5c43d79e7a5342d67fd29fe141d19a7 /debian
parent06c6ef4e2ffd843ab1aabc9c1cdddfcda52d9edf (diff)
downloadqt4-x11-4d2b228aa581c45dbd4d70568a45166c24544267.tar.gz
Some backports from qt4-x11 branches:
* Add patches: * 09_qmake_lflags_as-needed workaround as LDFLAGS isn't honored by configure script. we set --as-needed flag for Qt build only. * 10_config_tests_fixes.diff configuration test fixes for Interbase/Firebird and ODBC sql drivers. * Update 01_qmake_for_debian patch: * re-introduce link_prl and drop QT_SHARED workaround. * Update rules: * Remove exported LD_LIBRARY_PATH and LDFLAGS. * Remove DEB_CONFIGURE_SCRIPT_ENV. * Exclude debug files from dh_shlibdeps using DEB_DH_SHLIBDEPS_ARGS_ALL. * Update configure options to use libtiff from system. * Remove debug configure option to build with -02. * Update common-install-arch target to fix wrong path in pkconfig and prl files.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog20
-rw-r--r--debian/patches/01_qmake_for_debian.diff16
-rw-r--r--debian/patches/09_qmake_lflags_as-needed.diff16
-rw-r--r--debian/patches/10_config_tests_fixes.diff62
-rw-r--r--debian/patches/series2
-rwxr-xr-xdebian/rules19
6 files changed, 111 insertions, 24 deletions
diff --git a/debian/changelog b/debian/changelog
index 2374a39..c82e9fe 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,23 @@
+qt4-x11 (4.3.4-2) unstable; urgency=low
+
+ * Add patches:
+ * 09_qmake_lflags_as-needed
+ workaround as LDFLAGS isn't honored by configure script.
+ we set --as-needed flag for Qt build only.
+ * 10_config_tests_fixes.diff
+ configuration test fixes for Interbase/Firebird and ODBC sql drivers.
+ * Update 01_qmake_for_debian patch:
+ * re-introduce link_prl and drop QT_SHARED workaround.
+ * Update rules:
+ * Remove exported LD_LIBRARY_PATH and LDFLAGS.
+ * Remove DEB_CONFIGURE_SCRIPT_ENV.
+ * Exclude debug files from dh_shlibdeps using DEB_DH_SHLIBDEPS_ARGS_ALL.
+ * Update configure options to use libtiff from system.
+ * Remove debug configure option to build with -02.
+ * Update common-install-arch target to fix wrong path in pkconfig and prl files.
+
+ -- Fathi Boudra <fabo@debian.org> Sat, 08 Mar 2008 10:09:02 +0100
+
qt4-x11 (4.3.4-1) unstable; urgency=low
* New upstream release:
diff --git a/debian/patches/01_qmake_for_debian.diff b/debian/patches/01_qmake_for_debian.diff
index 5cbb202..60aedbe 100644
--- a/debian/patches/01_qmake_for_debian.diff
+++ b/debian/patches/01_qmake_for_debian.diff
@@ -1,7 +1,6 @@
author: Brian Nelson <pyro@debian.org>
-Ensures qmake generates Makefiles that use the -qt4 tools and that use
-recursively link against all indirectly-used libraries.
+Ensures qmake generates Makefiles that use the -qt4 tools.
--- a/mkspecs/common/linux.conf
+++ b/mkspecs/common/linux.conf
@@ -16,16 +15,3 @@ recursively link against all indirectly-used libraries.
QMAKE_AR = ar cqs
QMAKE_RANLIB =
---- a/mkspecs/linux-g++/qmake.conf
-+++ b/mkspecs/linux-g++/qmake.conf
-@@ -4,8 +4,9 @@
-
- MAKEFILE_GENERATOR = UNIX
- TEMPLATE = app
--CONFIG += qt warn_on release incremental link_prl
-+CONFIG += qt warn_on release incremental
- QT += core gui
-+DEFINES += QT_SHARED
- QMAKE_INCREMENTAL_STYLE = sublib
-
- include(../common/g++.conf)
diff --git a/debian/patches/09_qmake_lflags_as-needed.diff b/debian/patches/09_qmake_lflags_as-needed.diff
new file mode 100644
index 0000000..6970386
--- /dev/null
+++ b/debian/patches/09_qmake_lflags_as-needed.diff
@@ -0,0 +1,16 @@
+author: Fathi Boudra <fabo@debian.org>
+
+workaround as LDFLAGS isn't honored by configure script.
+Bug reported to Trolltech.
+
+--- a/configure
++++ b/configure
+@@ -497,6 +497,8 @@
+ rm -f "$outpath/config.tests/.qmake.cache"
+ cp "$QMAKE_VARS_FILE" "$outpath/config.tests/.qmake.cache"
+
++QMakeVar add QMAKE_LFLAGS -Wl,--as-needed
++
+ QMakeVar add styles "cde mac motif plastique cleanlooks windows"
+ QMakeVar add decorations "default windows styled"
+ QMakeVar add gfx-drivers "linuxfb"
diff --git a/debian/patches/10_config_tests_fixes.diff b/debian/patches/10_config_tests_fixes.diff
new file mode 100644
index 0000000..623c11e
--- /dev/null
+++ b/debian/patches/10_config_tests_fixes.diff
@@ -0,0 +1,62 @@
+author: Fathi Boudra <fabo@debian.org>
+
+Configuration test fixes for Interbase/Firebird and ODBC sql drivers.
+
+--- a/config.tests/unix/ibase/ibase.pro
++++ b/config.tests/unix/ibase/ibase.pro
+@@ -1,4 +1,4 @@
+ SOURCES = ibase.cpp
+ CONFIG -= qt dylib
+ mac:CONFIG -= app_bundle
+-LIBS += -lgds
++LIBS += -lfbclient
+--- a/config.tests/unix/odbc/odbc.pro
++++ b/config.tests/unix/odbc/odbc.pro
+@@ -1,4 +1,4 @@
+ SOURCES = odbc.cpp
+ CONFIG -= qt dylib
+ CONFIG -= app_bundle
+-LIBS += -lodbc
++LIBS += -liodbc
+--- a/src/plugins/sqldrivers/odbc/odbc.pro
++++ b/src/plugins/sqldrivers/odbc/odbc.pro
+@@ -12,7 +12,7 @@
+
+ unix {
+ !contains( LIBS, .*odbc.* ) {
+- LIBS *= -lodbc
++ LIBS *= -liodbc
+ }
+ }
+
+--- a/src/sql/drivers/drivers.pri
++++ b/src/sql/drivers/drivers.pri
+@@ -48,7 +48,7 @@
+ SOURCES += drivers/odbc/qsql_odbc.cpp
+
+ mac:!contains( LIBS, .*odbc.* ):LIBS *= -liodbc
+- unix:!contains( LIBS, .*odbc.* ):LIBS *= -lodbc
++ unix:!contains( LIBS, .*odbc.* ):LIBS *= -liodbc
+
+ win32 {
+ !win32-borland:LIBS *= -lodbc32
+@@ -93,7 +93,7 @@
+ HEADERS += drivers/ibase/qsql_ibase.h
+ SOURCES += drivers/ibase/qsql_ibase.cpp
+
+- unix:LIBS *= -lgds
++ unix:LIBS *= -lfbclient
+
+ win32 {
+ !win32-borland:LIBS *= -lgds32_ms
+--- a/src/plugins/sqldrivers/ibase/ibase.pro
++++ b/src/plugins/sqldrivers/ibase/ibase.pro
+@@ -4,7 +4,7 @@
+ SOURCES = main.cpp \
+ ../../../sql/drivers/ibase/qsql_ibase.cpp
+
+-unix:!contains( LIBS, .*gds.* ):!contains( LIBS, .*libfb.* ):LIBS *= -lgds
++unix:!contains( LIBS, .*gds.* ):!contains( LIBS, .*libfb.* ):LIBS *= -lfbclient
+
+ win32:!contains( LIBS, .*gds.* ):!contains( LIBS, .*fbclient.* ) {
+ !win32-borland:LIBS *= -lgds32_ms
diff --git a/debian/patches/series b/debian/patches/series
index 353d03f..7dff4ff 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -27,6 +27,8 @@
06_qtdemo_destdir.diff
07_trust_dpkg-arch_over_uname-m.diff
08_load_ssl.diff
+09_qmake_lflags_as-needed.diff
+10_config_tests_fixes.diff
20_mips_atomic_ops.diff
#21_assume_no_fpu_for_embedded_devices.diff
30_arm_ftbfs_fixes.diff
diff --git a/debian/rules b/debian/rules
index 2571a15..b44478f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,8 +2,6 @@
export QTDIR := $(shell pwd)
export PATH := $(QTDIR)/bin:$(PATH)
-export LD_LIBRARY_PATH := $(QTDIR)/lib:$(LD_LIBRARY_PATH)
-export LDFLAGS := -Wl,--no-undefined -Wl,--as-needed
QTVERSION := $(shell ls changes-* | cut -f2 -d '-')
CURRENTVERSION := $(shell head -1 debian/changelog | sed 's/[^(]*(\([^)]*\)).*/\1/')
@@ -27,6 +25,8 @@ DEB_DH_MAKESHLIBS_ARGS_ALL := -V
DEB_DH_STRIP_ARGS_libqt4-debug := --exclude=.debug
+DEB_DH_SHLIBDEPS_ARGS_ALL := --exclude=.debug
+
DEB_INSTALL_CHANGELOGS_ALL := changes-$(QTVERSION)
DEB_INSTALL_DOCS_ALL := GPL_EXCEPTION_ADDENDUM.TXT
@@ -35,8 +35,6 @@ ifeq ($(DEB_HOST_ARCH),arm)
EXTRA_CONFIGURE_OPTS += -DQT_QLOCALE_USES_FCVT
endif
-DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-Wl,--no-undefined -Wl,--as-needed"
-
ifeq ($(DEB_HOST_ARCH_OS),linux)
PLATFORM_ARG = linux-g++
else
@@ -77,6 +75,7 @@ endif
-fast \
-no-rpath \
-system-zlib \
+ -system-libtiff \
-system-libpng \
-system-libjpeg \
-system-nas-sound \
@@ -90,7 +89,6 @@ endif
-lfontconfig \
-cups \
-no-exceptions \
- -debug \
-qdbus \
-pch \
-nomake examples \
@@ -130,12 +128,15 @@ clean::
# generate on build
rm -f debian/shlibs.local
-PKGCONFIGDIR := $(DEB_DESTDIR)/usr/lib/pkgconfig
common-install-arch::
# Fix wrong path in pkgconfig files
- for f in QtAssistantClient.pc QtDBus.pc QtTest.pc QtUiTools.pc; do \
- sed -i "s|-L/build/buildd/qt4-x11-$(QTVERSION)/lib||g" $(PKGCONFIGDIR)/$$f; \
- done
+ find $(DEB_DESTDIR)/usr/lib/pkgconfig -type f -name '*.pc' \
+ -exec perl -pi -e "s, -L$(CURDIR)/?\S+,,g" {} \;
+# Fix wrong path in prl files
+ find $(DEB_DESTDIR)/usr/lib -type f -name '*.prl' \
+ -exec perl -pi -e "s, -L$(CURDIR)/\S+,,g" {} \;
+ find $(DEB_DESTDIR)/usr/lib -type f -name '*.prl' \
+ -exec sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" {} \;
install/libqt4-core::
$(CURDIR)/bin/lrelease-qt4 debian/translations/qt_ca.ts \